summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-18 10:54:01 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-18 10:54:01 +0000
commit407ef888a47aae00ce92ae392d96c0bbce4ff8a8 (patch)
tree4c24a6ebc49de8fb1443b49149a6fa11c42e1f2c /app-accessibility/orca
parentInitial import from bug 207985, thanks to Troy Bowman <troy@dublan.net>. (diff)
downloadgentoo-2-407ef888a47aae00ce92ae392d96c0bbce4ff8a8.tar.gz
gentoo-2-407ef888a47aae00ce92ae392d96c0bbce4ff8a8.tar.bz2
gentoo-2-407ef888a47aae00ce92ae392d96c0bbce4ff8a8.zip
fix python eclass use, bug #207667
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/ChangeLog5
-rw-r--r--app-accessibility/orca/orca-2.20.3.ebuild24
2 files changed, 26 insertions, 3 deletions
diff --git a/app-accessibility/orca/ChangeLog b/app-accessibility/orca/ChangeLog
index 1e4850acfef2..4ecd0c141f4f 100644
--- a/app-accessibility/orca/ChangeLog
+++ b/app-accessibility/orca/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-accessibility/orca
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.34 2008/02/04 04:59:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.35 2008/02/18 10:54:01 eva Exp $
+
+ 18 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org> orca-2.20.3.ebuild:
+ fix python eclass use, bug #207667
04 Feb 2008; Jeroen Roovers <jer@gentoo.org> orca-2.20.3.ebuild:
Stable for HPPA (bug #208366).
diff --git a/app-accessibility/orca/orca-2.20.3.ebuild b/app-accessibility/orca/orca-2.20.3.ebuild
index 77c1fdc1c7a5..28ee8c968a27 100644
--- a/app-accessibility/orca/orca-2.20.3.ebuild
+++ b/app-accessibility/orca/orca-2.20.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-2.20.3.ebuild,v 1.7 2008/02/04 04:59:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-2.20.3.ebuild,v 1.8 2008/02/18 10:54:01 eva Exp $
-inherit gnome2
+inherit gnome2 python
DESCRIPTION="Extensible screen reader that provides access to the desktop"
HOMEPAGE="http://www.gnome.org/projects/orca/"
@@ -27,3 +27,23 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/orca
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_version
+ python_mod_cleanup
+}