summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-06-15 21:12:04 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-06-15 21:12:04 +0000
commit2a916fb55f3e3b9c727e04022ca46f3c02a4ecd4 (patch)
treeb0dcbc098309f63b51439d467fb2f0589e1e7a89 /app-accessibility
parentversion bump for bug 273714 by Holger Hoffstätte <holger DOT hoffstaette AT ... (diff)
downloadgentoo-2-2a916fb55f3e3b9c727e04022ca46f3c02a4ecd4.tar.gz
gentoo-2-2a916fb55f3e3b9c727e04022ca46f3c02a4ecd4.tar.bz2
gentoo-2-2a916fb55f3e3b9c727e04022ca46f3c02a4ecd4.zip
nfbtrans should now build with glibc-2.10.
This fixes bug #274243. (Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/nfbtrans/ChangeLog9
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch40
-rw-r--r--app-accessibility/nfbtrans/nfbtrans-7.74.ebuild3
3 files changed, 49 insertions, 3 deletions
diff --git a/app-accessibility/nfbtrans/ChangeLog b/app-accessibility/nfbtrans/ChangeLog
index 047c73a04a5d..64d7d76cb59a 100644
--- a/app-accessibility/nfbtrans/ChangeLog
+++ b/app-accessibility/nfbtrans/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/nfbtrans
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/nfbtrans/ChangeLog,v 1.13 2009/01/10 17:44:39 williamh Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/nfbtrans/ChangeLog,v 1.14 2009/06/15 21:12:04 williamh Exp $
+
+ 15 Jun 2009; William Hubbs <williamh@gentoo.org> nfbtrans-7.74.ebuild,
+ +files/nfbtrans-7.74-getline-fix.patch:
+ nfbtrans should now build with glibc-2.10.
+ This fixes bug #274243.
10 Jan 2009; William Hubbs <williamh@gentoo.org> nfbtrans-7.74.ebuild:
I removed virtual/libc from depend and set rdepend correctly. The SRC_URI
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch
new file mode 100644
index 000000000000..14c13c063246
--- /dev/null
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch
@@ -0,0 +1,40 @@
+diff --git a/nfbtrans.c.orig b/nfbtrans.c
+index e697393..9a2944e 100644
+--- a/nfbtrans.c.orig
++++ b/nfbtrans.c
+@@ -534,7 +534,7 @@ void compact_line(char *);
+ void length_error(char *);
+ void do_lop_op(foptype *);
+ void do_lop(void);
+-void getline(void);
++void nfbtrans_getline(void);
+ void get_input(char *, int);
+ int get_paragraph_type(int);
+ void check_purge(void);
+@@ -2585,7 +2585,7 @@ void do_lop()
+ }
+ } /* do_lop */
+
+-void getline()
++void nfbtrans_getline()
+ {
+ int i = -1;
+ for (;;)
+@@ -2722,7 +2722,7 @@ int get_paragraph_type(int mode)
+ total_lines = 0;
+ do
+ {
+- getline();
++ nfbtrans_getline();
+ if (linein[0])
+ { /* line not empty */
+ if (prev_char == '\0')
+@@ -2874,7 +2874,7 @@ void get_word()
+ } /* head */
+ else
+ header_flag = 0;
+- getline();
++ nfbtrans_getline();
+ if (remove_page_nums)
+ remove_page_number();
+ if (auto_center)
diff --git a/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild b/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild
index 98fdf0a74002..9603f13a8edb 100644
--- a/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild
+++ b/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild,v 1.7 2009/01/10 17:44:39 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild,v 1.8 2009/06/15 21:12:04 williamh Exp $
inherit eutils
@@ -24,6 +24,7 @@ src_unpack() {
mv SPANISH.ZIP spanish.zip
make lowercase || die
epatch "${FILESDIR}"/${P}-gentoo-fix.patch
+ epatch "${FILESDIR}"/${P}-getline-fix.patch
}
src_compile() {