summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2013-12-11 01:20:33 +0000
committerChristopher Brannon <teiresias@gentoo.org>2013-12-11 01:20:33 +0000
commit44911e10ba6b480c46d121f37c31eae8b7ac734d (patch)
tree783e70d6a84fb96d9bca9fb034d08a4c2885eb7a /app-accessibility
parentSecurity cleanup wrt bug 462458 (diff)
downloadgentoo-2-44911e10ba6b480c46d121f37c31eae8b7ac734d.tar.gz
gentoo-2-44911e10ba6b480c46d121f37c31eae8b7ac734d.tar.bz2
gentoo-2-44911e10ba6b480c46d121f37c31eae8b7ac734d.zip
Upgrade and bug fixes.
Add ebuild for emacspeak 39.0. Move servers/ out of /usr/share, since it can contain ELF files (closes bug #298012). Remove the /usr/bin/emacspeak script downstream, since it is known to be broken. Emacspeak's author consistently recommends against its use. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/emacspeak/ChangeLog12
-rw-r--r--app-accessibility/emacspeak/emacspeak-39.0.ebuild76
-rw-r--r--app-accessibility/emacspeak/emacspeak-9999.ebuild16
3 files changed, 102 insertions, 2 deletions
diff --git a/app-accessibility/emacspeak/ChangeLog b/app-accessibility/emacspeak/ChangeLog
index f8bc75024734..3025d637035b 100644
--- a/app-accessibility/emacspeak/ChangeLog
+++ b/app-accessibility/emacspeak/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-accessibility/emacspeak
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/ChangeLog,v 1.48 2013/07/09 02:25:08 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/ChangeLog,v 1.49 2013/12/11 01:20:32 teiresias Exp $
+
+*emacspeak-39.0 (11 Dec 2013)
+
+ 11 Dec 2013; Christopher Brannon <teiresias@gentoo.org>
+ +emacspeak-39.0.ebuild, emacspeak-9999.ebuild:
+ Add ebuild for emacspeak 39.0.
+ Move servers/ out of /usr/share, since it can contain ELF files
+ (closes bug #298012).
+ Remove the /usr/bin/emacspeak script downstream, since it is known to
+ be broken.
*emacspeak-38.0 (09 Jul 2013)
diff --git a/app-accessibility/emacspeak/emacspeak-39.0.ebuild b/app-accessibility/emacspeak/emacspeak-39.0.ebuild
new file mode 100644
index 000000000000..8d285f10c484
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-39.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-39.0.ebuild,v 1.1 2013/12/11 01:20:32 teiresias Exp $
+
+EAPI=5
+
+inherit eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk"
+ inherit subversion
+else
+ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+DESCRIPTION="the emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="+espeak"
+
+DEPEND=">=virtual/emacs-22
+ espeak? ( app-accessibility/espeak )"
+
+RDEPEND="${DEPEND}
+ >=dev-tcltk/tclx-8.4"
+
+src_prepare() {
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_configure() {
+ emake config
+}
+
+src_compile() {
+ emake emacspeak
+ if use espeak; then
+ local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+ if [[ -z $tcl_version ]]; then
+ die 'Unable to detect the installed version of dev-lang/tcl.'
+ fi
+ cd servers/linux-espeak
+ emake TCL_VERSION="${tcl_version}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${D}/usr/bin/emacspeak"
+ if use espeak; then
+ pushd servers/linux-espeak > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
+ fi
+ install -dm755 "${D}/usr/$(get_libdir)/emacspeak" || die
+ mv "${D}/usr/share/emacs/site-lisp/emacspeak/servers" \
+ "${D}/usr/$(get_libdir)/emacspeak/servers" || die
+ dosym "/usr/$(get_libdir)/emacspeak/servers" \
+ /usr/share/emacs/site-lisp/emacspeak/servers
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+ cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
+ user-guide || die
+}
+
+pkg_postinst() {
+ elog "As of version 39.0 and later, the /usr/bin/emacspeak"
+ elog "shell script has been removed downstream in Gentoo."
+ elog "You should launch emacspeak by another method, for instance"
+ elog " by adding the following to your ~/.emacs file:"
+ elog '(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")'
+}
diff --git a/app-accessibility/emacspeak/emacspeak-9999.ebuild b/app-accessibility/emacspeak/emacspeak-9999.ebuild
index 6f55decd9357..7b8b3bda3df0 100644
--- a/app-accessibility/emacspeak/emacspeak-9999.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-9999.ebuild,v 1.6 2013/07/09 02:25:08 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-9999.ebuild,v 1.7 2013/12/11 01:20:33 teiresias Exp $
EAPI=5
@@ -49,14 +49,28 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install
+ rm "${D}/usr/bin/emacspeak"
if use espeak; then
pushd servers/linux-espeak > /dev/null || die
emake DESTDIR="${D}" install
popd > /dev/null || die
fi
+ install -dm755 "${D}/usr/$(get_libdir)/emacspeak" || die
+ mv "${D}/usr/share/emacs/site-lisp/emacspeak/servers" \
+ "${D}/usr/$(get_libdir)/emacspeak/servers" || die
+ dosym "/usr/$(get_libdir)/emacspeak/servers" \
+ /usr/share/emacs/site-lisp/emacspeak/servers
dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
dohtml -r install-guide user-guide
cd "${D}/usr/share/emacs/site-lisp/${PN}"
rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
user-guide || die
}
+
+pkg_postinst() {
+ elog "As of version 39.0 and later, the /usr/bin/emacspeak"
+ elog "shell script has been removed downstream in Gentoo."
+ elog "You should launch emacspeak by another method, for instance"
+ elog " by adding the following to your ~/.emacs file:"
+ elog '(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")'
+}