summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-12-03 20:43:20 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-12-03 20:43:20 +0000
commit99d3e805d414fbed3aeb58c028359062bce281c5 (patch)
tree16908213967c3098f453185ff61fad54b49d9381 /app-accessibility
parentMarking mpg123-1.9.2 ppc64 for bug 294106 (diff)
downloadgentoo-2-99d3e805d414fbed3aeb58c028359062bce281c5.tar.gz
gentoo-2-99d3e805d414fbed3aeb58c028359062bce281c5.tar.bz2
gentoo-2-99d3e805d414fbed3aeb58c028359062bce281c5.zip
synced live ebuild with 3.1.1-r1
(Portage version: 2.2_rc55/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speakup/ChangeLog5
-rw-r--r--app-accessibility/speakup/speakup-9999.ebuild54
2 files changed, 32 insertions, 27 deletions
diff --git a/app-accessibility/speakup/ChangeLog b/app-accessibility/speakup/ChangeLog
index 745338a98331..5b1041eec07c 100644
--- a/app-accessibility/speakup/ChangeLog
+++ b/app-accessibility/speakup/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-accessibility/speakup
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.37 2009/10/25 18:54:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.38 2009/12/03 20:43:20 williamh Exp $
+
+ 03 Dec 2009; William Hubbs <williamh@gentoo.org> speakup-9999.ebuild:
+ synced live ebuild with 3.1.1-r1
*speakup-3.1.3-r1 (25 Oct 2009)
diff --git a/app-accessibility/speakup/speakup-9999.ebuild b/app-accessibility/speakup/speakup-9999.ebuild
index b843ffa5591f..14a6598412fe 100644
--- a/app-accessibility/speakup/speakup-9999.ebuild
+++ b/app-accessibility/speakup/speakup-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/speakup-9999.ebuild,v 1.2 2009/08/19 22:40:45 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/speakup-9999.ebuild,v 1.3 2009/12/03 20:43:20 williamh Exp $
EAPI="2"
@@ -14,56 +14,58 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="modules"
+
+MODULE_NAMES="speakup(${PN}:\"${S}\"/src)
+ speakup_acntpc(${PN}:\"${S}\"/src)
+ speakup_acntsa(${PN}:\"${S}\"/src)
+ speakup_apollo(${PN}:\"${S}\"/src)
+ speakup_audptr(${PN}:\"${S}\"/src)
+ speakup_bns(${PN}:\"${S}\"/src)
+ speakup_decext(${PN}:\"${S}\"/src)
+ speakup_decpc(${PN}:\"${S}\"/src)
+ speakup_dectlk(${PN}:\"${S}\"/src)
+ speakup_dtlk(${PN}:\"${S}\"/src)
+ speakup_dummy(${PN}:\"${S}\"/src)
+ speakup_keypc(${PN}:\"${S}\"/src)
+ speakup_ltlk(${PN}:\"${S}\"/src)
+ speakup_soft(${PN}:\"${S}\"/src)
+ speakup_spkout(${PN}:\"${S}\"/src)
+ speakup_txprt(${PN}:\"${S}\"/src)"
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+BUILD_TARGETS="clean all"
src_prepare() {
+ use modules && cmd=die || cmd=ewarn
case ${KV_EXTRA} in
*gentoo)
if kernel_is lt 2 6 25; then
- die "Speakup requires at least gentoo-sources-2.6.25"
+ $cmd "Speakup requires at least gentoo-sources-2.6.25"
fi
;;
*)
if kernel_is lt 2 6 26; then
- die "Speakup requires at least kernel version2.6.26"
+ $cmd "Speakup requires at least kernel version 2.6.26"
fi
;;
esac
}
src_compile() {
- MODULE_NAMES="speakup(${PN}:\"${S}\"/src)
- speakup_acntpc(${PN}:\"${S}\"/src)
- speakup_acntsa(${PN}:\"${S}\"/src)
- speakup_apollo(${PN}:\"${S}\"/src)
- speakup_audptr(${PN}:\"${S}\"/src)
- speakup_bns(${PN}:\"${S}\"/src)
- speakup_decext(${PN}:\"${S}\"/src)
- speakup_decpc(${PN}:\"${S}\"/src)
- speakup_dectlk(${PN}:\"${S}\"/src)
- speakup_dtlk(${PN}:\"${S}\"/src)
- speakup_dummy(${PN}:\"${S}\"/src)
- speakup_keypc(${PN}:\"${S}\"/src)
- speakup_ltlk(${PN}:\"${S}\"/src)
- speakup_soft(${PN}:\"${S}\"/src)
- speakup_spkout(${PN}:\"${S}\"/src)
- speakup_txprt(${PN}:\"${S}\"/src)"
- BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
- BUILD_TARGETS="clean all"
- linux-mod_src_compile
+ use modules && linux-mod_src_compile
}
src_install() {
- linux-mod_src_install
+ use modules && linux-mod_src_install
dobin tools/speakupconf
dosbin tools/talkwith
dodoc Bugs.txt README To-Do doc/DefaultKeyAssignments doc/spkguide.txt
- doman man/*
newdoc tools/README README.tools
}
pkg_postinst() {
- linux-mod_pkg_postinst
+ use modules && linux-mod_pkg_postinst
+
elog "You must set up the speech synthesizer driver to be loaded"
elog "automatically in order for your system to start speaking"
elog "when it is booted."