summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-05-18 13:52:14 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-05-18 13:52:14 +0000
commitf16a635abc562dc857cebd05d5804613d5974c1f (patch)
tree554e700996442ee372ccbc15450ee2c02ed26a99 /app-accessibility
parentRemove old. (diff)
downloadgentoo-2-f16a635abc562dc857cebd05d5804613d5974c1f.tar.gz
gentoo-2-f16a635abc562dc857cebd05d5804613d5974c1f.tar.bz2
gentoo-2-f16a635abc562dc857cebd05d5804613d5974c1f.zip
Removed old versions.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeak/ChangeLog6
-rw-r--r--app-accessibility/espeak/espeak-1.39.ebuild79
-rw-r--r--app-accessibility/espeak/espeak-1.40.01.ebuild77
3 files changed, 5 insertions, 157 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index 0ee8935e7f6d..e0387f442dde 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.74 2009/05/15 16:54:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.75 2009/05/18 13:52:14 williamh Exp $
+
+ 18 May 2009; William Hubbs <williamh@gentoo.org> -espeak-1.39.ebuild,
+ -espeak-1.40.01.ebuild:
+ Removed old versions.
15 May 2009; Raúl Porcel <armin76@gentoo.org> espeak-1.40.02.ebuild:
ia64/sparc stable wrt #265910
diff --git a/app-accessibility/espeak/espeak-1.39.ebuild b/app-accessibility/espeak/espeak-1.39.ebuild
deleted file mode 100644
index e34a145f5eed..000000000000
--- a/app-accessibility/espeak/espeak-1.39.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.39.ebuild,v 1.8 2009/03/09 11:42:26 flameeyes Exp $
-
-inherit eutils
-
-MY_P="${P}-source"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-DESCRIPTION="Speech synthesizer for English and other languages"
-HOMEPAGE="http://espeak.sourceforge.net/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="portaudio pulseaudio"
-DEPEND="portaudio? ( >=media-libs/portaudio-18.1-r5 )
- pulseaudio? ( media-sound/pulseaudio )
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-get_audio() {
- local MY_AUDIO
-
- MY_AUDIO=none
- if use portaudio; then
- MY_AUDIO=portaudio
- elif use pulseaudio; then
- MY_AUDIO=pulseaudio
- fi
- echo ${MY_AUDIO}
-}
-
-pkg_setup() {
- if ! use portaudio && ! use pulseaudio; then
- ewarn
- ewarn Since portaudio and pulseaudio are not in your use flags,
- ewarn espeak will only be able to create wav files.
- ewarn If this is not what you want, press ctrl-c and put either
- ewarn portaudio or pulseaudio in your use flags.
- ebeep
- epause 10
- elif use portaudio && use pulseaudio; then
- die "You must choose either portaudio or pulseaudio, but not both."
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # portaudio.h is by default the same as portaudio18.h, but use the version
- # 19 API if available
- if use portaudio; then
- if has_version "=media-libs/portaudio-19*" ; then
- mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
- fi
- fi
-}
-
-src_compile() {
- cd src
- emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
-
- einfo "Fixing byte order of phoneme data files"
- cd "${S}/platforms/big_endian"
- make
- ./espeak-phoneme-data "${S}/espeak-data"
- cp -f phondata phonindex phontab "${S}/espeak-data"
-}
-
-src_install() {
- cd src
- make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
-
- cd ..
- insinto /usr/share/espeak-data
- doins -r dictsource
- dodoc ChangeLog ReadMe
- dohtml -r docs/*
-}
diff --git a/app-accessibility/espeak/espeak-1.40.01.ebuild b/app-accessibility/espeak/espeak-1.40.01.ebuild
deleted file mode 100644
index 630387b172f6..000000000000
--- a/app-accessibility/espeak/espeak-1.40.01.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.40.01.ebuild,v 1.3 2009/03/09 11:42:26 flameeyes Exp $
-
-inherit eutils
-
-MY_P="${P}-source"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-DESCRIPTION="Speech synthesizer for English and other languages"
-HOMEPAGE="http://espeak.sourceforge.net/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="portaudio pulseaudio"
-DEPEND="app-arch/unzip
- portaudio? ( >=media-libs/portaudio-19_pre20071207 )
- pulseaudio? ( media-sound/pulseaudio )"
-
-S=${WORKDIR}/${MY_P}
-
-get_audio() {
- local MY_AUDIO
-
- MY_AUDIO=none
- if use portaudio; then
- MY_AUDIO=portaudio
- elif use pulseaudio; then
- MY_AUDIO=pulseaudio
- fi
- echo ${MY_AUDIO}
-}
-
-pkg_setup() {
- if ! use portaudio && ! use pulseaudio; then
- ewarn
- ewarn Since portaudio and pulseaudio are not in your use flags,
- ewarn espeak will only be able to create wav files.
- ewarn If this is not what you want, press ctrl-c and put either
- ewarn portaudio or pulseaudio in your use flags.
- ebeep
- epause 10
- elif use portaudio && use pulseaudio; then
- die "You must choose either portaudio or pulseaudio, but not both."
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # portaudio.h is by default the same as portaudio18.h, but we only have
- # portaudio 19.
- if use portaudio; then
- mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
- fi
-}
-
-src_compile() {
- cd src
- emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
-
- einfo "Fixing byte order of phoneme data files"
- cd "${S}/platforms/big_endian"
- make
- ./espeak-phoneme-data "${S}/espeak-data"
- cp -f phondata phonindex phontab "${S}/espeak-data"
-}
-
-src_install() {
- cd src
- make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
-
- cd ..
- insinto /usr/share/espeak-data
- doins -r dictsource
- dodoc ChangeLog ReadMe
- dohtml -r docs/*
-}