summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2007-06-04 05:17:27 +0000
committerWilliam Hubbs <williamh@gentoo.org>2007-06-04 05:17:27 +0000
commitfc1db106f119cacc23c8664c6f2c8973e1405f58 (patch)
treec8b1896ea089b6c4f4b6aa808f9d26b596bad2e8 /app-accessibility
parentVersion bump; thanks to affinity and Ali Polatel. (bug #175878). (diff)
downloadgentoo-2-fc1db106f119cacc23c8664c6f2c8973e1405f58.tar.gz
gentoo-2-fc1db106f119cacc23c8664c6f2c8973e1405f58.tar.bz2
gentoo-2-fc1db106f119cacc23c8664c6f2c8973e1405f58.zip
This closes #180312.
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog9
-rw-r--r--app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.6.2-r13
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-espeak-generic.patch11
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2-r1.ebuild48
4 files changed, 70 insertions, 1 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index d5f772b27841..6815c741dc5a 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.22 2007/05/28 19:29:05 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.23 2007/06/04 05:17:27 williamh Exp $
+
+*speech-dispatcher-0.6.2-r1 (04 Jun 2007)
+
+ 04 Jun 2007; William Hubbs <williamh@gentoo.org>
+ +files/speech-dispatcher-0.6.2-espeak-generic.patch,
+ +speech-dispatcher-0.6.2-r1.ebuild:
+ This rev bump closes #180312.
*speech-dispatcher-0.6.2 (28 May 2007)
diff --git a/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.6.2-r1 b/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.6.2-r1
new file mode 100644
index 000000000000..5491ffa6267e
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.6.2-r1
@@ -0,0 +1,3 @@
+MD5 e8a1d8f5f5a1899f87af4dd3ef9722c8 speech-dispatcher-0.6.2.tar.gz 974300
+RMD160 d0c30282d525c184bc1376e2fa39fd193d133c5f speech-dispatcher-0.6.2.tar.gz 974300
+SHA256 3db16854d65755a76c180271e65a6a29a43cd1f4e5d5eb3ea33b17b0ca58c4ae speech-dispatcher-0.6.2.tar.gz 974300
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-espeak-generic.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-espeak-generic.patch
new file mode 100644
index 000000000000..445209e826f8
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-espeak-generic.patch
@@ -0,0 +1,11 @@
+--- speech-dispatcher-0.6.2/config/modules/espeak-generic.conf 2007-06-03 20:57:00.000000000 -0500
++++ speech-dispatcher-0.6.2/config/modules/espeak-generic.conf 2007-06-03 21:00:32.000000000 -0500
+@@ -20,7 +20,7 @@
+ # can modify this value, see other parameters).
+ # The command can be split into more lines, if necessary, using '\'.
+ GenericExecuteSynth \
+-"echo \"$DATA\" | espeak -w /tmp/espeak.wav -v $VOICE -s $RATE -a $VOLUME -p $PITCH --stdin && aplay /tmp/espeak.wav"
++"echo \"$DATA\" | espeak -w /tmp/espeak.wav -v $VOICE -s $RATE -a 100 -p $PITCH --stdin && aplay /tmp/espeak.wav"
+
+ # GenericStripPunctChars is a list (enclosed in doublequotes) of
+ # all the characters that should be replaced by whitespaces in
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2-r1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..0570152ff82b
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2-r1.ebuild,v 1.1 2007/06/04 05:17:27 williamh Exp $
+
+inherit eutils
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-accessibility/espeak
+ dev-libs/dotconf
+ >=dev-libs/glib-2
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-espeak.patch
+ epatch ${FILESDIR}/${P}-espeak-generic.patch
+ epatch ${FILESDIR}/${P}-python.patch
+}
+
+src_compile() {
+ econf || die "configure failed"
+ make all || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ newinitd ${FILESDIR}/speech-dispatcher speech-dispatcher
+
+ dodoc AUTHORS ChangeLog NEWS TODO
+
+ insinto /usr/include
+ doins ${S}/src/c/api/libspeechd.h
+}
+
+pkg_postinst() {
+ elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+}