summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-02-22 21:26:03 +0000
committerJeroen Roovers <jer@gentoo.org>2012-02-22 21:26:03 +0000
commitfc6bfcf4543c7da59b80ddbed0a708c9518422a2 (patch)
treeb644a17397b4358c2283bfb03324e5ad47081cae /app-accessibility
parentVersion bump (bug #405283). (diff)
downloadgentoo-2-fc6bfcf4543c7da59b80ddbed0a708c9518422a2.tar.gz
gentoo-2-fc6bfcf4543c7da59b80ddbed0a708c9518422a2.tar.bz2
gentoo-2-fc6bfcf4543c7da59b80ddbed0a708c9518422a2.zip
Add patch by Christopher Brannon to respect LDFLAGS (bug #334031). Fix -rpath directory (bug #405339). Remove static libraries in case LIBDIR is not /usr/lib/.
(Portage version: 2.2.0_alpha88/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/flite/ChangeLog10
-rw-r--r--app-accessibility/flite/files/flite-1.4-ldflags.patch12
-rw-r--r--app-accessibility/flite/flite-1.4-r1.ebuild10
3 files changed, 27 insertions, 5 deletions
diff --git a/app-accessibility/flite/ChangeLog b/app-accessibility/flite/ChangeLog
index 1083a2de5e18..ef2c38c727b2 100644
--- a/app-accessibility/flite/ChangeLog
+++ b/app-accessibility/flite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/flite
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/ChangeLog,v 1.38 2010/02/28 23:14:49 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/ChangeLog,v 1.39 2012/02/22 21:26:03 jer Exp $
+
+ 22 Feb 2012; Jeroen Roovers <jer@gentoo.org> flite-1.4-r1.ebuild,
+ +files/flite-1.4-ldflags.patch:
+ Add patch by Christopher Brannon to respect LDFLAGS (bug #334031). Fix -rpath
+ directory (bug #405339). Remove static libraries in case LIBDIR is not
+ /usr/lib/.
28 Feb 2010; Jeroen Roovers <jer@gentoo.org> flite-1.3.ebuild:
Segfaults on HPPA, keywording -hppa (bug #307241).
diff --git a/app-accessibility/flite/files/flite-1.4-ldflags.patch b/app-accessibility/flite/files/flite-1.4-ldflags.patch
new file mode 100644
index 000000000000..f805f57508c1
--- /dev/null
+++ b/app-accessibility/flite/files/flite-1.4-ldflags.patch
@@ -0,0 +1,12 @@
+diff -Naur flite-1.4-release/config/common_make_rules flite-1.4-release.new/config/common_make_rules
+--- flite-1.4-release/config/common_make_rules 2009-07-30 14:52:56.000000000 +0000
++++ flite-1.4-release.new/config/common_make_rules 2011-03-26 20:22:59.000000000 +0000
+@@ -123,7 +123,7 @@
+ @ rm -rf shared_os && mkdir shared_os
+ @ rm -f $@ $@.${PROJECT_VERSION} $@.${PROJECT_SHLIB_VERSION}
+ @ (cd shared_os && ar x ../$<)
+- @ (cd shared_os && $(CC) -shared -Wl,-soname,`basename $@`.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os)
++ @ (cd shared_os && $(CC) $(LDFLAGS) -shared -Wl,-soname,`basename $@`.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os)
+ @ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_VERSION}` `basename $@.${PROJECT_SHLIB_VERSION}` )
+ @ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_SHLIB_VERSION}` `basename $@` )
+ @ rm -rf shared_os
diff --git a/app-accessibility/flite/flite-1.4-r1.ebuild b/app-accessibility/flite/flite-1.4-r1.ebuild
index a0a2c741b0d1..c344f0550de6 100644
--- a/app-accessibility/flite/flite-1.4-r1.ebuild
+++ b/app-accessibility/flite/flite-1.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.4-r1.ebuild,v 1.1 2010/01/01 22:30:51 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.4-r1.ebuild,v 1.2 2012/02/22 21:26:03 jer Exp $
EAPI="2"
@@ -30,6 +30,10 @@ get_audio() {
src_prepare() {
epatch "${FILESDIR}"/${P}-fix-parallel-builds.patch
epatch "${FILESDIR}"/${P}-respect-destdir.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ sed -i main/Makefile \
+ -e '/-rpath/s|$(LIBDIR)|$(INSTALLLIBDIR)|g' \
+ || die
}
src_configure() {
@@ -49,7 +53,7 @@ src_install() {
emake DESTDIR="${D}" install || die "installation failed"
dodoc ACKNOWLEDGEMENTS README || die "Documentation installation failed"
if ! use static-libs; then
- rm -rf "${D}"/usr/lib/*.a
+ rm -rf "${D}"/usr/lib*/*.a
fi
}