summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-09-15 08:55:22 +0000
committerPeter Volkov <pva@gentoo.org>2011-09-15 08:55:22 +0000
commit6cba907ceb33ebd93850a2765c6580a530bb4447 (patch)
tree7e8aa6d4de3a5f52058cdfd351d07445218fb0d2 /app-admin/apache-tools
parentRemove old. (diff)
downloadgentoo-2-6cba907ceb33ebd93850a2765c6580a530bb4447.tar.gz
gentoo-2-6cba907ceb33ebd93850a2765c6580a530bb4447.tar.bz2
gentoo-2-6cba907ceb33ebd93850a2765c6580a530bb4447.zip
Version bump, bug #382971 wrt Agostino Sarubbo.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/apache-tools')
-rw-r--r--app-admin/apache-tools/ChangeLog8
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.21.ebuild88
-rw-r--r--app-admin/apache-tools/metadata.xml3
3 files changed, 98 insertions, 1 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index 2ce175a6d3a4..f967d7e7a808 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.98 2011/09/03 13:31:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.99 2011/09/15 08:55:22 pva Exp $
+
+*apache-tools-2.2.21 (15 Sep 2011)
+
+ 15 Sep 2011; Peter Volkov <pva@gentoo.org> +apache-tools-2.2.21.ebuild,
+ metadata.xml:
+ Version bump, bug #382971 wrt Agostino Sarubbo.
03 Sep 2011; Raúl Porcel <armin76@gentoo.org> apache-tools-2.2.20.ebuild:
arm/ia64/s390/sh/sparc/x86 stable wrt #380475
diff --git a/app-admin/apache-tools/apache-tools-2.2.21.ebuild b/app-admin/apache-tools/apache-tools-2.2.21.ebuild
new file mode 100644
index 000000000000..798e60660354
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.21.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.21.ebuild,v 1.1 2011/09/15 08:55:22 pva Exp $
+
+EAPI="4"
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_prepare() {
+ # Apply these patches:
+ # (1) apache-tools-2.2.20-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-2.2.20-Makefile.patch
+}
+
+src_configure() {
+ local myconf=""
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ use ssl && myconf+=" --with-ssl=/usr --enable-ssl"
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf}
+}
+
+src_compile() {
+ cd support || die
+ emake
+}
+
+src_install () {
+ cd support || die
+
+ make DESTDIR="${D}" install
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${D}"/usr/sbin/ >/dev/null
+ for i in *; do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+ popd "${D}"/usr/sbin/ >/dev/null
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}
diff --git a/app-admin/apache-tools/metadata.xml b/app-admin/apache-tools/metadata.xml
index ace24ac6e456..4d46b240afd5 100644
--- a/app-admin/apache-tools/metadata.xml
+++ b/app-admin/apache-tools/metadata.xml
@@ -5,6 +5,9 @@
<maintainer>
<email>apache-bugs@gentoo.org</email>
</maintainer>
+ <maintainer>
+ <email>pva@gentoo.org</email>
+ </maintainer>
<longdescription lang="en">
app-admin/apache-tools contains tools that might be useful without
having apache itself installed (like htdigest/htpasswd, but also ab -