summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-03-25 23:38:05 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-03-25 23:38:05 +0000
commit8b4c390c9cec9840dab222538f316aebf0880ecf (patch)
tree3e8b7e446a46cf8371faa74a5582142f9cf28227 /app-admin/apg/apg-2.3.0b-r2.ebuild
parentWith permission of the maintainer ebuild from bug #121532 added. (diff)
downloadgentoo-2-8b4c390c9cec9840dab222538f316aebf0880ecf.tar.gz
gentoo-2-8b4c390c9cec9840dab222538f316aebf0880ecf.tar.bz2
gentoo-2-8b4c390c9cec9840dab222538f316aebf0880ecf.zip
* closing bug #126995
(Portage version: 2.1_pre7)
Diffstat (limited to 'app-admin/apg/apg-2.3.0b-r2.ebuild')
-rw-r--r--app-admin/apg/apg-2.3.0b-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/apg/apg-2.3.0b-r2.ebuild b/app-admin/apg/apg-2.3.0b-r2.ebuild
new file mode 100644
index 000000000000..69b40a064140
--- /dev/null
+++ b/app-admin/apg/apg-2.3.0b-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apg/apg-2.3.0b-r2.ebuild,v 1.1 2006/03/25 23:38:05 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Another Password Generator"
+HOMEPAGE="http://www.adel.nursat.kz/apg/"
+SRC_URI="http://www.adel.nursat.kz/apg/download/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="cracklib"
+
+DEPEND="virtual/libc
+ cracklib? ( sys-libs/cracklib )"
+
+src_unpack() {
+ unpack ${A}
+ chmod -R +w ${S}
+ cd ${S}
+ if use cracklib; then
+ epatch ${FILESDIR}/${P}-cracklib.patch
+ epatch ${FILESDIR}/${PN}-glibc-2.4.patch
+ fi
+}
+
+src_compile() {
+ sed -i 's,^#\(APG_CS_CLIBS += -lnsl\)$,\1,' Makefile
+
+ emake standalone || die "compile problem"
+ emake -C bfconvert || die "compile problem"
+}
+
+src_install() {
+ dobin apg apgbfm bfconvert/bfconvert || die
+ dodoc CHANGES INSTALL README THANKS TODO
+ cd doc
+ doman man/apg.1 man/apgbfm.1
+ dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt
+}