summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-07-20 00:07:35 +0000
committerChuck Short <zul@gentoo.org>2004-07-20 00:07:35 +0000
commit4fbe84c65f0dad7f10765efe387ad3086dabb305 (patch)
tree072c6a5982c36faed486116902157e2c815870c0 /app-admin/bacula
parentNew ebuild for linuxtrade, ncurses-based realtime quote tracker, submitted by... (diff)
downloadgentoo-2-4fbe84c65f0dad7f10765efe387ad3086dabb305.tar.gz
gentoo-2-4fbe84c65f0dad7f10765efe387ad3086dabb305.tar.bz2
gentoo-2-4fbe84c65f0dad7f10765efe387ad3086dabb305.zip
Fixed wxwindows support, fixed client support.
Diffstat (limited to 'app-admin/bacula')
-rw-r--r--app-admin/bacula/ChangeLog6
-rw-r--r--app-admin/bacula/bacula-1.34.5.ebuild16
2 files changed, 16 insertions, 6 deletions
diff --git a/app-admin/bacula/ChangeLog b/app-admin/bacula/ChangeLog
index 3e2900735f1c..1dd9b13b650d 100644
--- a/app-admin/bacula/ChangeLog
+++ b/app-admin/bacula/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/bacula
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.34 2004/06/29 19:19:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.35 2004/07/20 00:07:35 zul Exp $
+
+ 21 Jul 2004; Chuck Short <zul@gentoo.org> bacula-1.34.5.ebuild:
+ Fixed wxwindows support. Closes #57350.
+ Fixed client support. Closes #57302.
29 Jun 2004; Aron Griffis <agriffis@gentoo.org> bacula-1.34.1.ebuild:
sync IUSE (-postgres)
diff --git a/app-admin/bacula/bacula-1.34.5.ebuild b/app-admin/bacula/bacula-1.34.5.ebuild
index 3f3e24a73623..cdeb2db10f16 100644
--- a/app-admin/bacula/bacula-1.34.5.ebuild
+++ b/app-admin/bacula/bacula-1.34.5.ebuild
@@ -21,6 +21,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
mysql? ( >=dev-db/mysql-3.23 )
postgres? ( >=dev-db/postgresql-7.4.0 )
X? ( virtual/x11 )
+ wxwindows? ( >=x11-libs/wxGTK-2.4.2 )
virtual/mta
dev-libs/gmp"
RDEPEND="${DEPEND}
@@ -38,11 +39,10 @@ src_compile() {
`use_enable readline`
`use_enable gnome`
`use_enable tcpd tcp-wrappers`
- `use_enable X x`
- `use_enable wxwindows wx-console`
- "
- #not ./configure'able
- #`use_enable ssl`
+ `use_enable X x`"
+
+ [ -n "$BUILD_CLIENT_ONLY" ] \
+ && myconf="${myconf} --enable-client-only"
# mysql is the reccomended choice ...
if use mysql
@@ -59,6 +59,12 @@ src_compile() {
myconf="${myconf/--with-sqlite/}"
fi
+ if use wxwindows
+ then
+ myconf="${myconf} --enable-wx-console"
+ fi
+
+
./configure \
--enable-smartalloc \
--prefix=/usr \