summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-24 16:01:24 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-24 16:01:24 +0000
commit623f17f6da095be65bbd6e84e7c635f2ad805811 (patch)
treecd647d3bd0f066a174886fc6b4e75a1e8de278e7 /app-admin/collectd
parentMarked ~x86-solaris, bug #296509 (diff)
downloadgentoo-2-623f17f6da095be65bbd6e84e7c635f2ad805811.tar.gz
gentoo-2-623f17f6da095be65bbd6e84e7c635f2ad805811.tar.bz2
gentoo-2-623f17f6da095be65bbd6e84e7c635f2ad805811.zip
Properly address the libtool / eautoreconf problem
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/collectd')
-rw-r--r--app-admin/collectd/ChangeLog7
-rw-r--r--app-admin/collectd/collectd-4.10.3.ebuild6
-rw-r--r--app-admin/collectd/collectd-5.0.0.ebuild6
-rw-r--r--app-admin/collectd/files/collectd-4.10.3-lt.patch31
4 files changed, 43 insertions, 7 deletions
diff --git a/app-admin/collectd/ChangeLog b/app-admin/collectd/ChangeLog
index 042fce99bb74..b3f60f1b7461 100644
--- a/app-admin/collectd/ChangeLog
+++ b/app-admin/collectd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/collectd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/collectd/ChangeLog,v 1.18 2011/04/24 15:15:23 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/collectd/ChangeLog,v 1.19 2011/04/24 16:01:24 dilfridge Exp $
+
+ 24 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ collectd-4.10.3.ebuild, +files/collectd-4.10.3-lt.patch,
+ collectd-5.0.0.ebuild:
+ Properly address the libtool / eautoreconf problem
*collectd-5.0.0 (24 Apr 2011)
diff --git a/app-admin/collectd/collectd-4.10.3.ebuild b/app-admin/collectd/collectd-4.10.3.ebuild
index 77d9b1a86a3a..28f76037532f 100644
--- a/app-admin/collectd/collectd-4.10.3.ebuild
+++ b/app-admin/collectd/collectd-4.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/collectd/collectd-4.10.3.ebuild,v 1.2 2011/03/30 20:30:37 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/collectd/collectd-4.10.3.ebuild,v 1.3 2011/04/24 16:01:24 dilfridge Exp $
EAPI=3
@@ -102,6 +102,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-4.10.1"-{libperl,libiptc,noowniptc}.patch
"${FILESDIR}/${PN}-4.10.2"-{libocci,libnotify-0.7,nohal}.patch
+ "${FILESDIR}/${PN}-4.10.3"-lt.patch
)
# @FUNCTION: collectd_plugin_kernel_linux
@@ -193,8 +194,7 @@ src_prepare() {
# paths like "/usr/var/..."
sed -i -e "s:@prefix@/var:/var:g" src/collectd.conf.in || die
- # the tarball of 4.10.3 was generated with a different set of autotools, leading to odd problems
- _elibtoolize --ltdl
+ rm -r libltdl || die
eautoreconf
}
diff --git a/app-admin/collectd/collectd-5.0.0.ebuild b/app-admin/collectd/collectd-5.0.0.ebuild
index ea869a363e35..bd5f421eaa2d 100644
--- a/app-admin/collectd/collectd-5.0.0.ebuild
+++ b/app-admin/collectd/collectd-5.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/collectd/collectd-5.0.0.ebuild,v 1.1 2011/04/24 15:15:23 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/collectd/collectd-5.0.0.ebuild,v 1.2 2011/04/24 16:01:24 dilfridge Exp $
EAPI=4
@@ -102,6 +102,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-4.10.1"-{libperl,libiptc,noowniptc}.patch
"${FILESDIR}/${PN}-4.10.2"-{libocci,libnotify-0.7,nohal}.patch
+ "${FILESDIR}/${PN}-4.10.3"-lt.patch
)
# @FUNCTION: collectd_plugin_kernel_linux
@@ -193,8 +194,7 @@ src_prepare() {
# paths like "/usr/var/..."
sed -i -e "s:@prefix@/var:/var:g" src/collectd.conf.in || die
- # the tarball of 4.10.3 and 5.0.0 was generated with a different set of autotools, leading to odd problems
- _elibtoolize --ltdl
+ rm -r libltdl || die
eautoreconf
}
diff --git a/app-admin/collectd/files/collectd-4.10.3-lt.patch b/app-admin/collectd/files/collectd-4.10.3-lt.patch
new file mode 100644
index 000000000000..68cba1589381
--- /dev/null
+++ b/app-admin/collectd/files/collectd-4.10.3-lt.patch
@@ -0,0 +1,31 @@
+diff -ruN collectd-4.10.3.orig/Makefile.am collectd-4.10.3/Makefile.am
+--- collectd-4.10.3.orig/Makefile.am 2011-03-26 17:04:26.000000000 +0100
++++ collectd-4.10.3/Makefile.am 2011-04-24 17:48:18.013229944 +0200
+@@ -1,6 +1,6 @@
+-ACLOCAL_AMFLAGS = -I libltdl/m4
++# ACLOCAL_AMFLAGS = -I libltdl/m4
+
+-SUBDIRS = libltdl src bindings
++SUBDIRS = src bindings
+
+ INCLUDES = $(LTDLINCL)
+
+diff -ruN collectd-4.10.3.orig/configure.in collectd-4.10.3/configure.in
+--- collectd-4.10.3.orig/configure.in 2011-03-26 17:08:53.000000000 +0100
++++ collectd-4.10.3/configure.in 2011-04-24 17:50:06.001229943 +0200
+@@ -6,7 +6,6 @@
+ m4_ifdef([LT_PACKAGE_VERSION],
+ # libtool >= 2.2
+ [
+- LT_CONFIG_LTDL_DIR([libltdl])
+ LT_INIT([dlopen])
+ LTDL_INIT([convenience])
+ AC_DEFINE(LIBTOOL_VERSION, 2, [Define to used libtool version.])
+@@ -18,7 +17,6 @@
+ AC_SUBST(LTDLINCL)
+ AC_SUBST(LIBLTDL)
+ AC_LIBTOOL_DLOPEN
+- AC_CONFIG_SUBDIRS(libltdl)
+ AC_DEFINE(LIBTOOL_VERSION, 1, [Define to used libtool version.])
+ ]
+ )