summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2007-01-12 15:23:09 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2007-01-12 15:23:09 +0000
commitb2cc67cab2c6a65c1c0f7cb0c60b1a8f2357e4ab (patch)
treebdf947f19791fcfb7ef7a04e3b73984197bb5626 /app-admin/consolehm/consolehm-1.31.ebuild
parentAdded g-wrap-1.9.7.ebuild (diff)
downloadgentoo-2-b2cc67cab2c6a65c1c0f7cb0c60b1a8f2357e4ab.tar.gz
gentoo-2-b2cc67cab2c6a65c1c0f7cb0c60b1a8f2357e4ab.tar.bz2
gentoo-2-b2cc67cab2c6a65c1c0f7cb0c60b1a8f2357e4ab.zip
New ebuild, Gentoo/FreeBSD only.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'app-admin/consolehm/consolehm-1.31.ebuild')
-rw-r--r--app-admin/consolehm/consolehm-1.31.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/consolehm/consolehm-1.31.ebuild b/app-admin/consolehm/consolehm-1.31.ebuild
new file mode 100644
index 000000000000..35b2ed309f5c
--- /dev/null
+++ b/app-admin/consolehm/consolehm-1.31.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/consolehm/consolehm-1.31.ebuild,v 1.1 2007/01/12 15:23:09 the_paya Exp $
+
+inherit eutils
+
+DESCRIPTION="Console based hardware monitor for FreeBSD"
+HOMEPAGE="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/fenner/"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/fenner/${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~x86-fbsd"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PN}-gcc4.patch || die "patch failed"
+ export CHMS="${S}/consolehm"
+ # The only 'SMBus' smb.h i've found is in a different place:
+ cd "${S}/consolehm"
+ sed -i.orig -e 's:machine/smb.h:dev/smbus/smb.h:g' \
+ configure.in \
+ configure \
+ chm.h || die "sed failed."
+}
+
+src_compile() {
+ cd "${S}/consolehm"
+ econf || die "econf failed"
+ MAKE=make emake || die "emake failed"
+}
+
+src_install() {
+ dobin "${S}/consolehm/chm"
+ doman "${S}/consolehm/chm.8"
+ dodoc ${S}/CHANGELOG
+ dodoc ${S}/README
+ dodoc ${S}/TODO
+}