summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-04 04:34:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-04 04:34:12 +0000
commit905d52ffe04f95863a7b4448dd39ef72bd608d01 (patch)
tree4bb6e02ecfb047a7e24524962c79a83a2463fb96 /app-admin/cpu
parentfix bug 37061 (diff)
downloadgentoo-2-905d52ffe04f95863a7b4448dd39ef72bd608d01.tar.gz
gentoo-2-905d52ffe04f95863a7b4448dd39ef72bd608d01.tar.bz2
gentoo-2-905d52ffe04f95863a7b4448dd39ef72bd608d01.zip
fix bug 37061
Diffstat (limited to 'app-admin/cpu')
-rw-r--r--app-admin/cpu/ChangeLog10
-rw-r--r--app-admin/cpu/Manifest8
-rw-r--r--app-admin/cpu/cpu-1.4.2-r1.ebuild42
-rw-r--r--app-admin/cpu/cpu-1.4.2.ebuild10
-rw-r--r--app-admin/cpu/files/digest-cpu-1.4.2-r11
5 files changed, 58 insertions, 13 deletions
diff --git a/app-admin/cpu/ChangeLog b/app-admin/cpu/ChangeLog
index 653434fe9e35..33c841153616 100644
--- a/app-admin/cpu/ChangeLog
+++ b/app-admin/cpu/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for app-admin/cpu
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/ChangeLog,v 1.5 2003/10/27 10:17:30 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/ChangeLog,v 1.6 2004/01/04 04:34:04 robbat2 Exp $
+
+*cpu-1.4.2-r1 (03 Jan 2004)
+
+ 03 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> cpu-1.4.2-r1.ebuild,
+ cpu-1.4.2.ebuild:
+ fix bug 37061
*cpu-1.4.2 (27 Oct 2003)
- 27 Oct 2003; root <root@gentoo.org> cpu-1.3.100-r1.ebuild,
+ 27 Oct 2003; Aliz <aliz@gentoo.org> cpu-1.3.100-r1.ebuild,
cpu-1.3.100.ebuild, cpu-1.4.2.ebuild:
Version bump and unmasks.
diff --git a/app-admin/cpu/Manifest b/app-admin/cpu/Manifest
index 78429a60df26..12d2b6ad64b8 100644
--- a/app-admin/cpu/Manifest
+++ b/app-admin/cpu/Manifest
@@ -1,9 +1,9 @@
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/Manifest,v 1.12 2004/01/04 04:34:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/Manifest,v 1.13 2004/01/04 04:34:12 robbat2 Exp $
MD5 4c7c7fae8f3f6ecdef12667a81294539 cpu-1.3.100.ebuild 1353
-MD5 a5484820ba687175d16af17b1d88353b cpu-1.4.2-r1.ebuild 1166
+MD5 c460fe0693fdbe1b14d329fccbff7c65 cpu-1.4.2-r1.ebuild 1172
MD5 b31fa3612c8d110211213e67dae38ae3 cpu-1.3.100-r1.ebuild 1327
-MD5 a5484820ba687175d16af17b1d88353b cpu-1.4.2.ebuild 1166
-MD5 de6470afa56ff3a17e4fbe84df134d17 ChangeLog 1048
+MD5 fd8b31e961322c8f65744bab5125eb36 cpu-1.4.2.ebuild 1169
+MD5 ed811b1029a3789066fe1a5490410e86 ChangeLog 1051
MD5 021b5afd2ac0d086a3400da75c9ce5db files/digest-cpu-1.3.100 64
MD5 5e8365fbe120902788e48f72e1e18ae9 files/digest-cpu-1.4.2-r1 62
MD5 021b5afd2ac0d086a3400da75c9ce5db files/digest-cpu-1.3.100-r1 64
diff --git a/app-admin/cpu/cpu-1.4.2-r1.ebuild b/app-admin/cpu/cpu-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..c24f8447838d
--- /dev/null
+++ b/app-admin/cpu/cpu-1.4.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.4.2-r1.ebuild,v 1.1 2004/01/04 04:34:05 robbat2 Exp $
+
+DESCRIPTION="LDAP user management tool written in C and loosely based on FreeBSD's pw(8)"
+HOMEPAGE="http://cpu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cpu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="net-nds/openldap
+ sys-libs/cracklib"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.54"
+
+WANT_AUTOCONF_2_5=1
+
+src_compile() {
+ local myconf
+
+ # provide PASSWD support as well
+ # It's broken in the application at the moment, so lets not...
+ # myconf="${myconf} --with-passwd"
+
+ # Tell it where to find LDAP
+ myconf="${myconf} --with-ldap"
+ # Tell it where to find CRACKLIB
+ myconf="${myconf} --with-libcrack"
+
+ # This app really belongs in sbin!
+ myconf="${myconf} --bindir=/usr/sbin"
+
+ econf ${myconf} || die "Configure failure"
+ emake || die "Make failure"
+}
+
+src_install() {
+ einstall bindir="${D}/usr/sbin" datadir="${D}/usr/share/doc/${PF}" || die "Einstall failure"
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
diff --git a/app-admin/cpu/cpu-1.4.2.ebuild b/app-admin/cpu/cpu-1.4.2.ebuild
index 893ed4f59c85..879c88271a21 100644
--- a/app-admin/cpu/cpu-1.4.2.ebuild
+++ b/app-admin/cpu/cpu-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.4.2.ebuild,v 1.1 2003/10/27 10:17:30 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.4.2.ebuild,v 1.2 2004/01/04 04:34:05 robbat2 Exp $
DESCRIPTION="LDAP user management tool written in C and loosely based on FreeBSD's pw(8)"
HOMEPAGE="http://cpu.sourceforge.net/"
@@ -8,7 +8,7 @@ SRC_URI="mirror://sourceforge/cpu/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
RDEPEND="net-nds/openldap
sys-libs/cracklib"
@@ -29,18 +29,14 @@ src_compile() {
# Tell it where to find CRACKLIB
myconf="${myconf} --with-libcrack"
- # cache our config!
- #myconf="${myconf} --cache-file=${S}/config.cache"
-
# This app really belongs in sbin!
myconf="${myconf} --bindir=/usr/sbin"
econf ${myconf} || die "Configure failure"
-
emake || die "Make failure"
}
src_install() {
- einstall bindir="${D}/usr/sbin" || die "Einstall failure"
+ einstall bindir="${D}/usr/sbin" datadir="${D}/usr/share/doc/${PF}" || die "Einstall failure"
dodoc AUTHORS COPYING ChangeLog NEWS README TODO
}
diff --git a/app-admin/cpu/files/digest-cpu-1.4.2-r1 b/app-admin/cpu/files/digest-cpu-1.4.2-r1
new file mode 100644
index 000000000000..f78ee1d0b987
--- /dev/null
+++ b/app-admin/cpu/files/digest-cpu-1.4.2-r1
@@ -0,0 +1 @@
+MD5 24b00d725b1470448253367d8ef34c89 cpu-1.4.2.tar.bz2 250421