summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2014-03-20 17:19:31 +0000
committerMichael Orlitzky <mjo@gentoo.org>2014-03-20 17:19:31 +0000
commit89aa7d172624a62a90273426b39ec06df3e61467 (patch)
tree274f4af287f72617ccc524d98fa199a042b470f4 /app-admin/drush
parentUpdate sys-apps/gentoo-functions dependency for prefix. (diff)
downloadgentoo-2-89aa7d172624a62a90273426b39ec06df3e61467.tar.gz
gentoo-2-89aa7d172624a62a90273426b39ec06df3e61467.tar.bz2
gentoo-2-89aa7d172624a62a90273426b39ec06df3e61467.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x6F48D3DA05C2DADB!)
Diffstat (limited to 'app-admin/drush')
-rw-r--r--app-admin/drush/ChangeLog9
-rw-r--r--app-admin/drush/drush-6.2.0.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/app-admin/drush/ChangeLog b/app-admin/drush/ChangeLog
index 54f9c1ac33ef..6586e6fd696d 100644
--- a/app-admin/drush/ChangeLog
+++ b/app-admin/drush/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/drush
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/ChangeLog,v 1.8 2013/12/23 16:04:31 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/ChangeLog,v 1.9 2014/03/20 17:19:31 mjo Exp $
+
+*drush-6.2.0 (20 Mar 2014)
+
+ 20 Mar 2014; Michael Orlitzky <mjo@gentoo.org> +drush-6.2.0.ebuild:
+ Version bump.
23 Dec 2013; Pacho Ramos <pacho@gentoo.org> drush-5.8.ebuild:
Add missing dependency, bug #482382 by Michael Orlitzky
diff --git a/app-admin/drush/drush-6.2.0.ebuild b/app-admin/drush/drush-6.2.0.ebuild
new file mode 100644
index 000000000000..8e5ade318a07
--- /dev/null
+++ b/app-admin/drush/drush-6.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/drush-6.2.0.ebuild,v 1.1 2014/03/20 17:19:31 mjo Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command line shell and scripting interface for Drupal"
+HOMEPAGE="https://github.com/drush-ops/${PN}"
+SRC_URI="https://github.com/drush-ops/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples"
+
+DEPEND=""
+RDEPEND="dev-lang/php[cli,ctype,json,simplexml]
+ dev-php/PEAR-Console_Table"
+
+src_prepare() {
+ # dodoc compresses all of the documentation, so we fix the filenames
+ # in a few places.
+
+ # First, the README location in bootstrap.inc.
+ sed -i -e \
+ "s!/share/doc/drush!/share/doc/${PF}!" \
+ -e "s!README\.md!\0.bz2!g" \
+ includes/bootstrap.inc || die
+
+ # Next, the list of documentation in docs.drush.inc. Note that
+ # html files don't get compressed.
+ sed -i \
+ -e "s!\.bashrc'!.bashrc.bz2'!" \
+ -e "s!\.ini'!.ini.bz2'!" \
+ -e "s!\.md'!.md.bz2'!" \
+ -e "s!\.php'!.php.bz2'!" \
+ -e "s!\.script'!.script.bz2'!" \
+ -e "s!\.txt'!.txt.bz2'!" \
+ commands/core/docs.drush.inc || die
+}
+
+src_install() {
+ local docs="README.md docs"
+ use examples && docs="${docs} examples"
+ dodoc -r ${docs}
+
+ insinto /usr/share/drush
+ doins -r classes commands includes lib misc
+ doins drush_logo-black.png drush.info drush.php
+
+ exeinto /usr/share/drush
+ doexe drush
+ dosym /usr/share/drush/drush /usr/bin/drush
+
+ keepdir /etc/drush
+ newbashcomp drush.complete.sh drush
+}