summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-12-10 17:45:14 +0000
committerMike Gilbert <floppym@gentoo.org>2013-12-10 17:45:14 +0000
commitaed655231a78faf835a868f5c7280638f2af46ce (patch)
treeaa98f0154c39e171bbedee91dd588877471a852a /app-admin/eselect-python
parentsci-physics/root: Merge changes from sci overlay (diff)
downloadgentoo-2-aed655231a78faf835a868f5c7280638f2af46ce.tar.gz
gentoo-2-aed655231a78faf835a868f5c7280638f2af46ce.tar.bz2
gentoo-2-aed655231a78faf835a868f5c7280638f2af46ce.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-admin/eselect-python')
-rw-r--r--app-admin/eselect-python/ChangeLog8
-rw-r--r--app-admin/eselect-python/eselect-python-20131210.ebuild53
-rw-r--r--app-admin/eselect-python/eselect-python-99999999.ebuild9
3 files changed, 65 insertions, 5 deletions
diff --git a/app-admin/eselect-python/ChangeLog b/app-admin/eselect-python/ChangeLog
index 9e08a124fea1..d66eb7bff190 100644
--- a/app-admin/eselect-python/ChangeLog
+++ b/app-admin/eselect-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.78 2013/04/13 20:50:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.79 2013/12/10 17:45:14 floppym Exp $
+
+*eselect-python-20131210 (10 Dec 2013)
+
+ 10 Dec 2013; Mike Gilbert <floppym@gentoo.org>
+ +eselect-python-20131210.ebuild, eselect-python-99999999.ebuild:
+ Version bump.
13 Apr 2013; Agostino Sarubbo <ago@gentoo.org> eselect-python-20111108.ebuild:
Stable for s390, wrt bug #462644
diff --git a/app-admin/eselect-python/eselect-python-20131210.ebuild b/app-admin/eselect-python/eselect-python-20131210.ebuild
new file mode 100644
index 000000000000..dce287a28a92
--- /dev/null
+++ b/app-admin/eselect-python/eselect-python-20131210.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20131210.ebuild,v 1.1 2013/12/10 17:45:14 floppym Exp $
+
+# Keep the EAPI low here because everything else depends on it.
+# We want to make upgrading simpler.
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+# Avoid autotool deps for released versions for circ dep issues.
+if [[ ${PV} == "99999999" ]] ; then
+ DEPEND="sys-devel/autoconf"
+else
+ DEPEND=""
+fi
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ cd "${S}"
+ eautoreconf
+ else
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ local ret=0
+ ebegin "Running 'eselect python update'"
+ eselect python update --python2 --if-unset || ret=1
+ eselect python update --python3 --if-unset || ret=1
+ eend ${ret}
+}
diff --git a/app-admin/eselect-python/eselect-python-99999999.ebuild b/app-admin/eselect-python/eselect-python-99999999.ebuild
index 7a210211a6af..b6c890d96bf1 100644
--- a/app-admin/eselect-python/eselect-python-99999999.ebuild
+++ b/app-admin/eselect-python/eselect-python-99999999.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-99999999.ebuild,v 1.9 2013/03/22 03:25:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-99999999.ebuild,v 1.10 2013/12/10 17:45:14 floppym Exp $
# Keep the EAPI low here because everything else depends on it.
# We want to make upgrading simpler.
if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/${PN}.git"
- inherit autotools git-2
else
- SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
fi
@@ -30,7 +31,7 @@ fi
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
- git-2_src_unpack
+ git-r3_src_unpack
cd "${S}"
eautoreconf
else