summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-25 16:17:35 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-25 16:17:35 +0000
commitbba49051560afa6d84cd82bb6abbe8adcb5696e1 (patch)
tree893f5e17e144ac29d34a5a24861c5a98e16da969 /app-admin/gam-server
parentVersion bump. All BSD and Interix beywords dropped because of new dependency ... (diff)
downloadgentoo-2-bba49051560afa6d84cd82bb6abbe8adcb5696e1.tar.gz
gentoo-2-bba49051560afa6d84cd82bb6abbe8adcb5696e1.tar.bz2
gentoo-2-bba49051560afa6d84cd82bb6abbe8adcb5696e1.zip
Fix compilation with latest glib, bug #382783 by Maciej Piechotka; fix crosscompilation issues, bug #267604 by Andrei Slavoiu; enable linux specific features on armel, upstream bug #588338; drop DG_DISABLE_DEPRECATED; don't try to even check for python, simplifying ebuild for people running python3 as main interpreter; use gnome.org eclass to set SRC_URI and use bz2 tarball instead of gz.
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/gam-server')
-rw-r--r--app-admin/gam-server/ChangeLog13
-rw-r--r--app-admin/gam-server/files/gam-server-0.1.10-G_CONST_RETURN-removal.patch67
-rw-r--r--app-admin/gam-server/files/gam-server-0.1.10-armel-features.patch47
-rw-r--r--app-admin/gam-server/files/gam-server-0.1.10-crosscompile-fix.patch38
-rw-r--r--app-admin/gam-server/gam-server-0.1.10.ebuild42
5 files changed, 189 insertions, 18 deletions
diff --git a/app-admin/gam-server/ChangeLog b/app-admin/gam-server/ChangeLog
index d8fbd9b3c306..00a4b679a13d 100644
--- a/app-admin/gam-server/ChangeLog
+++ b/app-admin/gam-server/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-admin/gam-server
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gam-server/ChangeLog,v 1.10 2011/07/11 04:25:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gam-server/ChangeLog,v 1.11 2011/09/25 16:17:35 pacho Exp $
+
+ 25 Sep 2011; Pacho Ramos <pacho@gentoo.org> gam-server-0.1.10.ebuild,
+ +files/gam-server-0.1.10-G_CONST_RETURN-removal.patch,
+ +files/gam-server-0.1.10-armel-features.patch,
+ +files/gam-server-0.1.10-crosscompile-fix.patch:
+ Fix compilation with latest glib, bug #382783 by Maciej Piechotka; fix
+ crosscompilation issues, bug #267604 by Andrei Slavoiu; enable linux specific
+ features on armel, upstream bug #588338; drop DG_DISABLE_DEPRECATED; don't
+ try to even check for python, simplifying ebuild for people running python3
+ as main interpreter; use gnome.org eclass to set SRC_URI and use bz2 tarball
+ instead of gz.
11 Jul 2011; Samuli Suominen <ssuominen@gentoo.org> gam-server-0.1.10.ebuild:
Stop depending on dev-util/pkgconfig wrt #374775 by dragos240
diff --git a/app-admin/gam-server/files/gam-server-0.1.10-G_CONST_RETURN-removal.patch b/app-admin/gam-server/files/gam-server-0.1.10-G_CONST_RETURN-removal.patch
new file mode 100644
index 000000000000..087312f5baae
--- /dev/null
+++ b/app-admin/gam-server/files/gam-server-0.1.10-G_CONST_RETURN-removal.patch
@@ -0,0 +1,67 @@
+From 2a9d32734a2e5125ae77de6c75789e1c6ee24dbe Mon Sep 17 00:00:00 2001
+From: Maciej Piechotka <uzytkownik2@gmail.com>
+Date: Tue, 13 Sep 2011 09:47:05 +0200
+Subject: [PATCH] Fix compilation of recent glib removing G_CONST_RETURN
+
+---
+ server/gam_node.c | 2 +-
+ server/gam_node.h | 2 +-
+ server/gam_subscription.c | 2 +-
+ server/gam_subscription.h | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/server/gam_node.c b/server/gam_node.c
+index 02358ba..d0302d2 100644
+--- a/server/gam_node.c
++++ b/server/gam_node.c
+@@ -122,7 +122,7 @@ gam_node_set_is_dir(GamNode * node, gboolean is_dir)
+ * it has finished with the string. If it must keep it longer, it
+ * should makes its own copy. The returned string must not be freed.
+ */
+-G_CONST_RETURN char *
++const char *
+ gam_node_get_path(GamNode * node)
+ {
+ g_assert(node);
+diff --git a/server/gam_node.h b/server/gam_node.h
+index 02c8692..83349a8 100644
+--- a/server/gam_node.h
++++ b/server/gam_node.h
+@@ -58,7 +58,7 @@ gboolean gam_node_is_dir (GamNode *node);
+ void gam_node_set_is_dir (GamNode *node,
+ gboolean is_dir);
+
+-G_CONST_RETURN char *gam_node_get_path (GamNode *node);
++const char *gam_node_get_path (GamNode *node);
+
+ GList *gam_node_get_subscriptions (GamNode *node);
+
+diff --git a/server/gam_subscription.c b/server/gam_subscription.c
+index dfa3273..4675b34 100644
+--- a/server/gam_subscription.c
++++ b/server/gam_subscription.c
+@@ -141,7 +141,7 @@ gam_subscription_pathlen(GamSubscription * sub)
+ * @param sub the GamSubscription
+ * @returns The path being monitored. It should not be freed.
+ */
+-G_CONST_RETURN char *
++const char *
+ gam_subscription_get_path(GamSubscription * sub)
+ {
+ if (sub == NULL)
+diff --git a/server/gam_subscription.h b/server/gam_subscription.h
+index d894fbe..e6b4e15 100644
+--- a/server/gam_subscription.h
++++ b/server/gam_subscription.h
+@@ -21,7 +21,7 @@ int gam_subscription_pathlen (GamSubscription *sub);
+
+ int gam_subscription_get_reqno (GamSubscription *sub);
+
+-G_CONST_RETURN char *gam_subscription_get_path (GamSubscription *sub);
++const char *gam_subscription_get_path (GamSubscription *sub);
+
+ GamListener *gam_subscription_get_listener (GamSubscription *sub);
+
+--
+1.7.6.1
+
diff --git a/app-admin/gam-server/files/gam-server-0.1.10-armel-features.patch b/app-admin/gam-server/files/gam-server-0.1.10-armel-features.patch
new file mode 100644
index 000000000000..fdfcbd7e6db6
--- /dev/null
+++ b/app-admin/gam-server/files/gam-server-0.1.10-armel-features.patch
@@ -0,0 +1,47 @@
+From 05dcfcd69848e119c6a30d363bc41e896029f8af Mon Sep 17 00:00:00 2001
+From: Sebastian Dröge <slomo@debian.org>
+Date: Tue, 15 Dec 2009 12:24:25 +0000
+Subject: Bug 588338 - Enable linux specific features on armel
+
+---
+diff --git a/configure.in b/configure.in
+index b0bbaec..e4b684e 100644
+--- a/configure.in
++++ b/configure.in
+@@ -176,7 +176,7 @@ fi
+
+ dnl check what OS we're on
+ #AM_CONDITIONAL(HAVE_LINUX, test x$target_os = xlinux-gnu)
+-if test x$target_os = xlinux-gnu; then
++if test x$target_os = xlinux-gnu -o x$target_os = xlinux-gnueabi; then
+ AC_DEFINE([HAVE_LINUX],[],[Whether we are using linux or not])
+ fi
+
+@@ -223,7 +223,7 @@ fi
+ dnl check if inotify backend is enabled
+ AM_CONDITIONAL(ENABLE_INOTIFY, test x$inotify = xtrue)
+
+-if test x$os = xlinux-gnu; then
++if test x$os = xlinux-gnu -o x$os = xlinux-gnueabi; then
+ AC_ARG_ENABLE(dnotify,
+ AC_HELP_STRING([--disable-dnotify], [Disable the DNotify backend]),
+ [dnotify="${enableval}"], [dnotify=true])
+@@ -297,10 +297,12 @@ else
+ fi
+
+ dnl Use weak symbols on linux/gcc to avoid imposing libpthreads to apps
+-if test x$os = xlinux-gnu -a x$WITH_THREADS = x1 ; then
+- if test "${CC}" = "gcc" ; then
+- echo Use weak symbols !
+- THREAD_LIBS=
++if test x$os = xlinux-gnu -o x$os = xlinux-gnueabi ; then
++ if test x$WITH_THREADS = x1 ; then
++ if test "${CC}" = "gcc" ; then
++ echo Use weak symbols !
++ THREAD_LIBS=
++ fi
+ fi
+ fi
+ AC_SUBST(THREAD_LIBS)
+--
+cgit v0.9.0.2
diff --git a/app-admin/gam-server/files/gam-server-0.1.10-crosscompile-fix.patch b/app-admin/gam-server/files/gam-server-0.1.10-crosscompile-fix.patch
new file mode 100644
index 000000000000..ce3a15b5e160
--- /dev/null
+++ b/app-admin/gam-server/files/gam-server-0.1.10-crosscompile-fix.patch
@@ -0,0 +1,38 @@
+--- configure.in.orig 2009-04-26 23:00:43.445135823 +0300
++++ configure.in 2009-04-26 23:25:04.042489243 +0300
+@@ -389,8 +389,7 @@
+
+ AC_MSG_CHECKING(abstract socket namespace)
+ AC_LANG_PUSH(C)
+-AC_RUN_IFELSE([AC_LANG_PROGRAM(
+-[[
++AC_TRY_RUN([
+ #include <sys/types.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -398,8 +397,8 @@
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ #include <errno.h>
+-]],
+-[[
++
++int main() {
+ int listen_fd;
+ struct sockaddr_un addr;
+
+@@ -424,9 +423,11 @@
+ }
+ else
+ exit (0);
+-]])],
+- [have_abstract_sockets=yes],
+- [have_abstract_sockets=no])
++}
++],
++have_abstract_sockets=yes,
++have_abstract_sockets=no,
++have_abstract_sockets=no)
+ AC_LANG_POP(C)
+ AC_MSG_RESULT($have_abstract_sockets)
+
diff --git a/app-admin/gam-server/gam-server-0.1.10.ebuild b/app-admin/gam-server/gam-server-0.1.10.ebuild
index 73de1434b3c3..653a479c60ff 100644
--- a/app-admin/gam-server/gam-server-0.1.10.ebuild
+++ b/app-admin/gam-server/gam-server-0.1.10.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gam-server/gam-server-0.1.10.ebuild,v 1.10 2011/07/11 04:25:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gam-server/gam-server-0.1.10.ebuild,v 1.11 2011/09/25 16:17:35 pacho Exp $
-inherit autotools eutils flag-o-matic libtool multilib python
+EAPI="3"
+GNOME_ORG_MODULE="gamin"
-MY_PN="gamin"
-MY_P=${MY_PN}-${PV}
+inherit autotools eutils flag-o-matic libtool multilib python gnome.org
DESCRIPTION="Library providing the FAM File Alteration Monitor API"
HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
-SRC_URI="http://www.gnome.org/~veillard/${MY_PN}/sources/${MY_P}.tar.gz
- mirror://gentoo/${MY_PN}-0.1.9-freebsd.patch.bz2
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gamin-0.1.9-freebsd.patch.bz2
http://pkgconfig.freedesktop.org/releases/pkg-config-0.26.tar.gz" # pkg.m4 for eautoreconf
LICENSE="LGPL-2"
@@ -18,26 +18,35 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
IUSE="debug kernel_linux"
-RDEPEND=">=dev-libs/glib-2
+RDEPEND=">=dev-libs/glib-2:2
>=dev-libs/libgamin-0.1.10
!app-admin/fam
!<app-admin/gamin-0.1.10"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+#S=${WORKDIR}/${MY_P}
+src_prepare() {
mv -vf "${WORKDIR}"/pkg-config-*/pkg.m4 "${WORKDIR}"/ || die
# Fix compile warnings; bug #188923
- epatch "${DISTDIR}/${MY_PN}-0.1.9-freebsd.patch.bz2"
+ epatch "${DISTDIR}/gamin-0.1.9-freebsd.patch.bz2"
# Fix file-collision due to shared library, upstream bug #530635
- epatch "${FILESDIR}/${P}-noinst-lib.patch"
+ epatch "${FILESDIR}/${PN}-0.1.10-noinst-lib.patch"
+
+ # Fix compilation with latest glib, bug #382783
+ epatch "${FILESDIR}/${PN}-0.1.10-G_CONST_RETURN-removal.patch"
+
+ # Fix crosscompilation issues, bug #267604
+ epatch "${FILESDIR}/${PN}-0.1.10-crosscompile-fix.patch"
+
+ # Enable linux specific features on armel, upstream bug #588338
+ epatch "${FILESDIR}/${P}-armel-features.patch"
+
+ # Drop DEPRECATED flags
+ sed -i -e 's:-DG_DISABLE_DEPRECATED:$(NULL):g' server/Makefile.am || die
# autoconf is required as the user-cflags patch modifies configure.in
# however, elibtoolize is also required, so when the above patch is
@@ -45,7 +54,7 @@ src_unpack() {
AT_M4DIR="${WORKDIR}" eautoreconf
}
-src_compile() {
+src_configure() {
# fixes bug 225403
#append-flags "-D_GNU_SOURCE"
@@ -57,10 +66,9 @@ src_compile() {
econf \
--disable-debug \
--disable-libgamin \
+ --without-python \
$(use_enable kernel_linux inotify) \
$(use_enable debug debug-api)
-
- emake || die
}
src_install() {