summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-12-07 00:34:15 +0000
committerDaniel Drake <dsd@gentoo.org>2006-12-07 00:34:15 +0000
commitccd4160fd162ebc32b3a84d91dc922c6d32d12c9 (patch)
treeb26d5ba876c6b7d08ee1268b2a759cb22f6ea9e0 /app-admin/gamin
parentAdded pdf USE-flag. Otherwise gtk2 will not build due to insufficient cairo-... (diff)
downloadgentoo-2-ccd4160fd162ebc32b3a84d91dc922c6d32d12c9.tar.gz
gentoo-2-ccd4160fd162ebc32b3a84d91dc922c6d32d12c9.tar.bz2
gentoo-2-ccd4160fd162ebc32b3a84d91dc922c6d32d12c9.zip
Version bump thanks to Raymond Lewis Rebbeck in bug #157043
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'app-admin/gamin')
-rw-r--r--app-admin/gamin/ChangeLog7
-rw-r--r--app-admin/gamin/files/digest-gamin-0.1.83
-rw-r--r--app-admin/gamin/gamin-0.1.8.ebuild49
3 files changed, 58 insertions, 1 deletions
diff --git a/app-admin/gamin/ChangeLog b/app-admin/gamin/ChangeLog
index db627b08c0ce..6bca11f092a6 100644
--- a/app-admin/gamin/ChangeLog
+++ b/app-admin/gamin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/gamin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.52 2006/10/26 10:01:54 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.53 2006/12/07 00:34:15 dsd Exp $
+
+*gamin-0.1.8 (07 Dec 2006)
+
+ 07 Dec 2006; Daniel Drake <dsd@gentoo.org> +gamin-0.1.8.ebuild:
+ Version bump thanks to Raymond Lewis Rebbeck in bug #157043
26 Oct 2006; Roy Marples <uberlord@gentoo.org> gamin-0.1.7.ebuild:
Added ~sparc-fbsd keyword.
diff --git a/app-admin/gamin/files/digest-gamin-0.1.8 b/app-admin/gamin/files/digest-gamin-0.1.8
new file mode 100644
index 000000000000..c5c511693c18
--- /dev/null
+++ b/app-admin/gamin/files/digest-gamin-0.1.8
@@ -0,0 +1,3 @@
+MD5 985022c8b1b993e471d528fd0e14ffbe gamin-0.1.8.tar.gz 564530
+RMD160 3ad723480f840d67daedb9bc10a93b48ba34bc47 gamin-0.1.8.tar.gz 564530
+SHA256 be22f69b4797db510f4270ff0e228dd027e99e561ac5f5d38be595be7e82d203 gamin-0.1.8.tar.gz 564530
diff --git a/app-admin/gamin/gamin-0.1.8.ebuild b/app-admin/gamin/gamin-0.1.8.ebuild
new file mode 100644
index 000000000000..8034a6fb565b
--- /dev/null
+++ b/app-admin/gamin/gamin-0.1.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.8.ebuild,v 1.1 2006/12/07 00:34:15 dsd Exp $
+
+inherit autotools eutils libtool
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/gamin/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug doc"
+
+RDEPEND=">=dev-libs/glib-2
+ !app-admin/fam"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/fam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Do not remove
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable debug) \
+ $(use_enable debug debug-api) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
+ use doc && dohtml doc/*
+}
+