summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-11-25 23:41:48 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-11-25 23:41:48 +0000
commit33af1ec742ce7fae80902a62040d15e8bfb61715 (patch)
tree2a4645b5dc00d46c4f630085c28a715337e561f2 /app-admin/keepassx
parentstable sparc, bug 215651 (diff)
downloadgentoo-2-33af1ec742ce7fae80902a62040d15e8bfb61715.tar.gz
gentoo-2-33af1ec742ce7fae80902a62040d15e8bfb61715.tar.bz2
gentoo-2-33af1ec742ce7fae80902a62040d15e8bfb61715.zip
Version bump, ebuild QA fixes. Remove old.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'app-admin/keepassx')
-rw-r--r--app-admin/keepassx/ChangeLog8
-rw-r--r--app-admin/keepassx/keepassx-0.3.4.ebuild (renamed from app-admin/keepassx/keepassx-0.3.3.ebuild)19
2 files changed, 21 insertions, 6 deletions
diff --git a/app-admin/keepassx/ChangeLog b/app-admin/keepassx/ChangeLog
index 0e367d11ad04..afe6b4247ff5 100644
--- a/app-admin/keepassx/ChangeLog
+++ b/app-admin/keepassx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/keepassx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.32 2008/11/07 18:59:29 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.33 2008/11/25 23:41:48 tgurr Exp $
+
+*keepassx-0.3.4 (25 Nov 2008)
+
+ 25 Nov 2008; Timo Gurr <tgurr@gentoo.org> -keepassx-0.3.3.ebuild,
+ +keepassx-0.3.4.ebuild:
+ Version bump, ebuild QA fixes. Remove old.
07 Nov 2008; Timo Gurr <tgurr@gentoo.org> keepassx-0.3.3.ebuild:
Fix another qt check for monolithic qt.
diff --git a/app-admin/keepassx/keepassx-0.3.3.ebuild b/app-admin/keepassx/keepassx-0.3.4.ebuild
index 144ab01d1e2c..2f8d1667c59c 100644
--- a/app-admin/keepassx/keepassx-0.3.3.ebuild
+++ b/app-admin/keepassx/keepassx-0.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.3.ebuild,v 1.5 2008/11/07 18:59:29 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.4.ebuild,v 1.1 2008/11/25 23:41:48 tgurr Exp $
EAPI="2"
@@ -14,24 +14,33 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug"
-DEPEND="|| ( ( x11-libs/qt-core:4
- x11-libs/qt-gui:4
+DEPEND="|| ( ( x11-libs/qt-core:4[qt3support]
+ x11-libs/qt-gui:4[qt3support]
x11-libs/qt-xmlpatterns:4 )
( =x11-libs/qt-4.3*:4[png,qt3support,zlib] ) )"
RDEPEND="${DEPEND}"
-src_compile() {
+src_configure() {
+ # generate translations
cd "${S}/src"
lrelease src.pro || die "lrelease failed"
mv "${S}"/src/translations/*.qm "${S}"/share/keepassx/i18n
+
cd "${S}"
use debug && myconf="DEBUG=1"
eqmake4 ${PN}.pro PREFIX="${D}/usr" ${myconf} || die "eqmake4 failed"
- PATH=${PATH/\/usr\/lib\/distcc\/bin:} # workaround for bug #214327
+}
+
+src_compile(){
+ # workaround compile failure due to distcc, bug #214327
+ PATH=${PATH/\/usr\/lib\/distcc\/bin:}
emake || die "emake failed"
}
src_install(){
+ # workaround pre-stripping the keepassx binary during install, bug #248711
+ sed -i -e '/strip/d' "${S}"/src/Makefile || die "sed failed"
+
emake DESTDIR="${D}" install || die "emake install failed"
dodoc changelog todo || die "dodoc failed"
}