summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-10-11 23:33:10 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-10-11 23:33:10 +0000
commit83bd66fe24dc61b9c80c6badbf64621348b7ee7e (patch)
tree621271a1ca98ebaa565d5ca079edc19a9aef8ec1 /app-admin/logrotate
parentQA fixes; remove unnecessary setting of WANT_AUTOCONF to latest (diff)
downloadgentoo-2-83bd66fe24dc61b9c80c6badbf64621348b7ee7e.tar.gz
gentoo-2-83bd66fe24dc61b9c80c6badbf64621348b7ee7e.tar.bz2
gentoo-2-83bd66fe24dc61b9c80c6badbf64621348b7ee7e.zip
QA fixes; unquoted variables
(Portage version: 2.2_rc45/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/logrotate')
-rw-r--r--app-admin/logrotate/ChangeLog6
-rw-r--r--app-admin/logrotate/logrotate-3.7.1-r2.ebuild24
-rw-r--r--app-admin/logrotate/logrotate-3.7.2.ebuild10
-rw-r--r--app-admin/logrotate/logrotate-3.7.7.ebuild16
-rw-r--r--app-admin/logrotate/logrotate-3.7.8.ebuild14
5 files changed, 37 insertions, 33 deletions
diff --git a/app-admin/logrotate/ChangeLog b/app-admin/logrotate/ChangeLog
index 2abed00bf68e..867a22c887d1 100644
--- a/app-admin/logrotate/ChangeLog
+++ b/app-admin/logrotate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/logrotate
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.85 2009/07/02 19:36:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.86 2009/10/11 23:33:10 halcy0n Exp $
+
+ 11 Oct 2009; Mark Loeser <halcy0n@gentoo.org> logrotate-3.7.1-r2.ebuild,
+ logrotate-3.7.2.ebuild, logrotate-3.7.7.ebuild, logrotate-3.7.8.ebuild:
+ QA fixes; unquoted variables
02 Jul 2009; Markus Meier <maekke@gentoo.org> logrotate-3.7.8.ebuild:
amd64 stable, bug #273419
diff --git a/app-admin/logrotate/logrotate-3.7.1-r2.ebuild b/app-admin/logrotate/logrotate-3.7.1-r2.ebuild
index a3c2edd5383e..c8a7aa7822e5 100644
--- a/app-admin/logrotate/logrotate-3.7.1-r2.ebuild
+++ b/app-admin/logrotate/logrotate-3.7.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.1-r2.ebuild,v 1.14 2007/03/26 07:28:20 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.1-r2.ebuild,v 1.15 2009/10/11 23:33:10 halcy0n Exp $
inherit eutils
@@ -24,20 +24,20 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${P}.tar.bz2
- cd ${S}
+ cd "${S}"
sed -i \
-e "s:CFLAGS += -g:CFLAGS += -g ${CFLAGS}:" \
-e "/CVSROOT =/d" \
Makefile || die "sed failed"
- epatch ${FILESDIR}/${P}-dateext-maxage.patch
- epatch ${FILESDIR}/${P}-datehack.patch
- epatch ${FILESDIR}/${P}-ignore-hidden.patch
- epatch ${FILESDIR}/${P}-manpage-fixes.patch
- epatch ${FILESDIR}/${P}-taboo-to-debug.patch
- epatch ${FILESDIR}/${P}-no-tmpdir.patch
- epatch ${FILESDIR}/${P}-weekly.patch
+ epatch "${FILESDIR}"/${P}-dateext-maxage.patch
+ epatch "${FILESDIR}"/${P}-datehack.patch
+ epatch "${FILESDIR}"/${P}-ignore-hidden.patch
+ epatch "${FILESDIR}"/${P}-manpage-fixes.patch
+ epatch "${FILESDIR}"/${P}-taboo-to-debug.patch
+ epatch "${FILESDIR}"/${P}-no-tmpdir.patch
+ epatch "${FILESDIR}"/${P}-weekly.patch
}
src_compile() {
@@ -53,10 +53,10 @@ src_install() {
dodoc examples/logrotate*
exeinto /etc/cron.daily
- doexe ${FILESDIR}/logrotate.cron
+ doexe "${FILESDIR}"/logrotate.cron
insinto /etc
- doins ${FILESDIR}/logrotate.conf
+ doins "${FILESDIR}"/logrotate.conf
keepdir /etc/logrotate.d
}
diff --git a/app-admin/logrotate/logrotate-3.7.2.ebuild b/app-admin/logrotate/logrotate-3.7.2.ebuild
index 19f3ca499580..9b70621826e9 100644
--- a/app-admin/logrotate/logrotate-3.7.2.ebuild
+++ b/app-admin/logrotate/logrotate-3.7.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.2.ebuild,v 1.16 2008/12/15 17:30:51 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.2.ebuild,v 1.17 2009/10/11 23:33:10 halcy0n Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -24,7 +24,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${P}.tar.bz2
- cd ${S}
+ cd "${S}"
strip-flags
@@ -48,10 +48,10 @@ src_install() {
dodoc examples/logrotate*
exeinto /etc/cron.daily
- doexe ${FILESDIR}/logrotate.cron
+ doexe "${FILESDIR}"/logrotate.cron
insinto /etc
- doins ${FILESDIR}/logrotate.conf
+ doins "${FILESDIR}"/logrotate.conf
keepdir /etc/logrotate.d
}
diff --git a/app-admin/logrotate/logrotate-3.7.7.ebuild b/app-admin/logrotate/logrotate-3.7.7.ebuild
index 1dee9713d872..b427aded26e2 100644
--- a/app-admin/logrotate/logrotate-3.7.7.ebuild
+++ b/app-admin/logrotate/logrotate-3.7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.7.ebuild,v 1.3 2009/01/14 16:26:28 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.7.ebuild,v 1.4 2009/10/11 23:33:10 halcy0n Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -24,7 +24,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${P}.tar.gz
- cd ${S}
+ cd "${S}"
strip-flags
@@ -32,10 +32,10 @@ src_unpack() {
-e "/CVSROOT =/d" \
Makefile || die "sed failed"
- epatch ${FILESDIR}/${P}-datehack.patch
- epatch ${FILESDIR}/${P}-ignore-hidden.patch
- epatch ${FILESDIR}/${P}-weekly.patch
- epatch ${FILESDIR}/${P}-fbsd.patch
+ epatch "${FILESDIR}"/${P}-datehack.patch
+ epatch "${FILESDIR}"/${P}-ignore-hidden.patch
+ epatch "${FILESDIR}"/${P}-weekly.patch
+ epatch "${FILESDIR}"/${P}-fbsd.patch
}
src_compile() {
@@ -53,10 +53,10 @@ src_install() {
dodoc examples/logrotate*
exeinto /etc/cron.daily
- doexe ${FILESDIR}/logrotate.cron
+ doexe "${FILESDIR}"/logrotate.cron
insinto /etc
- doins ${FILESDIR}/logrotate.conf
+ doins "${FILESDIR}"/logrotate.conf
keepdir /etc/logrotate.d
}
diff --git a/app-admin/logrotate/logrotate-3.7.8.ebuild b/app-admin/logrotate/logrotate-3.7.8.ebuild
index 128b5af7ba57..f0a7e0091b33 100644
--- a/app-admin/logrotate/logrotate-3.7.8.ebuild
+++ b/app-admin/logrotate/logrotate-3.7.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.8.ebuild,v 1.9 2009/07/02 19:36:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.8.ebuild,v 1.10 2009/10/11 23:33:10 halcy0n Exp $
EAPI="2"
@@ -26,10 +26,10 @@ DEPEND="${RDEPEND}
src_prepare() {
strip-flags
- epatch ${FILESDIR}/${PN}-3.7.7-datehack.patch
- epatch ${FILESDIR}/${PN}-3.7.7-ignore-hidden.patch
- epatch ${FILESDIR}/${PN}-3.7.7-weekly.patch
- epatch ${FILESDIR}/${PN}-3.7.7-fbsd.patch
+ epatch "${FILESDIR}"/${PN}-3.7.7-datehack.patch
+ epatch "${FILESDIR}"/${PN}-3.7.7-ignore-hidden.patch
+ epatch "${FILESDIR}"/${PN}-3.7.7-weekly.patch
+ epatch "${FILESDIR}"/${PN}-3.7.7-fbsd.patch
}
src_configure() {
@@ -51,10 +51,10 @@ src_install() {
dodoc examples/logrotate*
exeinto /etc/cron.daily
- doexe ${FILESDIR}/logrotate.cron
+ doexe "${FILESDIR}"/logrotate.cron
insinto /etc
- doins ${FILESDIR}/logrotate.conf
+ doins "${FILESDIR}"/logrotate.conf
keepdir /etc/logrotate.d
}