summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-16 06:06:36 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-16 06:06:36 +0000
commit309480c17700ad5f245f5f785363f0f8fe378564 (patch)
tree1f198a5c0a88f2a0a482181cc35861c8b8be14ca /app-admin/mcollective
parentAdd more python targets (diff)
downloadgentoo-2-309480c17700ad5f245f5f785363f0f8fe378564.tar.gz
gentoo-2-309480c17700ad5f245f5f785363f0f8fe378564.tar.bz2
gentoo-2-309480c17700ad5f245f5f785363f0f8fe378564.zip
fixes for bug 459290 and verbump to 2.2.4
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin/mcollective')
-rw-r--r--app-admin/mcollective/ChangeLog9
-rw-r--r--app-admin/mcollective/mcollective-2.2.0-r1.ebuild60
-rw-r--r--app-admin/mcollective/mcollective-2.2.4.ebuild60
-rw-r--r--app-admin/mcollective/metadata.xml2
4 files changed, 129 insertions, 2 deletions
diff --git a/app-admin/mcollective/ChangeLog b/app-admin/mcollective/ChangeLog
index 9b60440f453d..b308b8fa66a2 100644
--- a/app-admin/mcollective/ChangeLog
+++ b/app-admin/mcollective/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/mcollective
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.13 2013/06/16 09:27:14 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.14 2013/09/16 06:06:36 prometheanfire Exp $
+
+*mcollective-2.2.4 (16 Sep 2013)
+*mcollective-2.2.0-r1 (16 Sep 2013)
+
+ 16 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +mcollective-2.2.0-r1.ebuild, +mcollective-2.2.4.ebuild, metadata.xml:
+ fixes for bug 459290 and verbump to 2.2.4
16 Jun 2013; Pacho Ramos <pacho@gentoo.org> -mcollective-1.0.1.ebuild,
-mcollective-1.1.4.ebuild, -mcollective-1.2.1.ebuild,
diff --git a/app-admin/mcollective/mcollective-2.2.0-r1.ebuild b/app-admin/mcollective/mcollective-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..0604c3dbf94e
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.2.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-2.2.0-r1.ebuild,v 1.1 2013/09/16 06:06:36 prometheanfire Exp $
+
+EAPI="4"
+
+USE_RUBY="ruby18 ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin bin/mc-* bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist}
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}
diff --git a/app-admin/mcollective/mcollective-2.2.4.ebuild b/app-admin/mcollective/mcollective-2.2.4.ebuild
new file mode 100644
index 000000000000..cdf1e1622bce
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.2.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-2.2.4.ebuild,v 1.1 2013/09/16 06:06:36 prometheanfire Exp $
+
+EAPI="4"
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin bin/mc-* bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist}
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}
diff --git a/app-admin/mcollective/metadata.xml b/app-admin/mcollective/metadata.xml
index 1c668aa1a92f..c35f424e1fe5 100644
--- a/app-admin/mcollective/metadata.xml
+++ b/app-admin/mcollective/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>prometheanfire@gentoo.org</email>
</maintainer>
<use>
<flag name="client">Install client utilities</flag>