summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2012-05-18 07:03:00 +0000
committerLance Albertson <ramereth@gentoo.org>2012-05-18 07:03:00 +0000
commit80d5b66fc248a354d8c34493cad698a038ad6607 (patch)
treea222b57066c09b640ba3e01f7afecfea4bcfe20b /app-admin/mcollective
parentMarked ~ppc ~ppc64 for bug #402989. (diff)
downloadgentoo-2-80d5b66fc248a354d8c34493cad698a038ad6607.tar.gz
gentoo-2-80d5b66fc248a354d8c34493cad698a038ad6607.tar.bz2
gentoo-2-80d5b66fc248a354d8c34493cad698a038ad6607.zip
version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/mcollective')
-rw-r--r--app-admin/mcollective/ChangeLog7
-rw-r--r--app-admin/mcollective/mcollective-2.0.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-admin/mcollective/ChangeLog b/app-admin/mcollective/ChangeLog
index 098ffcb8b8dd..2053a4378b91 100644
--- a/app-admin/mcollective/ChangeLog
+++ b/app-admin/mcollective/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/mcollective
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.6 2012/03/09 05:20:10 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.7 2012/05/18 07:03:00 ramereth Exp $
+
+*mcollective-2.0.0 (18 May 2012)
+
+ 18 May 2012; Lance Albertson <ramereth@gentoo.org> +mcollective-2.0.0.ebuild:
+ Version bump
09 Mar 2012; Lance Albertson <ramereth@gentoo.org> mcollective-1.0.1.ebuild,
mcollective-1.1.4.ebuild, mcollective-1.2.1.ebuild:
diff --git a/app-admin/mcollective/mcollective-2.0.0.ebuild b/app-admin/mcollective/mcollective-2.0.0.ebuild
new file mode 100644
index 000000000000..42d8dedfb884
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-2.0.0.ebuild,v 1.1 2012/05/18 07:03:00 ramereth Exp $
+
+EAPI="4"
+
+USE_RUBY="ruby18 ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin bin/mc-* bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r website/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist}
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}