summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-06-04 13:08:29 +0000
committerJustin Lecher <jlec@gentoo.org>2014-06-04 13:08:29 +0000
commit070865a9573c0c61ab50ff254d0cd6acfd855bae (patch)
tree0edd259edd49a667084842ad69e1002024fa619d /app-admin/ngxtop
parentdie(). (diff)
downloadgentoo-2-070865a9573c0c61ab50ff254d0cd6acfd855bae.tar.gz
gentoo-2-070865a9573c0c61ab50ff254d0cd6acfd855bae.tar.bz2
gentoo-2-070865a9573c0c61ab50ff254d0cd6acfd855bae.zip
app-admin/ngxtop: Fix compatibility with >= py3.3, #512380
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-admin/ngxtop')
-rw-r--r--app-admin/ngxtop/ChangeLog8
-rw-r--r--app-admin/ngxtop/files/ngxtop-0.0.2-py3.patch41
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.2-r1.ebuild (renamed from app-admin/ngxtop/ngxtop-0.0.2.ebuild)4
3 files changed, 51 insertions, 2 deletions
diff --git a/app-admin/ngxtop/ChangeLog b/app-admin/ngxtop/ChangeLog
index c6294a97019c..412a95f8359c 100644
--- a/app-admin/ngxtop/ChangeLog
+++ b/app-admin/ngxtop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/ngxtop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ngxtop/ChangeLog,v 1.1 2014/06/04 09:59:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ngxtop/ChangeLog,v 1.2 2014/06/04 13:08:28 jlec Exp $
+
+*ngxtop-0.0.2-r1 (04 Jun 2014)
+
+ 04 Jun 2014; Justin Lecher <jlec@gentoo.org> -ngxtop-0.0.2.ebuild,
+ +ngxtop-0.0.2-r1.ebuild, +files/ngxtop-0.0.2-py3.patch:
+ Fix compatibility with >= py3.3, #512380
*ngxtop-0.0.2 (04 Jun 2014)
diff --git a/app-admin/ngxtop/files/ngxtop-0.0.2-py3.patch b/app-admin/ngxtop/files/ngxtop-0.0.2-py3.patch
new file mode 100644
index 000000000000..1e4520c7f7e0
--- /dev/null
+++ b/app-admin/ngxtop/files/ngxtop-0.0.2-py3.patch
@@ -0,0 +1,41 @@
+ ngxtop/config_parser.py | 4 ++--
+ ngxtop/ngxtop.py | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/ngxtop/config_parser.py b/ngxtop/config_parser.py
+index b8e4804..40b23c9 100644
+--- a/ngxtop/config_parser.py
++++ b/ngxtop/config_parser.py
+@@ -8,7 +8,7 @@ import subprocess
+ from pyparsing import Literal, Word, ZeroOrMore, OneOrMore, Group, \
+ printables, quotedString, pythonStyleComment, removeQuotes
+
+-from utils import choose_one, error_exit
++from .utils import choose_one, error_exit
+
+
+ REGEX_SPECIAL_CHARS = r'([\.\*\+\?\|\(\)\{\}\[\]])'
+@@ -106,7 +106,7 @@ def detect_log_config(arguments):
+
+ log_formats = dict(get_log_formats(config_str))
+ if len(access_logs) == 1:
+- log_path, format_name = access_logs.items()[0]
++ log_path, format_name = list(access_logs.items())[0]
+ if format_name == 'combined':
+ return log_path, LOG_FORMAT_COMBINED
+ if format_name not in log_formats:
+diff --git a/ngxtop/ngxtop.py b/ngxtop/ngxtop.py
+index afb5bc3..8667b8b 100755
+--- a/ngxtop/ngxtop.py
++++ b/ngxtop/ngxtop.py
+@@ -74,8 +74,8 @@ except ImportError:
+ from docopt import docopt
+ import tabulate
+
+-from config_parser import detect_log_config, detect_config_path, extract_variables, build_pattern
+-from utils import error_exit
++from .config_parser import detect_log_config, detect_config_path, extract_variables, build_pattern
++from .utils import error_exit
+
+
+ DEFAULT_QUERIES = [
diff --git a/app-admin/ngxtop/ngxtop-0.0.2.ebuild b/app-admin/ngxtop/ngxtop-0.0.2-r1.ebuild
index 8065b24730cc..cb730d8bd62f 100644
--- a/app-admin/ngxtop/ngxtop-0.0.2.ebuild
+++ b/app-admin/ngxtop/ngxtop-0.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ngxtop/ngxtop-0.0.2.ebuild,v 1.1 2014/06/04 09:59:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ngxtop/ngxtop-0.0.2-r1.ebuild,v 1.1 2014/06/04 13:08:28 jlec Exp $
EAPI=5
@@ -23,3 +23,5 @@ RDEPEND="
dev-python/tabulate[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
"
+
+PATCHES=( "${FILESDIR}"/${P}-py3.patch )