summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-04-29 22:28:55 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-04-29 22:28:55 +0000
commitc7d4763495280e4d1d1778db82b23e62109f1b29 (patch)
treec40f742404ad2267a47dbcfd32ae4b9450bb2a3a /app-admin/otpcalc/otpcalc-0.97.ebuild
parentRetouches retouches retouches (diff)
downloadgentoo-2-c7d4763495280e4d1d1778db82b23e62109f1b29.tar.gz
gentoo-2-c7d4763495280e4d1d1778db82b23e62109f1b29.tar.bz2
gentoo-2-c7d4763495280e4d1d1778db82b23e62109f1b29.zip
bump, & fix 90900
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-admin/otpcalc/otpcalc-0.97.ebuild')
-rw-r--r--app-admin/otpcalc/otpcalc-0.97.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/otpcalc/otpcalc-0.97.ebuild b/app-admin/otpcalc/otpcalc-0.97.ebuild
new file mode 100644
index 000000000000..c668b7a47078
--- /dev/null
+++ b/app-admin/otpcalc/otpcalc-0.97.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/otpcalc/otpcalc-0.97.ebuild,v 1.1 2005/04/29 22:28:55 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="A One Time Password and S/Key calculator for X"
+HOMEPAGE="http://killa.net/infosec/otpCalc/"
+SRC_URI="http://killa.net/infosec/otpCalc/otpCalc-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1.2*
+ virtual/x11
+ virtual/libc"
+
+S=${WORKDIR}/${P/c/C}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/otpcalc-man-table-format.diff
+ sed -i -e "s/VERSION/${PV}/g" ${S}/otpCalc.man
+ sed -i "s#-s -O3#${CFLAGS}#g" ${S}/Makefile.in
+}
+
+src_install() {
+ newman otpCalc.man otpCalc.1
+ dobin otpCalc || die
+}