summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-02-18 04:01:28 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-02-18 04:01:28 +0000
commit527676eedbe1a5032e4231f9c7f506eee1506b0e (patch)
treec812b41dbc7a47fafbc6828834e3b980d6f6a9ec /app-admin/puppet
parentVersion bump. (diff)
downloadgentoo-2-527676eedbe1a5032e4231f9c7f506eee1506b0e.tar.gz
gentoo-2-527676eedbe1a5032e4231f9c7f506eee1506b0e.tar.bz2
gentoo-2-527676eedbe1a5032e4231f9c7f506eee1506b0e.zip
fixed for bug 489868
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/ChangeLog8
-rw-r--r--app-admin/puppet/puppet-3.4.2-r2.ebuild165
2 files changed, 172 insertions, 1 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index 5af5c6a896f0..140b914c4501 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.192 2014/01/18 07:33:11 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.193 2014/02/18 04:01:28 prometheanfire Exp $
+
+*puppet-3.4.2-r2 (18 Feb 2014)
+
+ 18 Feb 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +puppet-3.4.2-r2.ebuild:
+ fixed for bug 489868
18 Jan 2014; Matthew Thode <prometheanfire@gentoo.org> -puppet-2.7.23.ebuild,
-puppet-3.2.4.ebuild:
diff --git a/app-admin/puppet/puppet-3.4.2-r2.ebuild b/app-admin/puppet/puppet-3.4.2-r2.ebuild
new file mode 100644
index 000000000000..9fa543c6a14c
--- /dev/null
+++ b/app-admin/puppet/puppet-3.4.2-r2.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.4.2-r2.ebuild,v 1.1 2014/02/18 04:01:28 prometheanfire Exp $
+
+EAPI="5"
+
+#supports ruby20, but needs deps first
+USE_RUBY="ruby19"
+
+inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/rgen
+ >=dev-ruby/facter-1.6.2
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite3? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl"
+
+DEPEND="${DEPEND}
+ ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
+ emacs? ( virtual/emacs )
+ xemacs? ( app-editors/xemacs )"
+RDEPEND="${RDEPEND}
+ ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_compile() {
+ if use emacs ; then
+ elisp-compile ext/emacs/puppet-mode.el
+ fi
+
+ if use xemacs ; then
+ # Create a separate version for xemacs to be able to install
+ # emacs and xemacs in parallel.
+ mkdir ext/xemacs
+ cp ext/emacs/* ext/xemacs/
+ xemacs-elisp-compile ext/xemacs/puppet-mode.el
+ fi
+}
+
+each_ruby_install() {
+ ${RUBY} install.rb --destdir="${D}" install || die
+}
+
+all_ruby_install() {
+ #systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ newinitd "${FILESDIR}"/puppet.init-r1 puppet
+
+ # Initial configuration files
+ insinto /etc/puppet
+
+ # Location of log and data files
+ keepdir /var/log/puppet
+ fowners -R puppet:puppet /var/log/puppet
+
+ if use minimal ; then
+ rm "${ED}/etc/puppet/auth.conf"
+ else
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
+ newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ insinto /etc/puppet
+
+ keepdir /etc/puppet/manifests
+ keepdir /etc/puppet/modules
+
+ keepdir /var/lib/puppet/ssl
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+ fperms 0750 /var/lib/puppet
+ fi
+ fperms 0750 /etc/puppet
+
+ if use emacs ; then
+ elisp-install ${PN} ext/emacs/puppet-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use xemacs ; then
+ xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
+ xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+
+ if [ \
+ -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
+ -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
+ -f "${EPREFIX}/etc/puppet/puppetca.conf" \
+ ] ; then
+ elog
+ elog "Please remove deprecated config files."
+ elog " /etc/puppet/puppetca.conf"
+ elog " /etc/puppet/puppetd.conf"
+ elog " /etc/puppet/puppetmasterd.conf"
+ elog
+ fi
+
+ if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
+ elog
+ elog "If you're upgrading from 2.x then we strongly suggest you to read:"
+ elog "http://docs.puppetlabs.com/guides/upgrading.html"
+ elog
+ fi
+
+ use emacs && elisp-site-regen
+ use xemacs && xemacs-elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use xemacs && xemacs-elisp-site-regen
+}