summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:35:39 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:35:39 +0000
commit91452bba8540108bec3c5c1225d87cc6ddc424f8 (patch)
tree908d7874e02557813f46d7cc8d97da22e66ee363 /app-admin/quickswitch
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadgentoo-2-91452bba8540108bec3c5c1225d87cc6ddc424f8.tar.gz
gentoo-2-91452bba8540108bec3c5c1225d87cc6ddc424f8.tar.bz2
gentoo-2-91452bba8540108bec3c5c1225d87cc6ddc424f8.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-admin/quickswitch')
-rw-r--r--app-admin/quickswitch/quickswitch-0.10.ebuild5
-rw-r--r--app-admin/quickswitch/quickswitch-1.0_pre1.ebuild12
2 files changed, 8 insertions, 9 deletions
diff --git a/app-admin/quickswitch/quickswitch-0.10.ebuild b/app-admin/quickswitch/quickswitch-0.10.ebuild
index 6abffd98706a..5c4ebc04aef6 100644
--- a/app-admin/quickswitch/quickswitch-0.10.ebuild
+++ b/app-admin/quickswitch/quickswitch-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/quickswitch/quickswitch-0.10.ebuild,v 1.9 2002/10/04 03:45:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/quickswitch/quickswitch-0.10.ebuild,v 1.10 2002/11/30 02:33:59 vapier Exp $
S=${WORKDIR}/${PN}
DESCRIPTION="Utility to switch network profiles on the fly"
@@ -13,8 +13,7 @@ KEYWORDS="x86 sparc sparc64"
DEPEND="sys-devel/perl"
-
-src_install () {
+src_install() {
dobin switchto
dosed "s:/etc/switch.conf:/etc/quickswitch/switch.conf:" /usr/bin/switchto
dosed "s:/etc/switchto.last:/etc/quickswitch/switchto.last:" /usr/bin/switchto
diff --git a/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild b/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild
index c7622308fea1..b7e9b07f32b7 100644
--- a/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild
+++ b/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild,v 1.8 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild,v 1.9 2002/11/30 02:35:13 vapier Exp $
-S=${WORKDIR}/quickwitch
+MY_PN="quickwitch"
+MY_P="${MY_PN}-${PV/_/}"
+S=${WORKDIR}/${MY_PN}
DESCRIPTION="Utility to switch network profiles on the fly"
-SRC_URI="mirror://sourceforge/quickswitch/quickwitch-1.0pre1.tar.gz"
+SRC_URI="mirror://sourceforge/quickswitch/${MY_P}.tar.gz"
HOMEPAGE="http://edgesolutions.ca/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
-
DEPEND=">=sys-devel/perl-5.6.0"
-src_install () {
- cd ${S}
+src_install() {
dobin switchto
dobin switcher
dosed "s:/etc/switchto.conf:/etc/quickswitch/switchto.conf:" /usr/bin/switchto