summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-16 14:30:58 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-16 14:30:58 +0000
commitedb2b8557925385cbb19ca324a92d585dd787730 (patch)
tree514f9c459e8473d26ae7ccd7779f00d608c9e010 /app-admin/realpath/realpath-1.12.ebuild
parentsparc stable wrt #217847 (diff)
downloadgentoo-2-edb2b8557925385cbb19ca324a92d585dd787730.tar.gz
gentoo-2-edb2b8557925385cbb19ca324a92d585dd787730.tar.bz2
gentoo-2-edb2b8557925385cbb19ca324a92d585dd787730.zip
Version bump.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'app-admin/realpath/realpath-1.12.ebuild')
-rw-r--r--app-admin/realpath/realpath-1.12.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/realpath/realpath-1.12.ebuild b/app-admin/realpath/realpath-1.12.ebuild
new file mode 100644
index 000000000000..58d9a0a19b1b
--- /dev/null
+++ b/app-admin/realpath/realpath-1.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/realpath/realpath-1.12.ebuild,v 1.1 2008/05/16 14:30:58 drac Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Return the canonicalized absolute pathname"
+HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
+SRC_URI="mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!sys-freebsd/freebsd-bin"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -DVERSION=\"$PV\" -o ${PN} || die "compile failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ doman man/${PN}.1
+ newdoc debian/changelog ChangeLog.debian
+}