summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2015-01-16 22:56:46 +0000
committerPatrick McLean <chutzpah@gentoo.org>2015-01-16 22:56:46 +0000
commit2b472c9f2d0d7b123f1725c41c0ba3de2191d77a (patch)
tree2d523226d3d35db127f7ee3c347179b479957fbb /app-admin/salt
parentLinux patch 3.18.3 (diff)
downloadgentoo-2-2b472c9f2d0d7b123f1725c41c0ba3de2191d77a.tar.gz
gentoo-2-2b472c9f2d0d7b123f1725c41c0ba3de2191d77a.tar.bz2
gentoo-2-2b472c9f2d0d7b123f1725c41c0ba3de2191d77a.zip
Version bump, add selinux USE flag (bug #533118). Sync 9999 ebuild with current version.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'app-admin/salt')
-rw-r--r--app-admin/salt/ChangeLog9
-rw-r--r--app-admin/salt/files/salt-2014.7.1-remove-pydsl-includes-test.patch104
-rw-r--r--app-admin/salt/salt-2014.7.1.ebuild111
-rw-r--r--app-admin/salt/salt-9999.ebuild17
4 files changed, 234 insertions, 7 deletions
diff --git a/app-admin/salt/ChangeLog b/app-admin/salt/ChangeLog
index efe3c08cca95..34b5dcf837e0 100644
--- a/app-admin/salt/ChangeLog
+++ b/app-admin/salt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/salt
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/ChangeLog,v 1.53 2015/01/03 12:26:40 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/ChangeLog,v 1.54 2015/01/16 22:56:46 chutzpah Exp $
+
+*salt-2014.7.1 (16 Jan 2015)
+
+ 16 Jan 2015; Patrick McLean <chutzpah@gentoo.org> +salt-2014.7.1.ebuild,
+ salt-9999.ebuild, +files/salt-2014.7.1-remove-pydsl-includes-test.patch:
+ Version bump, add selinux USE flag (bug #533118). Sync 9999 ebuild with
+ current version.
03 Jan 2015; Sven Vermeulen <swift@gentoo.org> salt-9999.ebuild:
Add selinux? dep to selinux-salt (bug #533118) for live ebuild
diff --git a/app-admin/salt/files/salt-2014.7.1-remove-pydsl-includes-test.patch b/app-admin/salt/files/salt-2014.7.1-remove-pydsl-includes-test.patch
new file mode 100644
index 000000000000..7c33c12f5c71
--- /dev/null
+++ b/app-admin/salt/files/salt-2014.7.1-remove-pydsl-includes-test.patch
@@ -0,0 +1,104 @@
+diff --git a/tests/unit/pydsl_test.py b/tests/unit/pydsl_test.py
+index 57ba81e..b26154e 100644
+--- a/tests/unit/pydsl_test.py
++++ b/tests/unit/pydsl_test.py
+@@ -298,99 +298,6 @@ class PyDSLRendererTestCase(TestCase):
+ finally:
+ shutil.rmtree(dirpath, ignore_errors=True)
+
+- def test_rendering_includes(self):
+- dirpath = tempfile.mkdtemp(dir=integration.SYS_TMP_DIR)
+- if not os.path.isdir(dirpath):
+- self.skipTest(
+- 'The temporary directory {0!r} was not created'.format(
+- dirpath
+- )
+- )
+- output = os.path.join(dirpath, 'output')
+- try:
+- write_to(os.path.join(dirpath, 'aaa.sls'), textwrap.dedent('''\
+- #!pydsl|stateconf -ps
+-
+- include('xxx')
+- yyy = include('yyy')
+-
+- # ensure states in xxx are run first, then those in yyy and then those in aaa last.
+- extend(state('yyy::start').stateconf.require(stateconf='xxx::goal'))
+- extend(state('.start').stateconf.require(stateconf='yyy::goal'))
+-
+- extend(state('yyy::Y2').cmd.run('echo Y2 extended >> {0}'))
+-
+- __pydsl__.set(ordered=True)
+-
+- yyy.hello('red', 1)
+- yyy.hello('green', 2)
+- yyy.hello('blue', 3)
+- '''.format(output)))
+-
+- write_to(os.path.join(dirpath, 'xxx.sls'), textwrap.dedent('''\
+- #!stateconf -os yaml . jinja
+-
+- include:
+- - yyy
+-
+- extend:
+- yyy::start:
+- stateconf.set:
+- - require:
+- - stateconf: .goal
+-
+- yyy::Y1:
+- cmd.run:
+- - name: 'echo Y1 extended >> {0}'
+-
+- .X1:
+- cmd.run:
+- - name: echo X1 >> {1}
+- - cwd: /
+- .X2:
+- cmd.run:
+- - name: echo X2 >> {2}
+- - cwd: /
+- .X3:
+- cmd.run:
+- - name: echo X3 >> {3}
+- - cwd: /
+-
+- '''.format(output, output, output, output)))
+-
+- write_to(os.path.join(dirpath, 'yyy.sls'), textwrap.dedent('''\
+- #!pydsl|stateconf -ps
+-
+- include('xxx')
+- __pydsl__.set(ordered=True)
+-
+- state('.Y1').cmd.run('echo Y1 >> {0}', cwd='/')
+- state('.Y2').cmd.run('echo Y2 >> {1}', cwd='/')
+- state('.Y3').cmd.run('echo Y3 >> {2}', cwd='/')
+-
+- def hello(color, number):
+- state(color).cmd.run('echo hello '+color+' '+str(number)+' >> {3}', cwd='/')
+- '''.format(output, output, output, output)))
+-
+- state_highstate({'base': ['aaa']}, dirpath)
+- expected = textwrap.dedent('''\
+- X1
+- X2
+- X3
+- Y1 extended
+- Y2 extended
+- Y3
+- hello red 1
+- hello green 2
+- hello blue 3
+- ''')
+-
+- with salt.utils.fopen(output, 'r') as f:
+- self.assertEqual(sorted(f.read()), sorted(expected))
+-
+- finally:
+- shutil.rmtree(dirpath, ignore_errors=True)
+-
+ def test_compile_time_state_execution(self):
+ if not sys.stdin.isatty():
+ self.skipTest('Not attached to a TTY')
diff --git a/app-admin/salt/salt-2014.7.1.ebuild b/app-admin/salt/salt-2014.7.1.ebuild
new file mode 100644
index 000000000000..8916ac8ffbe6
--- /dev/null
+++ b/app-admin/salt/salt-2014.7.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/salt-2014.7.1.ebuild,v 1.1 2015/01/16 22:56:46 chutzpah Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+inherit eutils distutils-r1 systemd
+
+DESCRIPTION="Salt is a remote execution and configuration manager"
+HOMEPAGE="http://saltstack.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/${PN}stack/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="api ldap libcloud libvirt gnupg keyring mako mongodb mysql nova"
+IUSE+=" openssl redis selinux timelib raet +zeromq test"
+
+RDEPEND="sys-apps/pciutils
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ libcloud? ( >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}] )
+ mako? ( dev-python/mako[${PYTHON_USEDEP}] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
+ openssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ libvirt? ( dev-python/libvirt-python[${PYTHON_USEDEP}] )
+ raet? (
+ dev-python/libnacl[${PYTHON_USEDEP}]
+ dev-python/ioflo[${PYTHON_USEDEP}]
+ dev-python/raet[${PYTHON_USEDEP}]
+ )
+ zeromq? (
+ >=dev-python/pyzmq-2.2.0[${PYTHON_USEDEP}]
+ dev-python/m2crypto[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+ api? (
+ || (
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+ )
+ mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+ keyring? ( dev-python/keyring[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
+ selinux? ( sec-policy/selinux-salt )
+ timelib? ( dev-python/timelib[${PYTHON_USEDEP}] )
+ nova? ( >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}] )
+ gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/timelib[${PYTHON_USEDEP}]
+ >=dev-python/SaltTesting-2014.8.5[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+DOCS=(README.rst AUTHORS)
+
+REQUIRED_USE="|| ( raet zeromq )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-remove-pydsl-includes-test.patch"
+)
+
+python_prepare() {
+ # this test fails because it trys to "pip install distribute"
+ rm tests/unit/{modules,states}/zcbuildout_test.py
+
+ # these tests fail because they depend on features that are only
+ # in git versions of SaltTesting
+ rm tests/unit/{templates/jinja,modules/hashutil}_test.py
+}
+
+python_install_all() {
+ USE_SETUPTOOLS=1 distutils-r1_python_install_all
+
+ for s in minion master syndic $(use api && echo api); do
+ newinitd "${FILESDIR}"/${s}-initd-3 salt-${s}
+ newconfd "${FILESDIR}"/${s}-confd-1 salt-${s}
+ systemd_dounit "${FILESDIR}"/salt-${s}.service
+ done
+
+ insinto /etc/${PN}
+ doins -r conf/*
+}
+
+python_test() {
+ # testsuite likes lots of files
+ ulimit -n 3072
+
+ # using ${T} for the TMPDIR makes some tests needs paths that exceed PATH_MAX
+ USE_SETUPTOOLS=1 SHELL="/bin/bash" TMPDIR="/tmp" \
+ ./tests/runtests.py --unit-tests --no-report --verbose || die "testing failed"
+}
diff --git a/app-admin/salt/salt-9999.ebuild b/app-admin/salt/salt-9999.ebuild
index 710ec63480da..1e20ea3c6d74 100644
--- a/app-admin/salt/salt-9999.ebuild
+++ b/app-admin/salt/salt-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/salt-9999.ebuild,v 1.15 2015/01/03 12:26:40 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/salt-9999.ebuild,v 1.16 2015/01/16 22:56:46 chutzpah Exp $
EAPI=5
PYTHON_COMPAT=(python2_7)
@@ -23,7 +23,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="cherrypy ldap libcloud libvirt gnupg keyring mako mongodb mysql nova"
+IUSE="api ldap libcloud libvirt gnupg keyring mako mongodb mysql nova"
IUSE+=" openssl redis selinux timelib raet +zeromq test"
RDEPEND="sys-apps/pciutils
@@ -48,6 +48,12 @@ RDEPEND="sys-apps/pciutils
dev-python/m2crypto[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]
)
+ api? (
+ || (
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+ )
mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
keyring? ( dev-python/keyring[${PYTHON_USEDEP}] )
mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
@@ -55,14 +61,13 @@ RDEPEND="sys-apps/pciutils
selinux? ( sec-policy/selinux-salt )
timelib? ( dev-python/timelib[${PYTHON_USEDEP}] )
nova? ( >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}] )
- gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
- cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] )"
+ gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pip[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
dev-python/timelib[${PYTHON_USEDEP}]
- >=dev-python/SaltTesting-2014.4.24[${PYTHON_USEDEP}]
+ >=dev-python/SaltTesting-2014.8.5[${PYTHON_USEDEP}]
${RDEPEND}
)"
@@ -78,7 +83,7 @@ python_prepare() {
python_install_all() {
USE_SETUPTOOLS=1 distutils-r1_python_install_all
- for s in minion master syndic; do
+ for s in minion master syndic $(use api && echo api); do
newinitd "${FILESDIR}"/${s}-initd-3 salt-${s}
newconfd "${FILESDIR}"/${s}-confd-1 salt-${s}
systemd_dounit "${FILESDIR}"/salt-${s}.service