summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-22 20:40:48 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-22 20:40:48 +0000
commit79d88711151e471fd937f40e7d09f191535fdfae (patch)
tree02d95e40223c8ac458e97027e1cbbf83b4e109af /app-admin/salt
parentfix commit message ... meant to use echangelog only (diff)
downloadgentoo-2-79d88711151e471fd937f40e7d09f191535fdfae.tar.gz
gentoo-2-79d88711151e471fd937f40e7d09f191535fdfae.tar.bz2
gentoo-2-79d88711151e471fd937f40e7d09f191535fdfae.zip
Use openrc to background daemons instead of internal support.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-admin/salt')
-rw-r--r--app-admin/salt/ChangeLog10
-rw-r--r--app-admin/salt/files/master-initd-214
-rw-r--r--app-admin/salt/files/minion-initd-214
-rw-r--r--app-admin/salt/files/syndic-initd-214
-rw-r--r--app-admin/salt/salt-0.17.4-r2.ebuild80
5 files changed, 130 insertions, 2 deletions
diff --git a/app-admin/salt/ChangeLog b/app-admin/salt/ChangeLog
index 46657e7b1628..b4d7bd8759cd 100644
--- a/app-admin/salt/ChangeLog
+++ b/app-admin/salt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/salt
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/ChangeLog,v 1.30 2013/12/26 10:56:49 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/ChangeLog,v 1.31 2014/01/22 20:40:48 radhermit Exp $
+
+*salt-0.17.4-r2 (22 Jan 2014)
+
+ 22 Jan 2014; Tim Harder <radhermit@gentoo.org> +salt-0.17.4-r2.ebuild,
+ +files/master-initd-2, +files/minion-initd-2, +files/syndic-initd-2:
+ Use openrc to background daemons instead of internal support.
*salt-0.17.4-r1 (26 Dec 2013)
diff --git a/app-admin/salt/files/master-initd-2 b/app-admin/salt/files/master-initd-2
new file mode 100644
index 000000000000..61380096cf9f
--- /dev/null
+++ b/app-admin/salt/files/master-initd-2
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/files/master-initd-2,v 1.1 2014/01/22 20:40:48 radhermit Exp $
+
+command="/usr/bin/salt-master"
+command_args="${SALT_OPTS}"
+command_background="1"
+pidfile="/var/run/salt-master.pid"
+name="SALT master daemon"
+
+depend() {
+ use net
+}
diff --git a/app-admin/salt/files/minion-initd-2 b/app-admin/salt/files/minion-initd-2
new file mode 100644
index 000000000000..9f6c65b49d9e
--- /dev/null
+++ b/app-admin/salt/files/minion-initd-2
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/files/minion-initd-2,v 1.1 2014/01/22 20:40:48 radhermit Exp $
+
+command="/usr/bin/salt-minion"
+command_args="${SALT_OPTS}"
+command_background="1"
+pidfile="/var/run/salt-minion.pid"
+name="SALT minion daemon"
+
+depend() {
+ need net
+}
diff --git a/app-admin/salt/files/syndic-initd-2 b/app-admin/salt/files/syndic-initd-2
new file mode 100644
index 000000000000..2f3227a6df1f
--- /dev/null
+++ b/app-admin/salt/files/syndic-initd-2
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/files/syndic-initd-2,v 1.1 2014/01/22 20:40:48 radhermit Exp $
+
+command="/usr/bin/salt-syndic"
+command_args="${SALT_OPTS}"
+command_background="1"
+pidfile="/var/run/salt-syndic.pid"
+name="SALT syndic daemon"
+
+depend() {
+ use net
+}
diff --git a/app-admin/salt/salt-0.17.4-r2.ebuild b/app-admin/salt/salt-0.17.4-r2.ebuild
new file mode 100644
index 000000000000..370b9c53ee40
--- /dev/null
+++ b/app-admin/salt/salt-0.17.4-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/salt/salt-0.17.4-r2.ebuild,v 1.1 2014/01/22 20:40:48 radhermit Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_6,2_7})
+
+inherit eutils distutils-r1 systemd
+
+DESCRIPTION="Salt is a remote execution and configuration manager."
+HOMEPAGE="http://saltstack.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${PN}stack/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ldap libvirt mako mongodb mysql openssl redis test"
+
+RDEPEND=">=dev-python/pyzmq-2.1.9[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/m2crypto[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/pycryptopp[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/pciutils
+ mako? ( dev-python/mako[${PYTHON_USEDEP}] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
+ openssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ libvirt? ( || (
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ app-emulation/libvirt[python,${PYTHON_USEDEP}]
+ )
+ )
+ mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ dev-python/pip
+ dev-python/virtualenv
+ dev-python/SaltTesting
+ ${RDEPEND}
+ )"
+
+PATCHES=("${FILESDIR}/${PN}-0.17.1-tests-nonroot.patch")
+DOCS=(README.rst AUTHORS)
+
+python_prepare() {
+ sed -i '/install_requires=/ d' setup.py || die "sed failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ for s in minion master syndic; do
+ newinitd "${FILESDIR}"/${s}-initd-2 salt-${s}
+ newconfd "${FILESDIR}"/${s}-confd-1 salt-${s}
+ systemd_dounit "${FILESDIR}"/salt-${s}.service
+ done
+
+ insinto /etc/${PN}
+ doins conf/*
+}
+
+python_test() {
+ # testsuite likes lots of files
+ ulimit -n 3072
+ SHELL="/bin/bash" TMPDIR=/tmp ./tests/runtests.py --unit-tests --no-report || die
+}