summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2005-11-12 23:23:09 +0000
committerChris PeBenito <pebenito@gentoo.org>2005-11-12 23:23:09 +0000
commit3ce8d09a05b1d9f866ebbbd4f04a974b43b25746 (patch)
tree22b5c946f1badd668f6f45a5397dcf1fb651dd61 /app-admin/setools
parentNew version and fixes (diff)
downloadgentoo-2-3ce8d09a05b1d9f866ebbbd4f04a974b43b25746.tar.gz
gentoo-2-3ce8d09a05b1d9f866ebbbd4f04a974b43b25746.tar.bz2
gentoo-2-3ce8d09a05b1d9f866ebbbd4f04a974b43b25746.zip
add patch to fix #112284.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-admin/setools')
-rw-r--r--app-admin/setools/ChangeLog6
-rw-r--r--app-admin/setools/files/setools-2.2-nogui.diff105
-rw-r--r--app-admin/setools/setools-2.2.ebuild6
3 files changed, 115 insertions, 2 deletions
diff --git a/app-admin/setools/ChangeLog b/app-admin/setools/ChangeLog
index 6973f921fe5c..94f165ebeaa4 100644
--- a/app-admin/setools/ChangeLog
+++ b/app-admin/setools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/setools
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/ChangeLog,v 1.40 2005/11/08 01:42:25 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/ChangeLog,v 1.41 2005/11/12 23:23:09 pebenito Exp $
+
+ 12 Nov 2005; Chris PeBenito <pebenito@gentoo.org>
+ +files/setools-2.2-nogui.diff, setools-2.2.ebuild:
+ Add patch to fix bug #112284.
*setools-2.2 (08 Nov 2005)
diff --git a/app-admin/setools/files/setools-2.2-nogui.diff b/app-admin/setools/files/setools-2.2-nogui.diff
new file mode 100644
index 000000000000..a71d3c54ddcd
--- /dev/null
+++ b/app-admin/setools/files/setools-2.2-nogui.diff
@@ -0,0 +1,105 @@
+Index: seaudit/Makefile
+===================================================================
+--- seaudit/Makefile (revision 3303)
++++ seaudit/Makefile (revision 3304)
+@@ -7,8 +7,6 @@
+
+ CFLAGS += -DDEFAULT_LOG='"$(DEFAULT_LOG_FILE)"'
+ CFLAGS += -DINSTALL_LIBDIR='"$(INSTALL_LIBDIR)"'
+-CFLAGS += -DSEAUDIT_GUI_VERSION_STRING='"$(shell cat SEAUDIT_GUI_VERSION)"'
+-CFLAGS += -DSEREPORT_VERSION_NUM='"$(shell cat SEAUDIT_REPORT_VERSION)"'
+
+ SEAUDIT_REPORT_BACKEND = report.o
+
+@@ -57,8 +55,14 @@
+ $(MAKE) -C ../libapol libapolso
+
+ %.o: %.c
+- $(CC) $(CFLAGS) $(GTK_CFLAGS) $(LIBXML_FLAGS) $(INCLUDE) -c $<
++ $(CC) $(CFLAGS) $(LIBXML_FLAGS) $(INCLUDE) -c $<
+
++$(OBJS): CFLAGS += $(GTK_CFLAGS)
++
++seaudit.o: CFLAGS += -DSEAUDIT_GUI_VERSION_STRING='"$(shell cat SEAUDIT_GUI_VERSION)"'
++
++seaudit-report.o: CFLAGS += -DSEREPORT_VERSION_NUM='"$(shell cat SEAUDIT_REPORT_VERSION)"'
++
+ install: seaudit seaudit-report
+ install -m 755 seaudit $(BINDIR)
+ install -m 755 seaudit-report $(BINDIR)
+Index: sediff/sediff.c
+===================================================================
+--- sediff/sediff.c (revision 3303)
++++ sediff/sediff.c (revision 3304)
+@@ -10,7 +10,6 @@
+
+ /* libapol */
+ #include "util.h"
+-#include "sediff_rename_types.h"
+ #include <policy.h>
+ #include <policy-io.h>
+ #include <policy-query.h>
+Index: sediff/Makefile
+===================================================================
+--- sediff/Makefile (revision 3303)
++++ sediff/Makefile (revision 3304)
+@@ -7,11 +7,6 @@
+ GTK_LIBS = `pkg-config --libs libglade-2.0`
+ GLADE_FILES = sediff.glade
+
+-CFLAGS += -DSEDIFF_VERSION_NUM='"$(shell cat SEDIFF_VERSION)"'
+-CFLAGS += -DSEDIFF_GUI_VERSION_NUM='"$(shell cat SEDIFF_GUI_VERSION)"'
+-CFLAGS += -DSEDIFF_GUI_VERSION_NUM='"$(shell cat SEDIFF_GUI_VERSION)"'
+-
+-
+ all: libapol sediff sediffx
+
+ sediff: sediff.o $(LIBAPOL)
+@@ -29,8 +24,13 @@
+ install -m 644 sediff_help.txt $(INSTALL_LIBDIR)
+
+ %.o: %.c
+- $(CC) $(CFLAGS) $(GTK_CFLAGS) $(INCLUDE) -c $<
++ $(CC) $(CFLAGS) $(INCLUDE) -c $<
+
++$(GUI-OBJS): CFLAGS += $(GTK_CFLAGS)
++sediff.o: CFLAGS += -DSEDIFF_VERSION_NUM='"$(shell cat SEDIFF_VERSION)"'
++sediff_gui.o: CFLAGS += -DSEDIFF_VERSION_NUM='"$(shell cat SEDIFF_VERSION)"'
++sediff_gui.o: CFLAGS += -DSEDIFF_GUI_VERSION_NUM='"$(shell cat SEDIFF_GUI_VERSION)"'
++
+ libapol:
+ $(MAKE) -C .. libapol
+
+Index: secmds/Makefile
+===================================================================
+--- secmds/Makefile (revision 3303)
++++ secmds/Makefile (revision 3304)
+@@ -22,13 +22,6 @@
+ SE_CMDS += $(SELINUX_TOOLS)
+ endif
+
+-CFLAGS += -DSEINFO_VERSION_NUM='"$(shell cat SEINFO_VERSION)"'
+-CFLAGS += -DSESEARCH_VERSION_NUM='"$(shell cat SESEARCH_VERSION)"'
+-CFLAGS += -DREPLCON_VERSION_NUM='"$(shell cat REPLCON_VERSION)"'
+-CFLAGS += -DFINDCON_VERSION_NUM='"$(shell cat FINDCON_VERSION)"'
+-CFLAGS += -DINDEXCON_VERSION_NUM='"$(shell cat INDEXCON_VERSION)"'
+-CFLAGS += -DSEARCHCON_VERSION_NUM='"$(shell cat SEARCHCON_VERSION)"'
+-CFLAGS += -DAPOL_DEFAULT_PERM_MAP="\"/usr/share/setools/apol_perm_mapping\""
+
+ SHELL = /bin/sh
+
+@@ -79,6 +72,14 @@
+ %.o: %.c
+ $(CC) $(CFLAGS) $(INCLUDE) -c $<
+
++seinfo.o: CFLAGS += -DSEINFO_VERSION_NUM='"$(shell cat SEINFO_VERSION)"'
++sesearch.o: CFLAGS += -DSESEARCH_VERSION_NUM='"$(shell cat SESEARCH_VERSION)"'
++replcon.o: CFLAGS += -DREPLCON_VERSION_NUM='"$(shell cat REPLCON_VERSION)"'
++findcon.o: CFLAGS += -DFINDCON_VERSION_NUM='"$(shell cat FINDCON_VERSION)"'
++indexcon.o: CFLAGS += -DINDEXCON_VERSION_NUM='"$(shell cat INDEXCON_VERSION)"'
++searchcon.o: CFLAGS += -DSEARCHCON_VERSION_NUM='"$(shell cat SEARCHCON_VERSION)"'
++flowtool.o: CFLAGS += -DAPOL_DEFAULT_PERM_MAP="\"/usr/share/setools/apol_perm_mapping\""
++
+ libapol:
+ $(MAKE) -C .. libapol
+
diff --git a/app-admin/setools/setools-2.2.ebuild b/app-admin/setools/setools-2.2.ebuild
index 923a437fb0b1..60cce50b22c3 100644
--- a/app-admin/setools/setools-2.2.ebuild
+++ b/app-admin/setools/setools-2.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-2.2.ebuild,v 1.1 2005/11/08 01:42:25 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-2.2.ebuild,v 1.2 2005/11/12 23:23:09 pebenito Exp $
+
+inherit eutils
DESCRIPTION="SELinux policy tools"
HOMEPAGE="http://www.tresys.com/selinux_policy_tools.html"
@@ -33,6 +35,8 @@ src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/setools-2.2-nogui.diff
+
# fix the Makefile to listen to portage CFLAGS
sed -i -e "/^CFLAGS/s/-O2/${CFLAGS}/g" ${S}/Makefile
sed -i -e "/^CFLAGS/s/-O2/${CFLAGS}/" ${S}/libsefs/sqlite/Makefile