summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-02-28 04:25:10 +0000
committerAron Griffis <agriffis@gentoo.org>2003-02-28 04:25:10 +0000
commit0c2019560cfedf19a82ef5bde389f8c5ab35fc71 (patch)
tree7b3728c292e9cc7dbafcf7b0201c3885f5fda03f /app-admin/syslog-ng
parentadd ~alpha (diff)
downloadgentoo-2-0c2019560cfedf19a82ef5bde389f8c5ab35fc71.tar.gz
gentoo-2-0c2019560cfedf19a82ef5bde389f8c5ab35fc71.tar.bz2
gentoo-2-0c2019560cfedf19a82ef5bde389f8c5ab35fc71.zip
fix bug 16308 and add ~alpha
Diffstat (limited to 'app-admin/syslog-ng')
-rw-r--r--app-admin/syslog-ng/ChangeLog10
-rw-r--r--app-admin/syslog-ng/files/syslog-ng.rc614
-rw-r--r--app-admin/syslog-ng/syslog-ng-1.5.26-r1.ebuild50
3 files changed, 72 insertions, 2 deletions
diff --git a/app-admin/syslog-ng/ChangeLog b/app-admin/syslog-ng/ChangeLog
index f248df76523c..532dd4922381 100644
--- a/app-admin/syslog-ng/ChangeLog
+++ b/app-admin/syslog-ng/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/syslog-ng
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/ChangeLog,v 1.21 2003/02/12 02:27:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/ChangeLog,v 1.22 2003/02/28 04:25:10 agriffis Exp $
+
+*syslog-ng-1.5.26-r1 (27 Feb 2003)
+
+ 27 Feb 2003; Aron Griffis <agriffis@gentoo.org> syslog-ng-1.5.26-r1.ebuild,
+ files/syslog-ng.rc6:
+ Fix bug 16308 by adding a reload() function to the init script. Bumped the
+ masked revision to pick up the change. Thanks to Michael Sterrett for his
+ work debugging and providing the patch. Also added ~alpha to KEYWORDS.
*syslog-ng-1.5.26 (09 Feb 2003)
diff --git a/app-admin/syslog-ng/files/syslog-ng.rc6 b/app-admin/syslog-ng/files/syslog-ng.rc6
index e3eba4361d56..e581d4b24b59 100644
--- a/app-admin/syslog-ng/files/syslog-ng.rc6
+++ b/app-admin/syslog-ng/files/syslog-ng.rc6
@@ -1,7 +1,9 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/files/syslog-ng.rc6,v 1.9 2003/02/14 22:34:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/files/syslog-ng.rc6,v 1.10 2003/02/28 04:25:10 agriffis Exp $
+
+opts="depend checkconfig start stop reload"
depend() {
need clock hostname
@@ -29,3 +31,13 @@ stop() {
eend $? "Failed to stop syslog-ng"
sleep 1 # needed for syslog-ng to stop in case we're restarting
}
+
+reload() {
+ if [ ! -f /var/run/syslog-ng.pid ]; then
+ eerror "syslog-ng isn't running"
+ return 1
+ fi
+ ebegin "Reloading configuration and re-opening log files"
+ kill -HUP `cat /var/run/syslog-ng.pid` &>/dev/null
+ eend $?
+}
diff --git a/app-admin/syslog-ng/syslog-ng-1.5.26-r1.ebuild b/app-admin/syslog-ng/syslog-ng-1.5.26-r1.ebuild
new file mode 100644
index 000000000000..56c36b2aae93
--- /dev/null
+++ b/app-admin/syslog-ng/syslog-ng-1.5.26-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/syslog-ng/syslog-ng-1.5.26-r1.ebuild,v 1.1 2003/02/28 04:25:10 agriffis Exp $
+
+DESCRIPTION="Syslog-ng is a syslog replacement with advanced filtering features"
+SRC_URI="http://www.balabit.hu/downloads/syslog-ng/1.5/${P}.tar.gz"
+HOMEPAGE="http://www.balabit.hu/en/downloads/syslog-ng/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="tcpd"
+
+DEPEND=">=dev-libs/libol-0.3.9
+ sys-devel/flex
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--enable-tcp-wrapper"
+ econf ${myconf}
+
+ emake prefix=${D}/usr all || die "compile problem"
+}
+
+src_install() {
+ einstall
+ rm -rf ${D}/usr/share/man
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS PORTS README
+ dodoc doc/{syslog-ng.conf.sample,syslog-ng.conf.demo,stresstest.sh}
+ doman doc/{syslog-ng.8,syslog-ng.conf.5}
+ dodoc doc/sgml/{syslog-ng.dvi,syslog-ng.html.tar.gz,syslog-ng.ps,syslog-ng.sgml,syslog-ng.txt}
+
+ insinto /usr/share/doc/${PF}
+ doins contrib/syslog2ng
+
+ dodir /etc/syslog-ng
+ insinto /etc/syslog-ng
+ doins ${FILESDIR}/syslog-ng.conf.sample
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/syslog-ng.rc6 syslog-ng
+}
+
+pkg_postinst() {
+ einfo "A sample configuration file can be found in /etc/syslog-ng."
+ einfo "To convert your existing syslog.conf for use with syslog-ng,"
+ einfo "use the syslog2ng script in /usr/share/doc/${PF}."
+}