summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-04 03:05:44 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-04 03:05:44 +0000
commit6c8d7107514868f03b1035153a543db83ab20197 (patch)
tree2040aae1d1e5974b14a1b3aeb4695239d4131edc /app-admin/testdisk/testdisk-5.9.ebuild
parentDon't assign default to S. (diff)
downloadgentoo-2-6c8d7107514868f03b1035153a543db83ab20197.tar.gz
gentoo-2-6c8d7107514868f03b1035153a543db83ab20197.tar.bz2
gentoo-2-6c8d7107514868f03b1035153a543db83ab20197.zip
version bump. QA stop installing INSTALL, COPYING. x86 stable on testdisk-5.7
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-admin/testdisk/testdisk-5.9.ebuild')
-rw-r--r--app-admin/testdisk/testdisk-5.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/testdisk/testdisk-5.9.ebuild b/app-admin/testdisk/testdisk-5.9.ebuild
new file mode 100644
index 000000000000..a7507a656f35
--- /dev/null
+++ b/app-admin/testdisk/testdisk-5.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-5.9.ebuild,v 1.1 2005/09/04 03:05:44 dragonheart Exp $
+
+
+MY_P=${P}-WIP
+
+DESCRIPTION="Multi-platform tool to check and undelete partition, supports reiserfs, ntfs, fat32, ext2/3 and many others. Also includes PhotoRec to recover pictures from digital camera memory."
+HOMEPAGE="http://www.cgsecurity.org/index.html?testdisk.html"
+SRC_URI="http://www.cgsecurity.org/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static reiserfs ntfs"
+DEPEND=">=sys-libs/ncurses-5.2
+ ntfs? ( >=sys-fs/ntfsprogs-1.9.4 )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35"
+RDEPEND="!static? ( ${DEPEND} )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf $(use_with ntfs) $(use_with reiserfs) || die
+ if use static
+ then
+ emake smallstatic || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ mv ${D}/usr/share/doc/${MY_P} ${D}/usr/share/doc/${PF}
+ rm ${D}/usr/share/doc/${PF}/COPYING ${D}/usr/share/doc/${PF}/INSTALL
+}
+