summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-06-27 08:57:24 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-06-27 08:57:24 +0000
commitce9fc34db6c83bdd6423920bbbc954d9bb5d055f (patch)
tree38b001d63c8adcda1ef5e6da9acc5479112f302e /app-admin/testdisk
parentVersion bump wrt bug #183373. (diff)
downloadgentoo-2-ce9fc34db6c83bdd6423920bbbc954d9bb5d055f.tar.gz
gentoo-2-ce9fc34db6c83bdd6423920bbbc954d9bb5d055f.tar.bz2
gentoo-2-ce9fc34db6c83bdd6423920bbbc954d9bb5d055f.zip
version bump thanks to upstream notification service. Cheers Christophe
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-admin/testdisk')
-rw-r--r--app-admin/testdisk/ChangeLog8
-rw-r--r--app-admin/testdisk/files/digest-testdisk-6.73
-rw-r--r--app-admin/testdisk/files/testdisk-6.7-constdef.patch11
-rw-r--r--app-admin/testdisk/testdisk-6.7.ebuild61
4 files changed, 82 insertions, 1 deletions
diff --git a/app-admin/testdisk/ChangeLog b/app-admin/testdisk/ChangeLog
index 4d5d83da910e..bff26315498e 100644
--- a/app-admin/testdisk/ChangeLog
+++ b/app-admin/testdisk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/testdisk
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.23 2007/02/18 20:22:46 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.24 2007/06/27 08:57:24 dragonheart Exp $
+
+*testdisk-6.7 (27 Jun 2007)
+
+ 27 Jun 2007; Daniel Black <dragonheart@gentoo.org>
+ +files/testdisk-6.7-constdef.patch, +testdisk-6.7.ebuild:
+ version bump thanks to upstream notification service. Cheers Christophe
*testdisk-6.6 (18 Feb 2007)
diff --git a/app-admin/testdisk/files/digest-testdisk-6.7 b/app-admin/testdisk/files/digest-testdisk-6.7
new file mode 100644
index 000000000000..8ac9bbde575b
--- /dev/null
+++ b/app-admin/testdisk/files/digest-testdisk-6.7
@@ -0,0 +1,3 @@
+MD5 cf5f633dbbeadfff0c38d39e1fa56b5e testdisk-6.7.tar.bz2 762396
+RMD160 5514ad8ef2dec793cc130916a4e6e62426d6bb24 testdisk-6.7.tar.bz2 762396
+SHA256 dd3acc1f17414e37f8e6ef71736f17cb69b98d5f84863973753edc19bc644bc8 testdisk-6.7.tar.bz2 762396
diff --git a/app-admin/testdisk/files/testdisk-6.7-constdef.patch b/app-admin/testdisk/files/testdisk-6.7-constdef.patch
new file mode 100644
index 000000000000..a527314892c8
--- /dev/null
+++ b/app-admin/testdisk/files/testdisk-6.7-constdef.patch
@@ -0,0 +1,11 @@
+--- testdisk-6.7/src/ntfsp.c.orig 2007-06-27 18:38:59.000000000 +1000
++++ testdisk-6.7/src/ntfsp.c 2007-06-27 18:48:21.000000000 +1000
+@@ -101,7 +101,7 @@
+ }
+ for(lcn=0;lcn<no_of_cluster;lcn++)
+ {
+- static long long bmplcn = -sizeof_buffer - 1; /* Which bit of $Bitmap is in the buffer */
++ static long long bmplcn = -512 - 1; /* Which bit of $Bitmap is in the buffer */
+ int byte, bit;
+ if ((lcn < bmplcn) || (lcn >= (bmplcn + (sizeof_buffer << 3))))
+ {
diff --git a/app-admin/testdisk/testdisk-6.7.ebuild b/app-admin/testdisk/testdisk-6.7.ebuild
new file mode 100644
index 000000000000..a3365d6129c9
--- /dev/null
+++ b/app-admin/testdisk/testdisk-6.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.7.ebuild,v 1.1 2007/06/27 08:57:24 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="Multi-platform tool to check and undelete partition, supports reiserfs, ntfs, fat32, ext2/3 and many others. Also includes PhotoRec to recover pictures from digital camera memory."
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static reiserfs ntfs jpeg"
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND=">=sys-libs/ncurses-5.2
+ jpeg? ( media-libs/jpeg )
+ ntfs? ( >=sys-fs/ntfsprogs-1.9.4 )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-constdef.patch
+}
+
+src_compile() {
+ local myconf="--without-ewf"
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf="${myconf} --without-reiserfs"
+ use ntfs || myconf="${myconf} --without-ntfs"
+ use jpeg || myconf="${myconf} --without-jpeg"
+
+ econf ${myconf} || die
+
+ # perform safety checks for NTFS and REISERFS
+ if useq ntfs && egrep -q 'undef HAVE_LIBNTFS\>' ${S}/config.h ; then
+ die "Failed to find NTFS library."
+ fi
+ if useq reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' ${S}/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if useq jpeg && egrep -q 'undef HAVE_LIBJPEG\>' ${S}/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ [ "$PF" != "$P" ] && mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+}
+