summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-07-29 23:47:43 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-07-29 23:47:43 +0000
commit695a27681a25ede4c70ef729d2a21f89cd01ad37 (patch)
treee4a0a795b00f5105e68ad07c15f22b21e79e847d /app-admin/webapp-config
parentMarked ~ppc for zzam. (diff)
downloadgentoo-2-695a27681a25ede4c70ef729d2a21f89cd01ad37.tar.gz
gentoo-2-695a27681a25ede4c70ef729d2a21f89cd01ad37.tar.bz2
gentoo-2-695a27681a25ede4c70ef729d2a21f89cd01ad37.zip
fix for move from net-www/apache to www-servers/apache
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/ChangeLog9
-rw-r--r--app-admin/webapp-config/files/digest-webapp-config-1.50.16-r13
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.50.16-apache-move.patch13
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild63
4 files changed, 87 insertions, 1 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index 36a6ce445106..595767a9af85 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/webapp-config
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.51 2007/06/07 14:29:52 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.52 2007/07/29 23:47:43 hollow Exp $
+
+*webapp-config-1.50.16-r1 (29 Jul 2007)
+
+ 29 Jul 2007; Benedikt Böhm <hollow@gentoo.org>
+ +files/webapp-config-1.50.16-apache-move.patch,
+ +webapp-config-1.50.16-r1.ebuild:
+ fix for move from net-www/apache to www-servers/apache
07 Jun 2007; Christian Faulhammer <opfer@gentoo.org> ChangeLog:
modified ChangeLog to meet common standards
diff --git a/app-admin/webapp-config/files/digest-webapp-config-1.50.16-r1 b/app-admin/webapp-config/files/digest-webapp-config-1.50.16-r1
new file mode 100644
index 000000000000..c0d0cea0a270
--- /dev/null
+++ b/app-admin/webapp-config/files/digest-webapp-config-1.50.16-r1
@@ -0,0 +1,3 @@
+MD5 58977a47e0b269d2df2e0b972f09e1a0 webapp-config-1.50.16.tar.gz 103576
+RMD160 d3ab1b27d9b279241d2c9ff3b764ac0b9699b0a0 webapp-config-1.50.16.tar.gz 103576
+SHA256 cd5cf95d0abc9b469b08e6fffa885df10d3651d558164d35efe8e45df1fc8a5f webapp-config-1.50.16.tar.gz 103576
diff --git a/app-admin/webapp-config/files/webapp-config-1.50.16-apache-move.patch b/app-admin/webapp-config/files/webapp-config-1.50.16-apache-move.patch
new file mode 100644
index 000000000000..6f9a30e7a689
--- /dev/null
+++ b/app-admin/webapp-config/files/webapp-config-1.50.16-apache-move.patch
@@ -0,0 +1,13 @@
+Index: webapp-config-1.50.16/WebappConfig/server.py
+===================================================================
+--- webapp-config-1.50.16.orig/WebappConfig/server.py
++++ webapp-config-1.50.16/WebappConfig/server.py
+@@ -300,7 +300,7 @@ class Apache(Basic):
+
+ name = 'Apache'
+ desc = 'supports installation on Apache 1 & 2'
+- dep = '>=net-www/apache-1.3'
++ dep = '>=www-servers/apache-1.3'
+
+ def set_server_user(self):
+ self.vhost_server_uid = get_user('apache')
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild
new file mode 100644
index 000000000000..df36d7d9c989
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild,v 1.1 2007/07/29 23:47:43 hollow Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://build.pardus.de/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-apache-move.patch
+}
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+src_test() {
+ cd ${S}
+ distutils_python_version
+ if [[ $PYVER_MAJOR > 1 ]] && [[ $PYVER_MINOR > 3 ]] ; then
+ elog "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+ else
+ elog "Python version below 2.4! Disabling tests."
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+ echo
+ epause 5
+}