summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-30 10:36:07 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-30 10:36:07 +0000
commit27fe45b13a015f9c2e8968f150cfe5f97183e3ad (patch)
tree7e89961ba3545cf74f9528fd1bd086ababa4535a /app-admin/webmin
parentstable x86, bug 197313 (diff)
downloadgentoo-2-27fe45b13a015f9c2e8968f150cfe5f97183e3ad.tar.gz
gentoo-2-27fe45b13a015f9c2e8968f150cfe5f97183e3ad.tar.bz2
gentoo-2-27fe45b13a015f9c2e8968f150cfe5f97183e3ad.zip
Fix init script for baselayout-1 and 2, #194143
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog8
-rw-r--r--app-admin/webmin/files/digest-webmin-1.370-r19
-rw-r--r--app-admin/webmin/files/init.d.webmin17
-rw-r--r--app-admin/webmin/webmin-1.370-r1.ebuild132
4 files changed, 157 insertions, 9 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index 1ca5b5f8fa53..25d19c83e2eb 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/webmin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.156 2007/10/28 12:43:28 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.157 2007/10/30 10:36:06 uberlord Exp $
+
+*webmin-1.370-r1 (30 Oct 2007)
+
+ 30 Oct 2007; Roy Marples <uberlord@gentoo.org> files/init.d.webmin,
+ +webmin-1.370-r1.ebuild:
+ Fix init script for baselayout-1 and 2, #194143
28 Oct 2007; Christian Heim <phreak@gentoo.org> webmin-1.350.ebuild,
webmin-1.370.ebuild:
diff --git a/app-admin/webmin/files/digest-webmin-1.370-r1 b/app-admin/webmin/files/digest-webmin-1.370-r1
new file mode 100644
index 000000000000..db7dd78aa85a
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.370-r1
@@ -0,0 +1,9 @@
+MD5 f74d252d7fa9c736895fb3a257dd3edc virtual-server-3.23.gpl.wbm.gz 379417
+RMD160 912ba4ff66b7644f05e7e5b52286b5a41cf7163d virtual-server-3.23.gpl.wbm.gz 379417
+SHA256 c5631f73921058df40a08b0d248bad1acf1dd5b7ded451c7c6f9fff1d923a360 virtual-server-3.23.gpl.wbm.gz 379417
+MD5 bcc81735c006f533d4e379d0394e606f webmin-1.370-minimal.tar.gz 1448705
+RMD160 110dc5aa3a4b8ee916bb0163d4d6cc7733c32652 webmin-1.370-minimal.tar.gz 1448705
+SHA256 16602d7df679b1e711aeb96d6191ce4ea3d1a3cae5ae2670e7cc6822eaa0dd12 webmin-1.370-minimal.tar.gz 1448705
+MD5 4138359051ca5f1fa3967aaa1e346e69 webmin-1.370.tar.gz 13132344
+RMD160 28805b553adc85b642ad3acffa3765a5127a529d webmin-1.370.tar.gz 13132344
+SHA256 db75b4dd0e65933e41bb95a73e70171d5c8bc19c280b2016fc0f0cabb0697be9 webmin-1.370.tar.gz 13132344
diff --git a/app-admin/webmin/files/init.d.webmin b/app-admin/webmin/files/init.d.webmin
index 832976c9a2e3..76498914a17d 100644
--- a/app-admin/webmin/files/init.d.webmin
+++ b/app-admin/webmin/files/init.d.webmin
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/files/init.d.webmin,v 1.5 2007/06/09 14:25:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/files/init.d.webmin,v 1.6 2007/10/30 10:36:07 uberlord Exp $
depend() {
use net logger
@@ -9,13 +9,13 @@ depend() {
checkconfig() {
- if [ -f /etc/webmin/config ]; then
- return 0;
- else
+ if [ ! -f /etc/webmin/config ]; then
eerror "Error starting webmin. /etc/webmin/config is not present."
eerror "Please report this on http://bugs.gentoo.org."
- return 1;
+ return 1
fi
+
+ return 0
}
start() { # copied from /etc/usermin/start
@@ -27,13 +27,14 @@ start() { # copied from /etc/usermin/start
unset PERLIO
export PERLIO
- start-stop-daemon --start --quiet --name webmin --oknodo \
- --exec /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
+ start-stop-daemon --start --exec /usr/libexec/webmin/miniserv.pl \
+ --pidfile /var/run/webmin.pid \
+ -- /etc/webmin/miniserv.conf
eend $?
}
stop() {
ebegin "Stopping Webmin"
- start-stop-daemon --stop --pidfile /var/run/webmin.pid --quiet
+ start-stop-daemon --stop --quiet --pidfile /var/run/webmin.pid
eend $?
}
diff --git a/app-admin/webmin/webmin-1.370-r1.ebuild b/app-admin/webmin/webmin-1.370-r1.ebuild
new file mode 100644
index 000000000000..3965606621aa
--- /dev/null
+++ b/app-admin/webmin/webmin-1.370-r1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.370-r1.ebuild,v 1.1 2007/10/30 10:36:06 uberlord Exp $
+
+inherit eutils pam
+
+VM_V="3.23"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+HOMEPAGE="http://www.webmin.com/"
+SRC_URI="webmin-minimal? ( mirror://sourceforge/webadmin/${P}-minimal.tar.gz )
+ !webmin-minimal? ( mirror://sourceforge/webadmin/${P}.tar.gz
+ http://www.webmin.com/download/virtualmin/virtual-server-${VM_V}.gpl.wbm.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+# ~mips removed because of broken deps. Bug #86085
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="apache2 pam postgres ssl webmin-minimal"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ ssl? ( dev-perl/Net-SSLeay )
+ postgres? ( dev-perl/DBD-Pg )
+ pam? ( dev-perl/Authen-PAM )
+ dev-perl/XML-Generator
+ virtual/logger"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # in webmin-minimal apache2 are not present
+ if ! use webmin-minimal ; then
+ # Bug #50810, #51943
+ if use apache2; then
+ epatch "${FILESDIR}"/${PN}-1.140-apache2.patch
+ fi
+
+ # Correct ldapness
+ epatch "${FILESDIR}"/${PN}-1.270-ldap-useradmin.patch
+
+ # Postfix should modify the last entry of the maps file
+ epatch "${FILESDIR}"/${PN}-1.300-postfix.patch
+
+ mv ${WORKDIR}/virtual-server-${VM_V}.gpl.wbm ${T}/vs.tar
+ tar -xf ${T}/vs.tar
+
+ # Don't create ${HOME}/cgi-bin on new accounts
+ epatch "${FILESDIR}"/virtual-server-3.23-nocgibin.patch
+
+ # Verify Postgres usernames
+ epatch "${FILESDIR}"/virtual-server-3.23-pgsql.patch
+ fi
+
+ epatch "${FILESDIR}"/${PN}-1.170-setup-nocheck.patch
+}
+
+src_install() {
+ # Bug #97212
+ addpredict /var/lib/rpm
+
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /var
+
+ cp -rp * ${D}/usr/libexec/webmin
+
+ # in webmin-minimal openslp is not present
+ if [ ! -f "${D}/usr/libexec/webmin/openslp/config-gentoo-linux" ] ; then
+ cp ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+ fi
+
+ newinitd "${FILESDIR}"/init.d.webmin webmin
+
+ newpamd "${FILESDIR}"/webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ # Fix ownership
+ chown -R root:0 ${D}
+
+ dodir /etc/webmin
+ dodir /var/log/webmin
+
+ config_dir=${D}/etc/webmin
+ var_dir=${D}/var/log/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ ${D}/usr/libexec/webmin/setup.sh > ${T}/webmin-setup.out 2>&1 || die "Failed to create initial webmin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=/var/run/webmin.pid:" ${D}/etc/webmin/miniserv.conf
+ find ${D}/etc/webmin -type f | xargs sed -i -e "s:${D}:/:g"
+
+ # Cleanup from the config script
+ rm -rf ${D}/var/log/webmin
+ keepdir /var/log/webmin/
+
+ # Get rid of this crap...
+ rm -rf ${D}/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1
+ rm -f ${D}/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1.tar.gz
+}
+
+pkg_postinst() {
+ local crypt=$(grep "^root:" ${ROOT}/etc/shadow | cut -f 2 -d :)
+ crypt=${crypt//\\/\\\\}
+ crypt=${crypt//\//\\\/}
+ sed -i -e "s/root:XXX/root:${crypt}/" "${ROOT}/etc/webmin/miniserv.users"
+
+ einfo "To make webmin start at boot time, run: 'rc-update add webmin default'."
+ use ssl && einfo "Point your web browser to https://localhost:10000 to use webmin."
+ use ssl || einfo "Point your web browser to http://localhost:10000 to use webmin."
+}