summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-02 23:53:58 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-02 23:53:58 +0000
commit332fc847a7f58ad2e16c6cd82445d00504eb4b37 (patch)
tree4b032ff22e8ba9e6c729e68aeb4361ebcf19e925 /app-admin/xstow
parentchangelog fix .. (diff)
downloadgentoo-2-332fc847a7f58ad2e16c6cd82445d00504eb4b37.tar.gz
gentoo-2-332fc847a7f58ad2e16c6cd82445d00504eb4b37.tar.bz2
gentoo-2-332fc847a7f58ad2e16c6cd82445d00504eb4b37.zip
new package
Diffstat (limited to 'app-admin/xstow')
-rw-r--r--app-admin/xstow/files/digest-xstow-0.4.61
-rw-r--r--app-admin/xstow/files/xstow-0.4.6-configure-ncurses.diff82
-rw-r--r--app-admin/xstow/xstow-0.4.6.ebuild40
3 files changed, 123 insertions, 0 deletions
diff --git a/app-admin/xstow/files/digest-xstow-0.4.6 b/app-admin/xstow/files/digest-xstow-0.4.6
new file mode 100644
index 000000000000..b46291fb305d
--- /dev/null
+++ b/app-admin/xstow/files/digest-xstow-0.4.6
@@ -0,0 +1 @@
+MD5 ffb06e41ad1ce460e91b1bfe4f47b4d8 xstow-0.4.6.tar.gz 149152
diff --git a/app-admin/xstow/files/xstow-0.4.6-configure-ncurses.diff b/app-admin/xstow/files/xstow-0.4.6-configure-ncurses.diff
new file mode 100644
index 000000000000..11ae4ad30858
--- /dev/null
+++ b/app-admin/xstow/files/xstow-0.4.6-configure-ncurses.diff
@@ -0,0 +1,82 @@
+--- xstow-0.4.6/configure 2002-12-06 08:12:57.000000000 -0500
++++ xstow-0.4.6-new/configure 2003-03-03 16:50:00.000000000 -0500
+@@ -4180,70 +4180,6 @@
+ if test $ac_cv_header_curses_h = yes; then
+
+ # test which libraray to use
+- echo "$as_me:4183: checking for initscr in -lcurses" >&5
+-echo $ECHO_N "checking for initscr in -lcurses... $ECHO_C" >&6
+-if test "${ac_cv_lib_curses_initscr+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcurses $LIBS"
+-cat >conftest.$ac_ext <<_ACEOF
+-#line 4191 "configure"
+-#include "confdefs.h"
+-
+-/* Override any gcc2 internal prototype to avoid an error. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char initscr ();
+-int
+-main ()
+-{
+-initscr ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:4210: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:4213: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:4216: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:4219: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_lib_curses_initscr=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-cat conftest.$ac_ext >&5
+-ac_cv_lib_curses_initscr=no
+-fi
+-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-echo "$as_me:4230: result: $ac_cv_lib_curses_initscr" >&5
+-echo "${ECHO_T}$ac_cv_lib_curses_initscr" >&6
+-if test $ac_cv_lib_curses_initscr = yes; then
+-
+- support_curses=1
+- LDFLAGS_DYNAMIC="$LDFLAGS -lcurses"
+-
+-cat >>confdefs.h <<\EOF
+-#define HAVE_CURSES_H 1
+-EOF
+-
+-else
+- support_curses=0
+-fi
+-
+- if test $support_curses -eq 0; then
+-
+ echo "$as_me:4247: checking for initscr in -lncurses" >&5
+ echo $ECHO_N "checking for initscr in -lncurses... $ECHO_C" >&6
+ if test "${ac_cv_lib_ncurses_initscr+set}" = set; then
+@@ -4306,8 +4242,6 @@
+ support_curses=0
+ fi
+
+- fi
+-
+ else
+
+ support_curses=0
diff --git a/app-admin/xstow/xstow-0.4.6.ebuild b/app-admin/xstow/xstow-0.4.6.ebuild
new file mode 100644
index 000000000000..0cb946abc2d8
--- /dev/null
+++ b/app-admin/xstow/xstow-0.4.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/xstow/xstow-0.4.6.ebuild,v 1.1 2003/04/02 23:53:58 liquidx Exp $
+
+IUSE="ncurses"
+
+inherit eutils
+
+DESCRIPTION="XStow is a replacement for GNU stow with extensions"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://xstow.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ ncurses? ( sys-libs/ncurses )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-configure-ncurses.diff
+}
+
+src_compile() {
+ local myconf
+ use ncurses || myconf="--without-ncurses"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dodoc README AUTHORS COPYING NEWS README TODO ChangeLog
+ make DESTDIR=${D} PACKAGE=${P} install || die
+}