summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2004-10-07 21:03:08 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2004-10-07 21:03:08 +0000
commit111eec381a39e2d66434b33a3349bb0dc2f31386 (patch)
treedda980814120bf13f8c7f98e853354edc14b3a64 /app-admin
parentver bump (Manifest recommit) (diff)
downloadgentoo-2-111eec381a39e2d66434b33a3349bb0dc2f31386.tar.gz
gentoo-2-111eec381a39e2d66434b33a3349bb0dc2f31386.tar.bz2
gentoo-2-111eec381a39e2d66434b33a3349bb0dc2f31386.zip
Now sets default instance if it wasnt set before (on instance creation).
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/zope-config/ChangeLog9
-rw-r--r--app-admin/zope-config/files/0.5/zope-config-0.5.patch26
-rw-r--r--app-admin/zope-config/files/digest-zope-config-0.50
-rw-r--r--app-admin/zope-config/zope-config-0.5.ebuild38
4 files changed, 72 insertions, 1 deletions
diff --git a/app-admin/zope-config/ChangeLog b/app-admin/zope-config/ChangeLog
index 50f9749cd548..932757938541 100644
--- a/app-admin/zope-config/ChangeLog
+++ b/app-admin/zope-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/zope-config
# Copyright 2003-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/zope-config/ChangeLog,v 1.28 2004/10/05 02:58:11 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/zope-config/ChangeLog,v 1.29 2004/10/07 21:03:07 radek Exp $
+
+*zope-config-0.5 (07 Oct 2004)
+
+ 07 Oct 2004; Radoslaw Stachowiak <radek@gentoo.org>
+ +files/0.5/zope-config-0.5.patch, +zope-config-0.5.ebuild:
+ Now sets default instance if it wasnt set before (on instance creation).
+ Released as a patch to 0.4 release !!!
05 Oct 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
zope-config-0.1-r1.ebuild, zope-config-0.4-r3.ebuild:
diff --git a/app-admin/zope-config/files/0.5/zope-config-0.5.patch b/app-admin/zope-config/files/0.5/zope-config-0.5.patch
new file mode 100644
index 000000000000..a694ddc79991
--- /dev/null
+++ b/app-admin/zope-config/files/0.5/zope-config-0.5.patch
@@ -0,0 +1,26 @@
+--- files/0.4/zope-config 2004-10-07 22:50:21.213319592 +0200
++++ /usr/sbin/zope-config 2004-10-07 22:45:46.249120504 +0200
+@@ -95,12 +95,17 @@
+ else
+ ${BIN}/mkzopeinstance.py --dir $2
+ fi
+- # create the log directory
+- mkdir ${EVENTLOGDIR}/${ZIRC_NAME}
+- # remove log directory in skeltarget
+- rm -r $2/log
+- # symlink log directory
+- ln -s ${EVENTLOGDIR}/${ZIRC_NAME} $2/log
++ # sets default instance if just created is first one
++ if [ $(zinst_default_get >/dev/null)$? -ne 0 ] ; then
++ echo $(basename ${ZINST_DIR}) >${ZI_DIR}/.default
++ chown zope:root ${ZI_DIR}/.default
++ fi
++ # create the log directory
++ mkdir ${EVENTLOGDIR}/${ZIRC_NAME}
++ # remove log directory in skeltarget
++ rm -r $2/log
++ # symlink log directory
++ ln -s ${EVENTLOGDIR}/${ZIRC_NAME} $2/log
+ RESULT=$?
+ else
+ if [ $NEWZOPE = 1 ] ; then
diff --git a/app-admin/zope-config/files/digest-zope-config-0.5 b/app-admin/zope-config/files/digest-zope-config-0.5
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-admin/zope-config/files/digest-zope-config-0.5
diff --git a/app-admin/zope-config/zope-config-0.5.ebuild b/app-admin/zope-config/zope-config-0.5.ebuild
new file mode 100644
index 000000000000..ccbf6457fae2
--- /dev/null
+++ b/app-admin/zope-config/zope-config-0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/zope-config/zope-config-0.5.ebuild,v 1.1 2004/10/07 21:03:07 radek Exp $
+
+DESCRIPTION="A Gentoo Zope multi-Instance configure tool"
+SRC_URI=""
+HOMEPAGE="http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+IUSE=""
+DEPEND=""
+RDEPEND=">=dev-util/dialog-0.7
+ sys-apps/grep
+ sys-apps/sed
+ sys-apps/shadow
+ dev-lang/python
+ sys-apps/coreutils"
+
+PDEPEND=">=net-zope/zope-2.7.2-r2"
+
+src_install() {
+ # the script
+ dosbin ${FILESDIR}/0.4/zope-config
+ patch ${D}/usr/sbin/zope-config ${FILESDIR}/${PV}/${P}.patch
+
+ # config file
+ insinto /etc
+ doins ${FILESDIR}/0.4/zope-config.conf
+ # ensure this directory exists
+ keepdir /var/log/zope
+}
+
+pkg_postinst() {
+ source ${FILESDIR}/0.4/zope-config.conf
+ einfo "Please note that new instances now log into ${EVENTLOGDIR}"
+ einfo "Please see the configuration file /etc/zope-config.conf"
+}