summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-23 16:57:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-23 16:57:34 +0000
commit9f05f75aaaeecc6777a97362a064ac3d801200bc (patch)
tree44d028859194cc9cb2f08fb349dd792988c68311 /app-admin
parentBump to 1.470, fixes half of #264086 (diff)
downloadgentoo-2-9f05f75aaaeecc6777a97362a064ac3d801200bc.tar.gz
gentoo-2-9f05f75aaaeecc6777a97362a064ac3d801200bc.tar.bz2
gentoo-2-9f05f75aaaeecc6777a97362a064ac3d801200bc.zip
Bump to 1.400. Fixes second half of #264086
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/usermin/ChangeLog9
-rw-r--r--app-admin/usermin/usermin-1.400.ebuild85
2 files changed, 92 insertions, 2 deletions
diff --git a/app-admin/usermin/ChangeLog b/app-admin/usermin/ChangeLog
index a34ad0666c62..ad40f5385b5d 100644
--- a/app-admin/usermin/ChangeLog
+++ b/app-admin/usermin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/usermin
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.147 2008/04/15 01:37:59 beandog Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.148 2009/04/23 16:57:34 patrick Exp $
+
+*usermin-1.400 (23 Apr 2009)
+
+ 23 Apr 2009; Patrick Lauer <patrick@gentoo.org> +usermin-1.400.ebuild:
+ Bump to 1.400. Fixes second half of #264086
15 Apr 2008; Steve Dibb <beandog@gentoo.org> usermin-1.330.ebuild:
Drop stable keywords, bug 217582
diff --git a/app-admin/usermin/usermin-1.400.ebuild b/app-admin/usermin/usermin-1.400.ebuild
new file mode 100644
index 000000000000..b0fd4859bba9
--- /dev/null
+++ b/app-admin/usermin/usermin-1.400.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/usermin-1.400.ebuild,v 1.1 2009/04/23 16:57:34 patrick Exp $
+
+IUSE="ssl"
+
+inherit eutils pam
+
+DESCRIPTION="a web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/perl"
+
+RDEPEND="${DEPEND}
+ sys-process/lsof
+ ssl? ( dev-perl/Net-SSLeay )"
+
+# pam? ( dev-perl/Authen-PAM )
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # Point to the correct mysql location
+ sed -i -e "s:/usr/local/mysql:/usr:g" mysql/config
+
+ epatch "${FILESDIR}"/${PN}-1.080-safestop.patch
+ epatch "${FILESDIR}"/${PN}-1.150-setup-nocheck.patch
+}
+
+src_install() {
+ # Change /usr/local/bin/perl references
+ find . -type f | xargs sed -i -e 's:^#!.*/usr/local/bin/perl:#!/usr/bin/perl:'
+
+ dodir /usr/libexec/usermin
+ cp -pR * "${D}"/usr/libexec/usermin
+
+ newinitd "${FILESDIR}"/init.d.usermin usermin
+
+ newpamd "${FILESDIR}"/${PN}.pam-include.1 ${PN}
+
+ # Fix ownership
+ chown -R root:0 "${D}"
+
+ dodir /etc/usermin
+ dodir /var/log/usermin
+
+ config_dir=${D}/etc/usermin
+ var_dir=${D}/var/log/usermin
+ perl=/usr/bin/perl
+ autoos=1
+ port=20000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ "${D}"/usr/libexec/usermin/setup.sh > "${T}"/usermin-setup.out 2>&1 || die "Failed to create initial usermin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=/var/run/usermin.pid:" "${D}"/etc/usermin/miniserv.conf
+ find "${D}"/etc/usermin -type f | xargs sed -i -e "s:${D}:/:g"
+
+ # Cleanup from the config script
+ rm -rf "${D}"/var/log/usermin
+ keepdir /var/log/usermin/
+}
+
+pkg_postinst() {
+ elog "To make usermin start at boot time, run: 'rc-update add usermin default'."
+ elog "Point your web browser to https://localhost:20000 to use usermin."
+}