summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-10 01:20:03 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-10 01:20:03 +0000
commita77f5d76bbe40bb1589458d047d7c555cee1e570 (patch)
treefa538157252082f9b7555791869614ea37457f1f /app-admin
parentwebmin masked (diff)
downloadgentoo-2-a77f5d76bbe40bb1589458d047d7c555cee1e570.tar.gz
gentoo-2-a77f5d76bbe40bb1589458d047d7c555cee1e570.tar.bz2
gentoo-2-a77f5d76bbe40bb1589458d047d7c555cee1e570.zip
new package
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webmin/ChangeLog12
-rw-r--r--app-admin/webmin/files/digest-webmin-0.9921
-rw-r--r--app-admin/webmin/webmin-0.992.ebuild69
3 files changed, 82 insertions, 0 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
new file mode 100644
index 000000000000..1d5371c9892a
--- /dev/null
+++ b/app-admin/webmin/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-admin/webmin
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.1 2002/07/10 01:20:03 seemant Exp $
+
+*webmin-0.992 (09 Jul 2002)
+
+ 09 Jul 2002; Seemant Kulleen <seemant@gentoo.org> webmin-0.992.ebuild
+ ChangeLog files/digest-webmin-0.992 :
+
+ Jamie Cameron, the venerable upstream author of Webmin, wrote us an
+ ebuild.
+
diff --git a/app-admin/webmin/files/digest-webmin-0.992 b/app-admin/webmin/files/digest-webmin-0.992
new file mode 100644
index 000000000000..9d5209bd3978
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-0.992
@@ -0,0 +1 @@
+MD5 3a44a10083fe66ed7fc9034c510f7571 webmin-0.992.tar.gz 5255411
diff --git a/app-admin/webmin/webmin-0.992.ebuild b/app-admin/webmin/webmin-0.992.ebuild
new file mode 100644
index 000000000000..8995d567f771
--- /dev/null
+++ b/app-admin/webmin/webmin-0.992.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2002, Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-0.992.ebuild,v 1.1 2002/07/10 01:20:03 seemant Exp $
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="http://www.webmin.com/download/${P}.tar.gz"
+HOMEPAGE="http://www.webmin.com/"
+DEPEND="sys-devel/perl"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ mkdir -p ${D}/usr/libexec/webmin
+ mkdir -p ${D}/etc/init.d
+ mkdir -p ${D}/var
+ mkdir -p ${D}/etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ cp webmin-gentoo-init ${D}/etc/init.d/webmin
+ cp webmin-pam ${D}/etc/pam.d/webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+ cat >/etc/webmin/uninstall.sh <<EOF
+#!/bin/sh
+printf "Are you sure you want to uninstall Webmin? (y/n) : "
+read answer
+printf "\\n"
+if [ "\\\$answer" = "y" ]; then
+ echo "Removing webmin package .."
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ emerge unmerge webmin
+ echo "Done!"
+fi
+EOF
+ chmod +x /etc/webmin/uninstall.sh
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}
+
+