summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-17 18:39:10 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-17 18:39:10 +0000
commitac055d3a8e750ceb2927913f120de32269ea6305 (patch)
treeea7165a254d7dcabb3dcdec3a2af9b98c0eef147 /app-admin
parentalpha/ia64/s390/sh/sparc stable wrt #413597 (diff)
downloadgentoo-2-ac055d3a8e750ceb2927913f120de32269ea6305.tar.gz
gentoo-2-ac055d3a8e750ceb2927913f120de32269ea6305.tar.bz2
gentoo-2-ac055d3a8e750ceb2927913f120de32269ea6305.zip
Fix tests, thanks prometheanfire, bug #421091
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/ChangeLog7
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.50.16-fix-unicode-tests.patch39
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r4.ebuild3
3 files changed, 47 insertions, 2 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index eacd66426cd1..2cc67b560416 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/webapp-config
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.74 2012/06/14 06:35:06 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.75 2012/06/17 18:39:10 blueness Exp $
+
+ 17 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
+ webapp-config-1.50.16-r4.ebuild,
+ +files/webapp-config-1.50.16-fix-unicode-tests.patch:
+ Fix tests, thanks prometheanfire, bug #421091
14 Jun 2012; Jeff Horelick <jdhore@gentoo.org>
webapp-config-1.50.16-r4.ebuild:
diff --git a/app-admin/webapp-config/files/webapp-config-1.50.16-fix-unicode-tests.patch b/app-admin/webapp-config/files/webapp-config-1.50.16-fix-unicode-tests.patch
new file mode 100644
index 000000000000..cad75a2e517f
--- /dev/null
+++ b/app-admin/webapp-config/files/webapp-config-1.50.16-fix-unicode-tests.patch
@@ -0,0 +1,39 @@
+Make strings unicode to fix test failures
+
+Python enables unicode by default. Various quoted strings used
+in tests were not declared as unicode and so caused false failures.
+This patch addresses this issue.
+
+Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
+Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
+
+diff -rupN webapp-config-1.50.16/WebappConfig.orig/db.py webapp-config-1.50.16/WebappConfig/db.py
+--- webapp-config-1.50.16/WebappConfig.orig/db.py 2012-06-17 11:10:15.964264617 -0500
++++ webapp-config-1.50.16/WebappConfig/db.py 2012-06-17 11:11:05.364265831 -0500
+@@ -186,7 +186,7 @@ class WebappDB(AppHierarchy):
+ >>> sb = [i[1] for i in b.list_locations().items()]
+ >>> sb.sort(lambda x,y: cmp(x[0]+x[1],y[0]+y[1]))
+ >>> sb
+- [['gallery', '1.4.4_p6'], ['gallery', '2.0_rc2'], ['horde', '3.0.5'], ['phpldapadmin', '0.9.7_alpha4']]
++ [[u'gallery', u'1.4.4_p6'], [u'gallery', u'2.0_rc2'], [u'horde', u'3.0.5'], [u'phpldapadmin', u'0.9.7_alpha4']]
+
+ >>> c = WebappDB(here + '/tests/testfiles/webapps',
+ ... package = 'horde', version = '3.0.5')
+@@ -572,7 +572,7 @@ class WebappSource(AppHierarchy):
+ ... 'horde', '3.0.5')
+ >>> d = a.get_source_directories('htdocs')
+ >>> [i for i in d if i != '.svn']
+- ['dir1', 'dir2']
++ [u'dir1', u'dir2']
+ '''
+ dirs = []
+
+@@ -604,7 +604,7 @@ class WebappSource(AppHierarchy):
+ >>> a = WebappSource(here + '/tests/testfiles/share-webapps',
+ ... 'horde', '3.0.5')
+ >>> a.get_source_files('htdocs')
+- ['test1', 'test2']
++ [u'test1', u'test2']
+ '''
+
+ files = []
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r4.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r4.ebuild
index 96744da003ad..96cf263dcc03 100644
--- a/app-admin/webapp-config/webapp-config-1.50.16-r4.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.50.16-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r4.ebuild,v 1.4 2012/06/14 06:35:06 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r4.ebuild,v 1.5 2012/06/17 18:39:10 blueness Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -29,6 +29,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-htdocs-symlink.patch"
epatch "${FILESDIR}/${P}-absolute-paths.patch"
epatch "${FILESDIR}/${P}-update-servers.patch"
+ epatch "${FILESDIR}/${P}-fix-unicode-tests.patch"
# Do not build nor install eclass manual, bug 322759
rm -f doc/webapp.eclass.5*
sed -e '/MAN_PAGES/s/webapp.eclass.5//' \