summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-09 07:49:05 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-09 07:49:05 +0000
commitc63d809563eb2287f15eb575225da837b7b51911 (patch)
tree6760c0eb0a6c2c698d13abfc10469ff622a02c7d /app-admin
parentversion bump (diff)
downloadgentoo-2-c63d809563eb2287f15eb575225da837b7b51911.tar.gz
gentoo-2-c63d809563eb2287f15eb575225da837b7b51911.tar.bz2
gentoo-2-c63d809563eb2287f15eb575225da837b7b51911.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sysstat/ChangeLog9
-rw-r--r--app-admin/sysstat/sysstat-11.0.1.ebuild84
-rw-r--r--app-admin/sysstat/sysstat-11.1.1.ebuild84
3 files changed, 176 insertions, 1 deletions
diff --git a/app-admin/sysstat/ChangeLog b/app-admin/sysstat/ChangeLog
index bdc9c8d52f64..8d31e526258c 100644
--- a/app-admin/sysstat/ChangeLog
+++ b/app-admin/sysstat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/sysstat
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.269 2014/09/06 13:05:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.270 2014/09/09 07:49:05 jer Exp $
+
+*sysstat-11.1.1 (09 Sep 2014)
+*sysstat-11.0.1 (09 Sep 2014)
+
+ 09 Sep 2014; Jeroen Roovers <jer@gentoo.org> +sysstat-11.0.1.ebuild,
+ +sysstat-11.1.1.ebuild:
+ Version bump.
06 Sep 2014; Jeroen Roovers <jer@gentoo.org> sysstat-11.0.0.ebuild:
Stable for HPPA (bug #520940).
diff --git a/app-admin/sysstat/sysstat-11.0.1.ebuild b/app-admin/sysstat/sysstat-11.0.1.ebuild
new file mode 100644
index 000000000000..4e6a98c05084
--- /dev/null
+++ b/app-admin/sysstat/sysstat-11.0.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-11.0.1.ebuild,v 1.1 2014/09/09 07:49:05 jer Exp $
+
+EAPI=5
+inherit eutils multilib systemd toolchain-funcs
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
+SRC_URI="${HOMEPAGE}${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="cron debug +doc isag nls lm_sensors selinux"
+
+RDEPEND="
+ cron? ( sys-process/cronbase )
+ isag? (
+ dev-lang/tk
+ dev-vcs/rcs
+ sci-visualization/gnuplot
+ )
+ nls? ( virtual/libintl )
+ lm_sensors? ( sys-apps/lm_sensors )
+ selinux? ( sec-policy/selinux-sysstat )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i nls/
+ local lingua pofile
+ for pofile in nls/*.po; do
+ lingua=${pofile/nls\/}
+ lingua=${lingua/.po}
+ if ! has ${lingua} ${LINGUAS}; then
+ rm "nls/${lingua}.po" || die
+ fi
+ done
+ fi
+ epatch "${FILESDIR}"/${PN}-10.0.4-flags.patch
+}
+
+src_configure() {
+ tc-export AR
+ sa_lib_dir=/usr/$(get_libdir)/sa \
+ conf_dir=/etc \
+ rcdir=Gentoo-does-not-use-rc.d \
+ econf \
+ --enable-copy-only \
+ --with-systemdsystemunitdir=$(systemd_get_unitdir) \
+ $(use_enable cron install-cron) \
+ $(use_enable debug debuginfo) \
+ $(use_enable doc documentation ) \
+ $(use_enable isag install-isag) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ keepdir /var/log/sa
+
+ use cron && dodir /etc/cron.{daily,hourly}
+
+ emake \
+ DESTDIR="${D}" \
+ DOC_DIR=/usr/share/doc/${PF} \
+ install
+
+ dodoc contrib/sargraph/sargraph
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ systemd_dounit ${PN}.service
+
+ use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
+}
diff --git a/app-admin/sysstat/sysstat-11.1.1.ebuild b/app-admin/sysstat/sysstat-11.1.1.ebuild
new file mode 100644
index 000000000000..67b81f52c301
--- /dev/null
+++ b/app-admin/sysstat/sysstat-11.1.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-11.1.1.ebuild,v 1.1 2014/09/09 07:49:05 jer Exp $
+
+EAPI=5
+inherit eutils multilib systemd toolchain-funcs
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
+SRC_URI="${HOMEPAGE}${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="cron debug +doc isag nls lm_sensors selinux"
+
+RDEPEND="
+ cron? ( sys-process/cronbase )
+ isag? (
+ dev-lang/tk
+ dev-vcs/rcs
+ sci-visualization/gnuplot
+ )
+ nls? ( virtual/libintl )
+ lm_sensors? ( sys-apps/lm_sensors )
+ selinux? ( sec-policy/selinux-sysstat )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i nls/
+ local lingua pofile
+ for pofile in nls/*.po; do
+ lingua=${pofile/nls\/}
+ lingua=${lingua/.po}
+ if ! has ${lingua} ${LINGUAS}; then
+ rm "nls/${lingua}.po" || die
+ fi
+ done
+ fi
+ epatch "${FILESDIR}"/${PN}-10.0.4-flags.patch
+}
+
+src_configure() {
+ tc-export AR
+ sa_lib_dir=/usr/$(get_libdir)/sa \
+ conf_dir=/etc \
+ rcdir=Gentoo-does-not-use-rc.d \
+ econf \
+ --enable-copy-only \
+ --with-systemdsystemunitdir=$(systemd_get_unitdir) \
+ $(use_enable cron install-cron) \
+ $(use_enable debug debuginfo) \
+ $(use_enable doc documentation ) \
+ $(use_enable isag install-isag) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ keepdir /var/log/sa
+
+ use cron && dodir /etc/cron.{daily,hourly}
+
+ emake \
+ DESTDIR="${D}" \
+ DOC_DIR=/usr/share/doc/${PF} \
+ install
+
+ dodoc contrib/sargraph/sargraph
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ systemd_dounit ${PN}.service
+
+ use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
+}