summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-08-18 13:05:33 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-08-18 13:05:33 +0000
commite015a9d81f20f14be695e77cac37b99e2cf28e89 (patch)
tree9ca059ea738599f1adfc97621ea016030666cf83 /app-admin
parentRemove old (diff)
downloadgentoo-2-e015a9d81f20f14be695e77cac37b99e2cf28e89.tar.gz
gentoo-2-e015a9d81f20f14be695e77cac37b99e2cf28e89.tar.bz2
gentoo-2-e015a9d81f20f14be695e77cac37b99e2cf28e89.zip
call eautoreconf, improve ebuild syntax, depend.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sxid/ChangeLog8
-rw-r--r--app-admin/sxid/sxid-4.2-r1.ebuild (renamed from app-admin/sxid/sxid-4.2.ebuild)17
2 files changed, 13 insertions, 12 deletions
diff --git a/app-admin/sxid/ChangeLog b/app-admin/sxid/ChangeLog
index a08b0d585494..de9676d5d8a7 100644
--- a/app-admin/sxid/ChangeLog
+++ b/app-admin/sxid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/sxid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/ChangeLog,v 1.27 2012/08/17 17:10:32 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/ChangeLog,v 1.28 2012/08/18 13:05:33 ago Exp $
+
+*sxid-4.2-r1 (18 Aug 2012)
+
+ 18 Aug 2012; Agostino Sarubbo <ago@gentoo.org> +sxid-4.2-r1.ebuild,
+ -sxid-4.2.ebuild:
+ call eautoreconf, improve ebuild syntax, depend.
17 Aug 2012; Michael Palimaka <kensington@gentoo.org> sxid-4.2.ebuild:
Migrate to EAPI 4.
diff --git a/app-admin/sxid/sxid-4.2.ebuild b/app-admin/sxid/sxid-4.2-r1.ebuild
index b24f1f700773..965e1a7bd072 100644
--- a/app-admin/sxid/sxid-4.2.ebuild
+++ b/app-admin/sxid/sxid-4.2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.2.ebuild,v 1.2 2012/08/17 17:10:32 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.2-r1.ebuild,v 1.1 2012/08/18 13:05:33 ago Exp $
EAPI=4
-inherit toolchain-funcs
+inherit autotools
DESCRIPTION="suid, sgid file and directory checking"
HOMEPAGE="http://freshmeat.net/projects/sxid"
@@ -16,20 +16,15 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
RDEPEND="virtual/mailx"
-DEPEND="sys-apps/sed
- sys-devel/gcc
- sys-devel/autoconf"
+DEPEND=""
+
+DOCS=( docs/sxid.{conf,cron}.example )
src_prepare() {
# this is an admin application and really requires root to run correctly
# we need to move the binary to the sbin directory
sed -i s/bindir/sbindir/g source/Makefile.in || die
- tc-export CC
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc docs/sxid.{conf,cron}.example
+ eautoreconf
}
pkg_postinst() {