summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2007-08-06 17:48:41 +0000
committerMasatomo Nakano <nakano@gentoo.org>2007-08-06 17:48:41 +0000
commitedaea377f33023a6bd6d4aa471828f8a5427d18c (patch)
tree2ae4ba9e48c71d65a3387d410cb812cd4a046246 /app-admin
parentalpha/ia64/x86 stable wrt security #187205 (diff)
downloadgentoo-2-edaea377f33023a6bd6d4aa471828f8a5427d18c.tar.gz
gentoo-2-edaea377f33023a6bd6d4aa471828f8a5427d18c.tar.bz2
gentoo-2-edaea377f33023a6bd6d4aa471828f8a5427d18c.zip
Fixed initial owner/permission problem reported in bug #187883.
(Portage version: 2.1.2.11)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/ChangeLog9
-rw-r--r--app-admin/puppet/files/digest-puppet-0.22.4-r13
-rw-r--r--app-admin/puppet/files/digest-puppet-0.23.0-r13
-rw-r--r--app-admin/puppet/puppet-0.22.4-r1.ebuild65
-rw-r--r--app-admin/puppet/puppet-0.23.0-r1.ebuild65
5 files changed, 144 insertions, 1 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index ed06e46fc029..1a5517b1ce81 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.5 2007/07/08 02:17:56 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.6 2007/08/06 17:48:41 nakano Exp $
+
+*puppet-0.23.0-r1 (06 Aug 2007)
+*puppet-0.22.4-r1 (06 Aug 2007)
+
+ 06 Aug 2007; Masatomo Nakano <nakano@gentoo.org> +puppet-0.22.4-r1.ebuild,
+ +puppet-0.23.0-r1.ebuild:
+ Fixed initial owner/permission problem reported in bug #187883.
*puppet-0.23.0 (08 Jul 2007)
diff --git a/app-admin/puppet/files/digest-puppet-0.22.4-r1 b/app-admin/puppet/files/digest-puppet-0.22.4-r1
new file mode 100644
index 000000000000..681135e45b00
--- /dev/null
+++ b/app-admin/puppet/files/digest-puppet-0.22.4-r1
@@ -0,0 +1,3 @@
+MD5 9bb853104f2616c7f2c8fa4e2f39b537 puppet-0.22.4.tgz 642077
+RMD160 c836292dc112e52d32bfdcd68d74799135e9c2e9 puppet-0.22.4.tgz 642077
+SHA256 7b26b50711c89ca1e1c12967a363c6f0bc6c04ddcd741358f74c107d04352042 puppet-0.22.4.tgz 642077
diff --git a/app-admin/puppet/files/digest-puppet-0.23.0-r1 b/app-admin/puppet/files/digest-puppet-0.23.0-r1
new file mode 100644
index 000000000000..25992bc96a0e
--- /dev/null
+++ b/app-admin/puppet/files/digest-puppet-0.23.0-r1
@@ -0,0 +1,3 @@
+MD5 c43342d7d24f1fe881ec97b59e7ea02d puppet-0.23.0.tgz 670293
+RMD160 7f8cb3152f9fe8587b3fc8a09710dbcbfbb3a001 puppet-0.23.0.tgz 670293
+SHA256 cd6959815e08ebc5e24cc49acefa4d4c5f4b277a0e75498d0ec48a4229c8ee4a puppet-0.23.0.tgz 670293
diff --git a/app-admin/puppet/puppet-0.22.4-r1.ebuild b/app-admin/puppet/puppet-0.22.4-r1.ebuild
new file mode 100644
index 000000000000..393e71eba7ab
--- /dev/null
+++ b/app-admin/puppet/puppet-0.22.4-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.22.4-r1.ebuild,v 1.1 2007/08/06 17:48:41 nakano Exp $
+
+inherit eutils ruby
+
+DESCRIPTION="A system automation and configuration management software"
+LICENSE="GPL-2"
+HOMEPAGE="http://reductivelabs.com/projects/puppet/index.html"
+SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
+RDEPEND=">=dev-ruby/facter-1.3.5 >=app-portage/eix-0.9.4"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+
+USE_RUBY="ruby18"
+
+pkg_setup() {
+ built_with_use virtual/ruby ipv6 || \
+ die "Ruby must be built with ipv6 support, otherwise puppet will not be able to run"
+
+ enewgroup puppet || die "Problem creating group puppet"
+ enewuser puppet -1 -1 /var/lib/puppet puppet || die "Problem creating user puppet"
+}
+
+src_compile() {
+ DESTDIR=${D} ruby_econf || die
+ DESTDIR=${D} ruby_emake "$@" || die
+}
+
+src_install() {
+ DESTDIR=${D} ruby_einstall "$@" || die
+ DESTDIR=${D} erubydoc
+
+ # Installation of init scripts and configuration
+ doinitd ${S}/conf/gentoo/init.d/puppetmaster
+ doconfd ${S}/conf/gentoo/conf.d/puppetmaster
+ doinitd ${S}/conf/gentoo/init.d/puppet
+ doconfd ${S}/conf/gentoo/conf.d/puppet
+
+ # Initial configuration files
+ dodir /etc/puppet/manifests
+ insinto /etc/puppet
+ doins ${S}/conf/gentoo/puppet/*
+
+ # Location of log and data files
+ dodir /var/log/puppet
+ dodir /var/lib/puppet
+ dodir /var/lib/puppet/ssl
+ keepdir /var/run/puppet
+ keepdir /var/lib/puppet/ssl
+ chown puppet ${D}/var/run/puppet
+}
+
+pkg_postinst() {
+ ewarn "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could cause puppet to hang"
+ ewarn "while installing packages."
+ ewarn
+ ewarn "Puppet uses eix to get information about currently installed packages, so please keep the eix"
+ ewarn "metadata cache updated so puppet is able to properly handle package installations."
+ ewarn
+ ewarn "Currently puppet only supports adding and removing services to the default runlevel, if you"
+ ewarn "want to add/remove a service from another runlevel you may do so using symlinking."
+}
diff --git a/app-admin/puppet/puppet-0.23.0-r1.ebuild b/app-admin/puppet/puppet-0.23.0-r1.ebuild
new file mode 100644
index 000000000000..0312d8ebac21
--- /dev/null
+++ b/app-admin/puppet/puppet-0.23.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.23.0-r1.ebuild,v 1.1 2007/08/06 17:48:41 nakano Exp $
+
+inherit eutils ruby
+
+DESCRIPTION="A system automation and configuration management software"
+LICENSE="GPL-2"
+HOMEPAGE="http://reductivelabs.com/projects/puppet/index.html"
+SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
+RDEPEND=">=dev-ruby/facter-1.3.5 >=app-portage/eix-0.9.4"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+
+USE_RUBY="ruby18"
+
+pkg_setup() {
+ built_with_use virtual/ruby ipv6 || \
+ die "Ruby must be built with ipv6 support, otherwise puppet will not be able to run"
+
+ enewgroup puppet || die "Problem creating group puppet"
+ enewuser puppet -1 -1 /var/lib/puppet puppet || die "Problem creating user puppet"
+}
+
+src_compile() {
+ DESTDIR=${D} ruby_econf || die
+ DESTDIR=${D} ruby_emake "$@" || die
+}
+
+src_install() {
+ DESTDIR=${D} ruby_einstall "$@" || die
+ DESTDIR=${D} erubydoc
+
+ # Installation of init scripts and configuration
+ doinitd ${S}/conf/gentoo/init.d/puppetmaster
+ doconfd ${S}/conf/gentoo/conf.d/puppetmaster
+ doinitd ${S}/conf/gentoo/init.d/puppet
+ doconfd ${S}/conf/gentoo/conf.d/puppet
+
+ # Initial configuration files
+ dodir /etc/puppet/manifests
+ insinto /etc/puppet
+ doins ${S}/conf/gentoo/puppet/*
+
+ # Location of log and data files
+ dodir /var/log/puppet
+ dodir /var/lib/puppet
+ dodir /var/lib/puppet/ssl
+ keepdir /var/run/puppet
+ keepdir /var/lib/puppet/ssl
+ chown puppet ${D}/var/run/puppet
+}
+
+pkg_postinst() {
+ ewarn "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could cause puppet to hang"
+ ewarn "while installing packages."
+ ewarn
+ ewarn "Puppet uses eix to get information about currently installed packages, so please keep the eix"
+ ewarn "metadata cache updated so puppet is able to properly handle package installations."
+ ewarn
+ ewarn "Currently puppet only supports adding and removing services to the default runlevel, if you"
+ ewarn "want to add/remove a service from another runlevel you may do so using symlinking."
+}