summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-02-11 16:43:38 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-02-11 16:43:38 +0000
commitfba9d781b1694580b059b499a411d5006ef712a2 (patch)
treec63b672affe35fc4d61e46f8273ad77ff310541d /app-admin
parentBump to 3.4.15, clean old (diff)
downloadgentoo-2-fba9d781b1694580b059b499a411d5006ef712a2.tar.gz
gentoo-2-fba9d781b1694580b059b499a411d5006ef712a2.tar.bz2
gentoo-2-fba9d781b1694580b059b499a411d5006ef712a2.zip
update of puppet to 3.1.0 for bug 456274
(Portage version: 2.1.11.50/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/ChangeLog7
-rw-r--r--app-admin/puppet/puppet-3.1.0.ebuild158
2 files changed, 164 insertions, 1 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index 7727d685c954..906631ea675f 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.139 2013/02/09 01:00:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.140 2013/02/11 16:43:38 prometheanfire Exp $
+
+*puppet-3.1.0 (11 Feb 2013)
+
+ 11 Feb 2013; Matthew Thode <prometheanfire@gentoo.org> +puppet-3.1.0.ebuild:
+ upating puppet to 3.1 for bug 456274
09 Feb 2013; Matthew Thode <prometheanfire@gentoo.org>
puppet-2.7.18-r1.ebuild, puppet-2.7.19-r1.ebuild, puppet-3.0.1-r1.ebuild:
diff --git a/app-admin/puppet/puppet-3.1.0.ebuild b/app-admin/puppet/puppet-3.1.0.ebuild
new file mode 100644
index 000000000000..e3bba48edd53
--- /dev/null
+++ b/app-admin/puppet/puppet-3.1.0.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.1.0.ebuild,v 1.1 2013/02/11 16:43:38 prometheanfire Exp $
+
+EAPI="4"
+
+USE_RUBY="ruby18 ruby19"
+
+inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ >=dev-ruby/facter-1.6.2
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite3? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl"
+
+DEPEND="${DEPEND}
+ ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
+ emacs? ( virtual/emacs )
+ xemacs? ( app-editors/xemacs )"
+RDEPEND="${RDEPEND}
+ ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_compile() {
+ if use emacs ; then
+ elisp-compile ext/emacs/puppet-mode.el
+ fi
+
+ if use xemacs ; then
+ # Create a separate version for xemacs to be able to install
+ # emacs and xemacs in parallel.
+ mkdir ext/xemacs
+ cp ext/emacs/* ext/xemacs/
+ xemacs-elisp-compile ext/xemacs/puppet-mode.el
+ fi
+}
+
+each_ruby_install() {
+ ${RUBY} install.rb --destdir="${D}" install || die
+}
+
+all_ruby_install() {
+ newinitd "${FILESDIR}"/puppet.init-r1 puppet
+
+ # Initial configuration files
+ insinto /etc/puppet
+
+ # Location of log and data files
+ keepdir /var/log/puppet
+ fowners -R puppet:puppet /var/log/puppet
+
+ if use minimal ; then
+ rm "${ED}/etc/puppet/auth.conf"
+ else
+ newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ insinto /etc/puppet
+
+ keepdir /etc/puppet/manifests
+ keepdir /etc/puppet/modules
+
+ keepdir /var/lib/puppet/ssl
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+ fi
+
+ if use emacs ; then
+ elisp-install ${PN} ext/emacs/puppet-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use xemacs ; then
+ xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
+ xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Puppet uses eix to get information about currently installed packages,"
+ elog "so please keep the eix metadata cache updated so puppet is able to properly"
+ elog "handle package installations."
+ elog
+ elog "Currently puppet only supports adding and removing services to the default"
+ elog "runlevel, if you want to add/remove a service from another runlevel you may"
+ elog "do so using symlinking."
+ elog
+
+ if [ \
+ -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
+ -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
+ -f "${EPREFIX}/etc/puppet/puppetca.conf" \
+ ] ; then
+ elog
+ elog "Please remove deprecated config files."
+ elog " /etc/puppet/puppetca.conf"
+ elog " /etc/puppet/puppetd.conf"
+ elog " /etc/puppet/puppetmasterd.conf"
+ elog
+ fi
+
+ if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
+ elog
+ elog "If you're upgrading from 2.x then we strongly suggest you to read:"
+ elog "http://docs.puppetlabs.com/guides/upgrading.html"
+ elog
+ fi
+
+ use emacs && elisp-site-regen
+ use xemacs && xemacs-elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use xemacs && xemacs-elisp-site-regen
+}