summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-28 05:26:07 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-28 05:26:07 +0000
commit3649fce9332f8bbba35bddadd1c05236f82ab1e8 (patch)
treeba3e2b1e10568ae673e85ec95b5f31d7b2eb1d67 /app-antivirus/clamav
parentAdd s390/sh love #376587 by Eray Aslan. (diff)
downloadgentoo-2-3649fce9332f8bbba35bddadd1c05236f82ab1e8.tar.gz
gentoo-2-3649fce9332f8bbba35bddadd1c05236f82ab1e8.tar.bz2
gentoo-2-3649fce9332f8bbba35bddadd1c05236f82ab1e8.zip
Fix autotools-utils usage (bug #392135).
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'app-antivirus/clamav')
-rw-r--r--app-antivirus/clamav/ChangeLog5
-rw-r--r--app-antivirus/clamav/clamav-0.97.3.ebuild31
2 files changed, 19 insertions, 17 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index f4937dad5017..3335cf4d3d55 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-antivirus/clamav
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.409 2011/11/27 03:37:41 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.410 2011/11/28 05:26:07 radhermit Exp $
+
+ 28 Nov 2011; Tim Harder <radhermit@gentoo.org> clamav-0.97.3.ebuild:
+ Fix autotools-utils usage (bug #392135).
27 Nov 2011; Tim Harder <radhermit@gentoo.org> clamav-0.97.3.ebuild:
Build in the source tree.
diff --git a/app-antivirus/clamav/clamav-0.97.3.ebuild b/app-antivirus/clamav/clamav-0.97.3.ebuild
index a19914b65b5a..45a8d0471e6d 100644
--- a/app-antivirus/clamav/clamav-0.97.3.ebuild
+++ b/app-antivirus/clamav/clamav-0.97.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.97.3.ebuild,v 1.7 2011/11/27 03:37:41 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.97.3.ebuild,v 1.8 2011/11/28 05:26:07 radhermit Exp $
EAPI=4
@@ -31,7 +31,7 @@ RESTRICT="test"
DOCS=( AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE )
-AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}"/${PN}-0.97-nls.patch )
pkg_setup() {
enewgroup clamav
@@ -39,26 +39,27 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.97-nls.patch
use ppc64 && append-flags -mminimal-toc
+ autotools-utils_src_prepare
}
src_configure() {
- econf \
- --disable-experimental \
- --enable-id-check \
- --with-dbdir=/var/lib/clamav \
- --with-system-tommath \
- $(use_enable bzip2) \
- $(use_enable clamdtop) \
- $(use_enable ipv6) \
- $(use_enable milter) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --disable-experimental
+ --enable-id-check
+ --with-dbdir=/var/lib/clamav
+ --with-system-tommath
+ $(use_enable bzip2)
+ $(use_enable clamdtop)
+ $(use_enable ipv6)
+ $(use_enable milter)
$(use_with iconv)
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
rm -rf "${ED}"/var/lib/clamav
newinitd "${FILESDIR}"/clamd.rc clamd
@@ -75,8 +76,6 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/clamav.logrotate clamav
- remove_libtool_files
-
# Modify /etc/{clamd,freshclam}.conf to be usable out of the box
sed -i -e "s:^\(Example\):\# \1:" \
-e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \