summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2004-06-14 21:01:21 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2004-06-14 21:01:21 +0000
commit49a79798863d39200ed2b22cfdfb3d5fc9cb0557 (patch)
tree72724c84c71419cac8782140532e24a793d7194e /app-antivirus
parentBump (Manifest recommit) (diff)
downloadgentoo-2-49a79798863d39200ed2b22cfdfb3d5fc9cb0557.tar.gz
gentoo-2-49a79798863d39200ed2b22cfdfb3d5fc9cb0557.tar.bz2
gentoo-2-49a79798863d39200ed2b22cfdfb3d5fc9cb0557.zip
version bump
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/Manifest2
-rw-r--r--app-antivirus/clamav/clamav-0.73.ebuild56
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.731
4 files changed, 65 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index b95521289f70..1666f309b960 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.4 2004/06/10 21:00:20 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.5 2004/06/14 21:01:21 lordvan Exp $
+
+*clamav-0.73 (14 Jun 2004)
+
+ 14 Jun 2004; Thomas Raschbacher <lordvan@gentoo.org> +clamav-0.73.ebuild:
+ new version 0.73 added
10 Jun 2004; Thomas Raschbacher <lordvan@gentoo.org> clamav-0.67.ebuild,
clamav-0.68.1.ebuild, clamav-0.70.ebuild, clamav-0.71.ebuild,
diff --git a/app-antivirus/clamav/Manifest b/app-antivirus/clamav/Manifest
index 8045bb045456..b95a75fb4615 100644
--- a/app-antivirus/clamav/Manifest
+++ b/app-antivirus/clamav/Manifest
@@ -1,5 +1,6 @@
MD5 86441a1d4dddcb16cf2511f0eaa5bc14 clamav-0.71.ebuild 1582
MD5 c740246ef7d380cd8d1437787020a61d clamav-0.67.ebuild 1475
+MD5 a046cf4d141b700fd8d36cfc9c212ed8 clamav-0.73.ebuild 1582
MD5 630aa48eaaa0ade8d6ca7f6f4d3b3d42 clamav-0.70.ebuild 1576
MD5 a046cf4d141b700fd8d36cfc9c212ed8 clamav-0.72.ebuild 1582
MD5 a959ae9c436948f302bbf99849ce88f9 ChangeLog 5675
@@ -11,5 +12,6 @@ MD5 a2d9e93fa7b5c61bbf79bdf79d3706e5 files/digest-clamav-0.67 64
MD5 747929a7025eda197fe5af2143f97a64 files/digest-clamav-0.70 64
MD5 4506954e47cda8c123e25422e146d732 files/digest-clamav-0.71 64
MD5 2c7f2f8b0a3e7d16ecc154dd129188e3 files/digest-clamav-0.72 64
+MD5 50b576f5cc3976c6bc0d9aa11a2d25a3 files/digest-clamav-0.73 64
MD5 e8dcbdecd955708ddc7c79399ffa6276 files/clamd.conf 166
MD5 80a677a25d57280cf6de5c1a1da96510 files/clamd.rc 1393
diff --git a/app-antivirus/clamav/clamav-0.73.ebuild b/app-antivirus/clamav/clamav-0.73.ebuild
new file mode 100644
index 000000000000..4c65017dc786
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.73.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.73.ebuild,v 1.1 2004/06/14 21:01:21 lordvan Exp $
+
+inherit eutils flag-o-matic
+
+#MY_P="${PN}-0.70-rc"
+MY_P="${P}"
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/clamav/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
+IUSE="milter crypt"
+
+DEPEND="virtual/glibc
+ crypt? ( >=dev-libs/gmp-4.1.2 )"
+PROVIDE="virtual/antivirus"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup clamav
+ enewuser clamav -1 /bin/false /dev/null clamav
+ pwconv || die
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+ local myconf
+ use milter && myconf="--enable-milter"
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog TODO FAQ INSTALL
+ exeinto /etc/init.d ; newexe ${FILESDIR}/clamd.rc clamd
+ insinto /etc/conf.d ; newins ${FILESDIR}/clamd.conf clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+}
+
+pkg_postinst() {
+ einfo ""
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ einfo ""
+ if use milter ; then
+ einfo "For simple instructions howto setup the clamav-milter..."
+ einfo ""
+ einfo "less /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ fi
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.73 b/app-antivirus/clamav/files/digest-clamav-0.73
new file mode 100644
index 000000000000..3101d1151e3b
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.73
@@ -0,0 +1 @@
+MD5 e96f007e9156b41b5f07707e3b004465 clamav-0.73.tar.gz 2646169