summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-01-27 08:39:02 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-01-27 08:39:02 +0000
commitb06a4ec9a8a7dc7fdfaba7fe65e2284779a7ad75 (patch)
tree1540d0827c93dcda06a03abef06b60950b6accfa /app-antivirus
parentEnforce the use of CFLAGS, #79655 reported by Stefan Briesenick <sbriesen@gmx... (diff)
downloadgentoo-2-b06a4ec9a8a7dc7fdfaba7fe65e2284779a7ad75.tar.gz
gentoo-2-b06a4ec9a8a7dc7fdfaba7fe65e2284779a7ad75.tar.bz2
gentoo-2-b06a4ec9a8a7dc7fdfaba7fe65e2284779a7ad75.zip
Version bump. Disabled milter useflag. "provide antivirus" in initscript.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog9
-rw-r--r--app-antivirus/clamav/clamav-0.81.ebuild64
-rw-r--r--app-antivirus/clamav/files/clamd.rc3
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.811
4 files changed, 75 insertions, 2 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index e9b472d6bc74..9157f58c361b 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.34 2005/01/26 21:27:40 kaiowas Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.35 2005/01/27 08:39:02 ticho Exp $
+
+*clamav-0.81 (27 Jan 2005)
+
+ 27 Jan 2005; Andrej Kacian <ticho@gentoo.org> files/clamd.rc,
+ +clamav-0.81.ebuild:
+ Version bump. Added "provide antivirus" to the initscript. Disabled milter
+ useflag, since it requires libmilter, which is not in portage.
26 Jan 2005; petre rodan <kaiowas@gentoo.org> clamav-0.75.1.ebuild,
clamav-0.80.ebuild, clamav-0.81_rc1.ebuild:
diff --git a/app-antivirus/clamav/clamav-0.81.ebuild b/app-antivirus/clamav/clamav-0.81.ebuild
new file mode 100644
index 000000000000..c2ebeb1c52d4
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.81.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.81.ebuild,v 1.1 2005/01/27 08:39:02 ticho Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/clamav/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~hppa ~alpha ~ppc64"
+IUSE="crypt selinux"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )"
+RDEPEND="selinux? ( sec-policy/selinux-clamav )"
+PROVIDE="virtual/antivirus"
+
+#S="${WORKDIR}/${P/_/}"
+
+pkg_setup() {
+ enewgroup clamav
+ enewuser clamav -1 /bin/false /dev/null clamav
+ pwconv || die
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # Disabled milter useflag, since it needs libmilter, which is not in portage
+ # - ticho (2005-01-27)
+ #use milter && myconf="--enable-milter"
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog TODO FAQ INSTALL
+ exeinto /etc/init.d ; newexe ${FILESDIR}/clamd.rc clamd
+ insinto /etc/conf.d ; newins ${FILESDIR}/clamd.conf clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+}
+
+pkg_postinst() {
+ echo
+ einfo "NOTE: As of clamav-0.80, the config file for clamd is no longer"
+ einfo " /etc/clamav.conf, but /etc/clamd.conf. Adjust your"
+ einfo " configuration accordingly before (re)starting clamd."
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ #if use milter ; then
+ # einfo "For simple instructions howto setup the clamav-milter..."
+ # einfo ""
+ # einfo "less /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ # echo
+ #fi
+}
diff --git a/app-antivirus/clamav/files/clamd.rc b/app-antivirus/clamav/files/clamd.rc
index 0e65a409b398..dc0f3b94e9a3 100644
--- a/app-antivirus/clamav/files/clamd.rc
+++ b/app-antivirus/clamav/files/clamd.rc
@@ -1,10 +1,11 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/files/clamd.rc,v 1.5 2005/01/25 11:21:50 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/files/clamd.rc,v 1.6 2005/01/27 08:39:02 ticho Exp $
depend() {
use net
+ provide antivirus
}
start() {
diff --git a/app-antivirus/clamav/files/digest-clamav-0.81 b/app-antivirus/clamav/files/digest-clamav-0.81
new file mode 100644
index 000000000000..760e821106c1
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.81
@@ -0,0 +1 @@
+MD5 60081ddd9f29cbb8f0a2fe575e5a8afa clamav-0.81.tar.gz 3347423