summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-15 09:21:43 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-15 09:21:43 +0000
commit297e1607eb5b712e9386f0c0e732399292176ee4 (patch)
tree3e5e7040a03b876e1fa4bb01880ac95c2c593192 /app-arch/dar
parentFirst version in portage, as requested and helped out in bug #32681 (Manifest... (diff)
downloadgentoo-2-297e1607eb5b712e9386f0c0e732399292176ee4.tar.gz
gentoo-2-297e1607eb5b712e9386f0c0e732399292176ee4.tar.bz2
gentoo-2-297e1607eb5b712e9386f0c0e732399292176ee4.zip
add -fno-unit-at-a-time if using gcc 3.4. fixes bug 51838
Diffstat (limited to 'app-arch/dar')
-rw-r--r--app-arch/dar/ChangeLog5
-rw-r--r--app-arch/dar/dar-2.1.3.ebuild6
2 files changed, 9 insertions, 2 deletions
diff --git a/app-arch/dar/ChangeLog b/app-arch/dar/ChangeLog
index fc2340383870..4e3845e49297 100644
--- a/app-arch/dar/ChangeLog
+++ b/app-arch/dar/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/dar
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dar/ChangeLog,v 1.12 2004/06/29 03:29:41 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dar/ChangeLog,v 1.13 2004/07/15 09:21:43 lv Exp $
+
+ 15 Jul 2004; Travis Tilley <lv@gentoo.org> dar-2.1.3.ebuild:
+ add -fno-unit-at-a-time if using gcc 3.4. fixes bug 51838
*dar-2.1.3 (29 Jun 2004)
diff --git a/app-arch/dar/dar-2.1.3.ebuild b/app-arch/dar/dar-2.1.3.ebuild
index 9bed88e84a9a..8ae9fea37e2d 100644
--- a/app-arch/dar/dar-2.1.3.ebuild
+++ b/app-arch/dar/dar-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dar/dar-2.1.3.ebuild,v 1.1 2004/06/29 03:29:41 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dar/dar-2.1.3.ebuild,v 1.2 2004/07/15 09:21:43 lv Exp $
inherit flag-o-matic libtool
@@ -25,6 +25,10 @@ src_unpack() {
autoreconf
einfo "Running libtoolize..."
elibtoolize
+
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]; then
+ append-flags -fno-unit-at-a-time
+ fi
}
src_compile() {