summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-22 22:04:35 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-22 22:04:35 +0000
commitaefc4a564efe71f976a59d3fd1d40829da2b3ce9 (patch)
treeb1a630848867b11cec296597be9c55431ff56cce /app-arch/gzip
parentInitial import (diff)
downloadgentoo-2-aefc4a564efe71f976a59d3fd1d40829da2b3ce9.tar.gz
gentoo-2-aefc4a564efe71f976a59d3fd1d40829da2b3ce9.tar.bz2
gentoo-2-aefc4a564efe71f976a59d3fd1d40829da2b3ce9.zip
Fix building with glibc-2.16+.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/gzip')
-rw-r--r--app-arch/gzip/ChangeLog6
-rw-r--r--app-arch/gzip/files/gzip-1.4-no-gets.patch22
-rw-r--r--app-arch/gzip/gzip-1.4.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/app-arch/gzip/ChangeLog b/app-arch/gzip/ChangeLog
index 6e2a33666088..3e883580dfd4 100644
--- a/app-arch/gzip/ChangeLog
+++ b/app-arch/gzip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/gzip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.112 2012/04/26 19:25:30 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.113 2012/05/22 22:04:35 vapier Exp $
+
+ 22 May 2012; Mike Frysinger <vapier@gentoo.org> +files/gzip-1.4-no-gets.patch,
+ gzip-1.4.ebuild:
+ Fix building with glibc-2.16+.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> gzip-1.4.ebuild:
keyword ~amd64-fbsd
diff --git a/app-arch/gzip/files/gzip-1.4-no-gets.patch b/app-arch/gzip/files/gzip-1.4-no-gets.patch
new file mode 100644
index 000000000000..6da6e64bb7fd
--- /dev/null
+++ b/app-arch/gzip/files/gzip-1.4-no-gets.patch
@@ -0,0 +1,22 @@
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
diff --git a/app-arch/gzip/gzip-1.4.ebuild b/app-arch/gzip/gzip-1.4.ebuild
index 5d0b93f8d116..87373ae1f95a 100644
--- a/app-arch/gzip/gzip-1.4.ebuild
+++ b/app-arch/gzip/gzip-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.4.ebuild,v 1.10 2012/04/26 19:25:30 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.4.ebuild,v 1.11 2012/05/22 22:04:35 vapier Exp $
inherit eutils flag-o-matic
@@ -25,6 +25,7 @@ src_unpack() {
#epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
epatch "${FILESDIR}"/${P}-assembler.patch #309079
+ epatch "${FILESDIR}"/${P}-no-gets.patch
}
src_compile() {