summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-27 07:14:05 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-27 07:14:05 +0000
commitf91f5321cf716e7032f90c3f51d794a8731aef7f (patch)
tree7c12b28cf3d68768b14fc1094035c166d2a17d11 /app-arch/lbzip2
parentsci-mathematics/pari: Drop old (diff)
downloadgentoo-2-f91f5321cf716e7032f90c3f51d794a8731aef7f.tar.gz
gentoo-2-f91f5321cf716e7032f90c3f51d794a8731aef7f.tar.bz2
gentoo-2-f91f5321cf716e7032f90c3f51d794a8731aef7f.zip
app-arch/lbzip2: Drop old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-arch/lbzip2')
-rw-r--r--app-arch/lbzip2/ChangeLog7
-rw-r--r--app-arch/lbzip2/files/lbzip2-2.2-assertion.patch107
-rw-r--r--app-arch/lbzip2/files/lbzip2-2.2-s_isreg.patch16
-rw-r--r--app-arch/lbzip2/lbzip2-2.2-r1.ebuild38
-rw-r--r--app-arch/lbzip2/lbzip2-2.3.ebuild35
5 files changed, 6 insertions, 197 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index cc3018c0c231..91061c9da219 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.67 2014/01/26 12:10:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.68 2014/01/27 07:14:05 jlec Exp $
+
+ 27 Jan 2014; Justin Lecher <jlec@gentoo.org> -lbzip2-2.2-r1.ebuild,
+ -lbzip2-2.3.ebuild, -files/lbzip2-2.2-assertion.patch,
+ -files/lbzip2-2.2-s_isreg.patch:
+ Drop old
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> lbzip2-2.3-r1.ebuild:
Stable for sparc, wrt bug #495322
diff --git a/app-arch/lbzip2/files/lbzip2-2.2-assertion.patch b/app-arch/lbzip2/files/lbzip2-2.2-assertion.patch
deleted file mode 100644
index b4946175b947..000000000000
--- a/app-arch/lbzip2/files/lbzip2-2.2-assertion.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-From 57eeee36927f8a40ece1ca06c674e0bd56d0f21f Mon Sep 17 00:00:00 2001
-Message-Id: <57eeee36927f8a40ece1ca06c674e0bd56d0f21f.1358019732.git.jlec@gentoo.org>
-From: Mikolaj Izdebski <zurgunt@gmail.com>
-Date: Sat, 20 Oct 2012 18:37:17 +0200
-Subject: [PATCH] Fix assertion failure, closes #8
-
-src/encode.c (generate_initial_trees): Rewrite from scratch.
----
- src/encode.c | 61 +++++++++++++++++++++++++++++++++++++++++++++++-------------
- 1 file changed, 48 insertions(+), 13 deletions(-)
-
-diff --git a/src/encode.c b/src/encode.c
-index 09cfacc..00a78dc 100644
---- a/src/encode.c
-+++ b/src/encode.c
-@@ -763,40 +763,75 @@ assign_codes(uint32_t C[], uint32_t L[], uint8_t B[], uint32_t n)
-
- /* Create initial mapping of symbols to trees.
-
-- The goal is to divide all as symbols [0,as) into nt equivalence classes
-+ The goal is to divide all as symbols [0,as) into nt equivalence classes (EC)
- [0,nt) such that standard deviation of symbol frequencies in classes is
- minimal. We use a kind of a heuristic to achieve that. There might exist a
- better way to achieve that, but this one seems to be good (and fast) enough.
-
- If the symbol v belongs to the equivalence class t then set s->length[t][v]
- to zero. Otherwise set it to 1.
--
-- TODO: This piece of code really needs some R&D...
- */
- static void
- generate_initial_trees(struct encoder_state *s, unsigned nm, unsigned nt)
- {
-- unsigned a, b, c, t;
--
-- /* Equivalence classes are empty. */
-+ unsigned a, b; /* range [a,b) of symbols forming current EC */
-+ unsigned freq; /* symbol frequency */
-+ unsigned cum; /* cumulative frequency */
-+ unsigned as; /* effective alphabet size (alphabet size minus number
-+ of symbols with frequency equal to zero) */
-+ unsigned t; /* current tree */
-+
-+ /* Equivalence classes are initially empty. */
- memset(s->length, 1, sizeof(s->length));
-
-+ /* Determine effective alphabet size. */
-+ as = 0;
-+ for (a = 0, cum = 0; cum < nm; a++) {
-+ freq = s->lookup[0][a];
-+ cum += freq;
-+ as += min(freq, 1);
-+ }
-+ assert(cum == nm);
-+
-+ /* Bound number of EC by number of symbols. Each EC is non-empty, so number
-+ of symbol EC must be <= number of symbols. */
-+ nt = min(nt, as);
-+
- /* For each equivalence class: */
-- for (a = 0, t = 0; t < nt; t++) {
-+ a = 0;
-+ for (t = 0; nt > 0; t++, nt--) {
-+ assert(nm > 0);
-+ assert(as >= nt);
-+
- /* Find a range of symbols which total count is roughly proportional to one
- nt-th of all values. */
-- for (c = 0, b = a; c * (nt-t) < nm; b++)
-- c += s->lookup[0][b];
-- assert(a < b);
-- if (a < b-1 && (2*c - s->lookup[0][b-1]) * (nt-t) > 2*nm) {
-- c -= s->lookup[0][--b];
-+ freq = s->lookup[0][a];
-+ cum = freq;
-+ as -= min(freq, 1);
-+ b = a+1;
-+ while (as > nt-1 && cum * nt < nm) {
-+ freq = s->lookup[0][b];
-+ cum += freq;
-+ as -= min(freq, 1);
-+ b++;
- }
-- nm -= c;
-+ if (cum > freq && (2*cum - freq) * nt > 2*nm) {
-+ cum -= freq;
-+ as += min(freq, 1);
-+ b--;
-+ }
-+ assert(a < b);
-+ assert(cum > 0);
-+ assert(cum <= nm);
-+ assert(as >= nt-1);
-+ Trace(("Tree %u: EC=[%3u,%3u), |EC|=%3u, cum=%6u", t, a, b, b-a, cum));
-
- /* Now [a,b) is our range -- assign it to equivalence class t. */
- bzero(&s->length[t][a], b - a);
- a = b;
-+ nm -= cum;
- }
-+ assert(as == 0);
- assert(nm == 0);
- }
-
---
-1.8.1
-
diff --git a/app-arch/lbzip2/files/lbzip2-2.2-s_isreg.patch b/app-arch/lbzip2/files/lbzip2-2.2-s_isreg.patch
deleted file mode 100644
index c67b134b5795..000000000000
--- a/app-arch/lbzip2/files/lbzip2-2.2-s_isreg.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- src/main.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/main.c b/src/main.c
-index f030fd5..5f8290e 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -702,7 +702,7 @@ input_init(const struct arg *operand, struct stat *sbuf)
- return -1;
- }
-
-- if (!S_ISREG(sbuf->st_mode)) {
-+ if (!decompress && !S_ISREG(sbuf->st_mode)) {
- warn("skipping \"%s\": not a regular file", operand->val);
- return -1;
- }
diff --git a/app-arch/lbzip2/lbzip2-2.2-r1.ebuild b/app-arch/lbzip2/lbzip2-2.2-r1.ebuild
deleted file mode 100644
index 0ed9305c387c..000000000000
--- a/app-arch/lbzip2/lbzip2-2.2-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.2-r1.ebuild,v 1.12 2013/06/02 08:37:27 ago Exp $
-
-EAPI=4
-
-inherit autotools-utils
-
-DESCRIPTION="Parallel bzip2 utility"
-HOMEPAGE="https://github.com/kjn/lbzip2/"
-SRC_URI="mirror://github/kjn/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="debug symlink"
-
-PATCHES=(
- "${FILESDIR}"/${P}-s_isreg.patch
- "${FILESDIR}"/${P}-assertion.patch
- )
-
-RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
-DEPEND=""
-
-src_configure() {
- local myeconfargs=(
- --disable-silent-rules
- $(use_enable debug tracing)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- use symlink && dosym ${PN} /usr/bin/bzip2
-}
diff --git a/app-arch/lbzip2/lbzip2-2.3.ebuild b/app-arch/lbzip2/lbzip2-2.3.ebuild
deleted file mode 100644
index c45db5b54ec9..000000000000
--- a/app-arch/lbzip2/lbzip2-2.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.3.ebuild,v 1.1 2013/09/23 11:18:45 jlec Exp $
-
-EAPI=5
-
-inherit autotools-utils
-
-DESCRIPTION="Parallel bzip2 utility"
-HOMEPAGE="https://github.com/kjn/lbzip2/"
-SRC_URI="http://archive.lbzip2.org/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="debug symlink"
-
-PATCHES=( "${FILESDIR}"/${P}-s_isreg.patch )
-
-RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
-DEPEND=""
-
-src_configure() {
- local myeconfargs=(
- --disable-silent-rules
- $(use_enable debug tracing)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- use symlink && dosym ${PN} /usr/bin/bzip2
-}