summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-26 22:53:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-26 22:53:41 +0000
commitb6ffae80b94c342f2e5517061ddde210c845839e (patch)
treed6160f94a919c8d63ae378b9ddabc763777b5aa7 /app-arch/libarchive
parentVersion bump (diff)
downloadgentoo-2-b6ffae80b94c342f2e5517061ddde210c845839e.tar.gz
gentoo-2-b6ffae80b94c342f2e5517061ddde210c845839e.tar.bz2
gentoo-2-b6ffae80b94c342f2e5517061ddde210c845839e.zip
Version bump.
(Portage version: 2.2_rc19/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'app-arch/libarchive')
-rw-r--r--app-arch/libarchive/ChangeLog8
-rw-r--r--app-arch/libarchive/libarchive-2.5.905a.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/app-arch/libarchive/ChangeLog b/app-arch/libarchive/ChangeLog
index 9eeb0ac6044c..bb4afe69be14 100644
--- a/app-arch/libarchive/ChangeLog
+++ b/app-arch/libarchive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/libarchive
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.35 2008/12/11 18:41:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.36 2008/12/26 22:53:41 flameeyes Exp $
+
+*libarchive-2.5.905a (26 Dec 2008)
+
+ 26 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libarchive-2.5.905a.ebuild:
+ Version bump.
*libarchive-2.5.904a (11 Dec 2008)
diff --git a/app-arch/libarchive/libarchive-2.5.905a.ebuild b/app-arch/libarchive/libarchive-2.5.905a.ebuild
new file mode 100644
index 000000000000..90103620f474
--- /dev/null
+++ b/app-arch/libarchive/libarchive-2.5.905a.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.5.905a.ebuild,v 1.1 2008/12/26 22:53:41 flameeyes Exp $
+
+EAPI=1
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="static acl xattr kernel_linux +bzip2 +lzma +zlib"
+
+COMPRESS_LIBS_DEPEND="lzma? ( app-arch/lzma-utils )
+ bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( ${COMPRESS_LIBS_DEPEND} )"
+DEPEND="${RDEPEND}
+ ${COMPRESS_LIBS_DEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if ! use static ; then
+ myconf="--enable-bsdtar=shared --enable-bsdcpio=shared"
+ fi
+
+ econf --bindir=/bin \
+ --enable-bsdtar --enable-bsdcpio \
+ $(use_enable acl) $(use_enable xattr) \
+ $(use_with zlib) \
+ $(use_with bzip2 bz2lib) $(use_with lzma lzmadec) \
+ ${myconf} \
+ --disable-dependency-tracking || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+
+ dodoc NEWS README
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}